Problem with FastCgi and RHEL4 (CentOS4.1) - the "Almost There" page

I am trying to setup rt-3.4.2 on a RHEL4 box. I have found quite a few
people with similar problems on the mailing list - but no solutions have
fixed the problem.

I get the “You’re almost there!” web page, stating that I haven’t setup
the webserver configuration to use RT’s fastcgi handler.

httpd.conf
FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 120
ScriptAlias /rt /opt/rt3/bin/mason_handler.fcgi

NameVirtualHost *:80
<VirtualHost *:80>
ServerName darg.twt.com
ServerAdmin root
DocumentRoot /opt/rt3/share/html/
#DocumentRoot /var/www/html/

Adding the following for RT (the ticket tracker)

AddHandler fastcgi-script fcgi
ErrorLog /var/log/httpd/httpd-rt-error.log
CustomLog /var/log/httpd/httpd-rt.log common
<Directory “/opt/rt3/share/html”>
Options FollowSymLinks ExecCGI
AllowOverride None

<Location /rt/NoAuth/images >
SetHandler default-handler

Pass through requests to display images

Alias /NoAuth/images/ /opt/rt3/share/html/NoAuth/images/

RT_SiteConfig.pm
Set($WebPath , “/rt”);
Set($WebBaseURL , “http://172.20.66.222:80”);
Set($WebURL , $WebBaseURL . $WebPath . “/”);

Running processes:
[root@darg rt-3.4.2]# ps -ef |grep apache
apache 4486 4483 0 10:11 ? 00:00:00 /usr/sbin/fcgi-
apache 4487 4486 4 10:11 ? 00:00:01 /usr/bin/perl
/opt/rt3/bin/mason_handler.fcgi
apache 4488 4483 0 10:11 ? 00:00:00 /usr/sbin/httpd
apache 4489 4483 0 10:11 ? 00:00:00 /usr/sbin/httpd
apache 4490 4483 0 10:11 ? 00:00:00 /usr/sbin/httpd
apache 4491 4483 0 10:11 ? 00:00:00 /usr/sbin/httpd
apache 4492 4483 0 10:11 ? 00:00:00 /usr/sbin/httpd
apache 4493 4483 0 10:11 ? 00:00:00 /usr/sbin/httpd
apache 4494 4483 0 10:11 ? 00:00:00 /usr/sbin/httpd
apache 4495 4483 0 10:11 ? 00:00:00 /usr/sbin/httpd

And the httpd error log:
[root@darg httpd]# cat error_log
[Fri Jun 24 10:14:02 2005] [notice] suEXEC mechanism enabled (wrapper:
/usr/sbin/suexec)
[Fri Jun 24 10:14:02 2005] [notice] Digest: generating secret for digest
authentication …
[Fri Jun 24 10:14:02 2005] [notice] Digest: done
[Fri Jun 24 10:14:02 2005] [notice] LDAP: Built with OpenLDAP LDAP SDK
[Fri Jun 24 10:14:02 2005] [notice] LDAP: SSL support unavailable
[Fri Jun 24 10:14:02 2005] [notice] FastCGI: process manager initialized
(pid 4533)
[Fri Jun 24 10:14:02 2005] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" started (pid 4534)
[Fri Jun 24 10:14:02 2005] [notice] mod_python: Creating 4 session mutexes
based on 256 max processes and 0 max threads.
[Fri Jun 24 10:14:03 2005] [notice] Apache/2.0.52 (CentOS) configured –
resuming normal operations

And here is one more non-working version of httpd.conf (modified per a
recent posting on the message board)
FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 300
-processes 4

NameVirtualHost *:80
<VirtualHost *:80>
ServerName darg.twt.com

ServerAdmin root

DocumentRoot /opt/rt3/share/html/
ErrorLog /var/log/httpd/httpd-rt-error.log
CustomLog /var/log/httpd/httpd-rt.log common

DocumentRoot /var/www/html/

Adding the following for RT (the ticket tracker)

AddHandler fastcgi-script fcgi

Alias /rt/ /opt/rt3/share/html/
Alias /NoAuth/images/ /opt/rt3/share/html/NoAuth/images/
ScriptAlias /rt /opt/rt3/bin/mason_handler.fcgi
<Directory /opt/rt3/bin>
Order allow,deny
Allow from all

<Directory “/opt/rt3/share/html”>
Options FollowSymLinks ExecCGI
AllowOverride None

<Location /rt/NoAuth/images >
SetHandler default-handler

Pass through requests to display images

Any help is appreciated.

thanks
david skrede
skrede@twt.com

Try this if you are using AP2.

apxs -n mod_fastcgi -i -a -c mod_fastcgi.c fcgi_buf.c fcgi_config.c \

fcgi_pm.c fcgi_protocol.c fcgi_util.c

And in the httpd.conf file be sure that the LoadModule path is correct.

LoadModule fastcgi_module modules/mod_fastcgi.so

J.P. Racine
racinejp@vianet.ca-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of
Skrede@TWT.com
Sent: Friday, June 24, 2005 11:40 AM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] Problem with FastCgi and RHEL4 (CentOS4.1) - the
"AlmostThere" page

I am trying to setup rt-3.4.2 on a RHEL4 box. I have found quite a few
people with similar problems on the mailing list - but no solutions have
fixed the problem.

I get the “You’re almost there!” web page, stating that I haven’t setup
the webserver configuration to use RT’s fastcgi handler.

httpd.conf
FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 120
ScriptAlias /rt /opt/rt3/bin/mason_handler.fcgi

NameVirtualHost *:80
<VirtualHost *:80>
ServerName darg.twt.com
ServerAdmin root
DocumentRoot /opt/rt3/share/html/
#DocumentRoot /var/www/html/

Adding the following for RT (the ticket tracker)

AddHandler fastcgi-script fcgi
ErrorLog /var/log/httpd/httpd-rt-error.log
CustomLog /var/log/httpd/httpd-rt.log common
<Directory “/opt/rt3/share/html”>
Options FollowSymLinks ExecCGI
AllowOverride None

<Location /rt/NoAuth/images >
SetHandler default-handler

Pass through requests to display images

Alias /NoAuth/images/ /opt/rt3/share/html/NoAuth/images/

RT_SiteConfig.pm
Set($WebPath , “/rt”);
Set($WebBaseURL , “http://172.20.66.222:80”);
Set($WebURL , $WebBaseURL . $WebPath . “/”);

Running processes:
[root@darg rt-3.4.2]# ps -ef |grep apache
apache 4486 4483 0 10:11 ? 00:00:00 /usr/sbin/fcgi-
apache 4487 4486 4 10:11 ? 00:00:01 /usr/bin/perl
/opt/rt3/bin/mason_handler.fcgi
apache 4488 4483 0 10:11 ? 00:00:00 /usr/sbin/httpd
apache 4489 4483 0 10:11 ? 00:00:00 /usr/sbin/httpd
apache 4490 4483 0 10:11 ? 00:00:00 /usr/sbin/httpd
apache 4491 4483 0 10:11 ? 00:00:00 /usr/sbin/httpd
apache 4492 4483 0 10:11 ? 00:00:00 /usr/sbin/httpd
apache 4493 4483 0 10:11 ? 00:00:00 /usr/sbin/httpd
apache 4494 4483 0 10:11 ? 00:00:00 /usr/sbin/httpd
apache 4495 4483 0 10:11 ? 00:00:00 /usr/sbin/httpd

And the httpd error log:
[root@darg httpd]# cat error_log
[Fri Jun 24 10:14:02 2005] [notice] suEXEC mechanism enabled (wrapper:
/usr/sbin/suexec)
[Fri Jun 24 10:14:02 2005] [notice] Digest: generating secret for digest
authentication …
[Fri Jun 24 10:14:02 2005] [notice] Digest: done
[Fri Jun 24 10:14:02 2005] [notice] LDAP: Built with OpenLDAP LDAP SDK
[Fri Jun 24 10:14:02 2005] [notice] LDAP: SSL support unavailable
[Fri Jun 24 10:14:02 2005] [notice] FastCGI: process manager initialized
(pid 4533)
[Fri Jun 24 10:14:02 2005] [warn] FastCGI: server
"/opt/rt3/bin/mason_handler.fcgi" started (pid 4534)
[Fri Jun 24 10:14:02 2005] [notice] mod_python: Creating 4 session
mutexes based on 256 max processes and 0 max threads.
[Fri Jun 24 10:14:03 2005] [notice] Apache/2.0.52 (CentOS) configured –
resuming normal operations

And here is one more non-working version of httpd.conf (modified per a
recent posting on the message board)
FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 300
-processes 4

NameVirtualHost *:80
<VirtualHost *:80>
ServerName darg.twt.com

ServerAdmin root

DocumentRoot /opt/rt3/share/html/
ErrorLog /var/log/httpd/httpd-rt-error.log
CustomLog /var/log/httpd/httpd-rt.log common

DocumentRoot /var/www/html/

Adding the following for RT (the ticket tracker)

AddHandler fastcgi-script fcgi

Alias /rt/ /opt/rt3/share/html/
Alias /NoAuth/images/ /opt/rt3/share/html/NoAuth/images/
ScriptAlias /rt /opt/rt3/bin/mason_handler.fcgi
<Directory /opt/rt3/bin>
Order allow,deny
Allow from all

<Directory “/opt/rt3/share/html”>
Options FollowSymLinks ExecCGI
AllowOverride None

<Location /rt/NoAuth/images >
SetHandler default-handler

Pass through requests to display images

Any help is appreciated.

thanks
david skrede
skrede@twt.com