Problem with basic configuration of rt-3.8.7 stripping domainname from incoming emails and setting default values

Hi,

I have 2 probably very simple questions:

question 1:
I have a basic auth working with autocreate users.
The usernames are without domainname. It works, I’m happy.

I have a form that does ticket creation via email.
Users are automaticcally created but with the domainname in them. This
make me not so happy :slight_smile:

I tried these settings:
Set($CanonicalizeEmailAddressMatch, ‘@onvz.nl$’);
Set($CanonicalizeEmailAddressReplace, ‘’);

To strip the incoming domainname but it does not work.
What am I missing here?

question 2:
How can I configure RT so that autocreated users (via email form
submission or REMOTE_USER authentication) will have a username 'user’
and an email adres ‘user@domain’?

please help, it’s driving me nuts and I have been reading the
mailinglist archives all day sofar.

kind regards,

Kind regards,
ONVZ Healthinsurance

Jeroen Baten
Consultant
IT Staff dept.

De Molen 66
Postbus 392
3990 GD Houten

Tel: +31 30 639 65 08
Fax: +31 30 639 63 25

Deze e-Mail en de inhoud daarvan is vertrouwelijk. Indien dit bericht niet voor u bestemd is, verzoeken wij u vriendelijk deze e-mail direct aan ons te retourneren en daarna te verwijderen. Openbaarmaking, vermenigvuldiging, verstrekking en/of gebruik door derden van dit e-mail bericht en/of informatie is niet toegestaan. De verzender sluit elke aansprakelijkheid uit in verband met het niet juist, onvolledig of niet tijdig overkomen van de informatie in deze e-mail.

Deze e-mail is gecontroleerd op virussen.

Hi,

I have 2 probably very simple questions:

question 1:

I have a basic auth working with autocreate users.
The usernames are without domainname. It works, I’m happy.

I have a form that does ticket creation via email.
Users are automaticcally created but with the domainname in them. This
make me not so happy :slight_smile:

I tried these settings:
Set($CanonicalizeEmailAddressMatch, ‘@onvz.nl$’);
Set($CanonicalizeEmailAddressReplace, ‘’);

To strip the incoming domainname but it does not work.
What am I missing here?

question 2:

How can I configure RT so that autocreated users (via email form
submission or REMOTE_USER authentication) will have a username 'user’
and an email adres ‘user@domain’?

please help, it’s driving me nuts and I have been reading the
mailinglist archives all day sofar.

kind regards,

Hi Jeroen,

Regarding your second question, that is really not a good idea.
The first part (“user”) is not guaranteed to be unique across
all mail domains. This will result in misdirected tickets when
email addresses containing the same “user” part get dumped in
the first one to log a ticket’s queue.

Regards,
Ken