Problem with attachment size limits

Hi,

I’m running RT 4.0.8, Apache 2.2.24, on CentOS 6.4 (final) with Mysql 5.1.67-1

I cannot attach files larger in size than a couple of hundred kb to tickets.

Yes … I’ve changed made all the upload max size parameters that I’m aware of, restarted apache and restarted the server:

php.ini:
post_max_size = 8M
upload_max_filesize = 4M

conf.d/fcgid.conf:
FcgidMaxRequestLen 4000000

RT_SiteConfig.pm:
Set($MaxAttachmentSize, 10_000_000);
Set($DropLongAttachments, 10_000_000);

Problem persists. Anyone know what I’m missing here?

what’s the mysql max_allowed_packet set to?

Also RT doesn’t use PHP, it’s written in perl so any php setting would
have no effect.
Later,
DarinOn Thu, May 29, 2014 at 4:04 PM, Duncan Napier dgnapier@sfu.ca wrote:

Hi,

I’m running RT 4.0.8, Apache 2.2.24, on CentOS 6.4 (final) with Mysql 5.1.67-1

I cannot attach files larger in size than a couple of hundred kb to tickets.

Yes … I’ve changed made all the upload max size parameters that I’m aware of, restarted apache and restarted the server:

php.ini:
post_max_size = 8M
upload_max_filesize = 4M

conf.d/fcgid.conf:
FcgidMaxRequestLen 4000000

RT_SiteConfig.pm:
Set($MaxAttachmentSize, 10_000_000);
Set($DropLongAttachments, 10_000_000);

Problem persists. Anyone know what I’m missing here?

RT Training - Boston, September 9-10
Training — Best Practical Solutions

Hi,

It was 1 Mb. I upped it to 4 Mb in my.cnf and everything is now good. Thanks a lot!

                             Duncan.----- Original Message -----

what’s the mysql max_allowed_packet set to?

Also RT doesn’t use PHP, it’s written in perl so any php setting
would
have no effect.

Later,
Darin

On Thu, May 29, 2014 at 4:04 PM, Duncan Napier dgnapier@sfu.ca wrote:

Hi,

I’m running RT 4.0.8, Apache 2.2.24, on CentOS 6.4 (final) with
Mysql 5.1.67-1

I cannot attach files larger in size than a couple of hundred kb to
tickets.

Yes … I’ve changed made all the upload max size parameters that
I’m aware of, restarted apache and restarted the server:

php.ini:
post_max_size = 8M
upload_max_filesize = 4M

conf.d/fcgid.conf:
FcgidMaxRequestLen 4000000

RT_SiteConfig.pm:
Set($MaxAttachmentSize, 10_000_000);
Set($DropLongAttachments, 10_000_000);

Problem persists. Anyone know what I’m missing here?

RT Training - Boston, September 9-10
Training — Best Practical Solutions

It was 1 Mb. I upped it to 4 Mb in my.cnf and everything
is now good. Thanks a lot!

RT already explicitly warns during database setup, as well as during
server startup, if the max_allowed_packet is 1M or less. Always read
the warning messages, and check your Apache error logs!

  • Alex

The only errors I found in the Apache log were the mod_fastcgi errors, as the default upload size for fastCGI is 128K. Once I upped that, the errors went away, but uploads were still for failing uploads > 1 Mb. Unfortunately, the mySQL packet errors don’t appear in the Apache error logs.

                                             Duncan.----- Original Message -----

On 05/29/2014 04:42 PM, Duncan Napier wrote:

It was 1 Mb. I upped it to 4 Mb in my.cnf and everything
is now good. Thanks a lot!

RT already explicitly warns during database setup, as well as during
server startup, if the max_allowed_packet is 1M or less. Always read
the warning messages, and check your Apache error logs!

  • Alex

Submit IT support requests for MBB to
http://at.sfu.ca/ohIkbR
Regards,

                             Duncan.

Duncan Napier
duncan_napier@sfu.ca
http://www.sfu.ca/~dgnapier/
IT Consultant
Faculty of Science
Simon Fraser University

“It takes ten years to become good at being a kid. Then another ten years
to become good at not being a kid” - Larry Wall.

The only errors I found in the Apache log were the mod_fastcgi errors

Ah – I failed to notice you’re still on 4.0.8; the warnings I
referenced appeared in 4.0.12.

  • Alex