Problem using fast-cgi and external auth, htaccess


I’ve successfully installed and configured RT3.0.10 and wish to use it
as our primary Helpdesk application.

I want RT3 to use Apache’s authenticated username for RT. We’re using a
simple .htaccess/.htpasswd setup with user details derived from another
system and kept synced.

My problem is that I cannot seem to get things working with both
fast-cgi/mason AND .htaccess!

If I have my httpd.conf configured correctly for a .htaccess file in
/usr/local/rt3/share/html, Apache will NOT authenticate users UNTIL I
comment out, or otherwise stuff up the line below in httpd.conf:

ScriptAlias / /usr/local/rt3/bin/mason_handler.fcgi/

If I change the Scriptalias line above, RT breaks. The best I’ve
achieved is to get the login screen to display after successfully
authenticating to apache, but once logged in, I just get a page of
code/junk. Even this is not so great, as I shouldn’t get the login
screen at all with WebExternalAuth set.

I can get either .htaccess or RT to work, but not both at once.

Some background, the whole point of this exercise is that I would like
to allow our users to email requests in, but to prevent problems with
changing email addresses, spam etc. I think the path I’m on will enable
me to set things up so users can go to the RT Web UI after being
authenticated by Apache, and RT will create an account for them based on
their apache username (due to WebExternalAuto being set as well). This
way users can email tickets in from their “official” email address, but
SPAM etc, will not trigger new accounts being created in RT and junk
tickets in queues etc.

If someone can help me with the above problem, or suggest a better way
of acheiving my goal, then I’d be most grateful.

technical info:

Solaris 9: Apache/2.0.48 (Unix) mod_ssl/2.0.48 OpenSSL/0.9.7c
mod_fastcgi/mod_fastcgi-SNAP-0404142202 JRun/4.0

RT installed in /usr/local/rt3

Document root in apache set to /usr/local/rt3/share/html (virtual server
running on non standard port using SSL.


David Batterham
Information Systems & Services Manager
Department of Electrical & Electronic Engineering
The University of Melbourne, Victoria 3010
Phone: +61 3 8344 3366
Fax: +61 3 8344 6678

My problem is that I cannot seem to get things working with both
fast-cgi/mason AND .htaccess!

Consider putting the Auth related stuff directly in httpd.conf.