Problem to integrate exim4 with request tracker 4.0

Hi all,

I am trying to setup an RT 4.0 system with exim4. I want it to be queue
agnostic, so the manual advised to use this setup:

cat /etc/exim4/conf.d/main/90_exim4-config_requesttracker

RT_USER=www-data
RT_URL=https://logs.markouassociates.com

rt_transport:
driver = pipe
user = RT_USER
command = rt-mailgate
–action ‘${if def:local_part_suffix {comment}{correspond}}’
–queue “$local_part”
–url RT_URL --no-verify-ssl

rt_router:
driver = accept
local_part_prefix = rt-
administration
local_part_suffix_optional
local_part_suffix = -comment
transport = rt_transport

But when I try to restart exim4 this is what I get:

service exim4 restart

  • Stopping MTA for restart
    2014-09-14 10:06:32 Exim configuration error in line 218 of
    /var/lib/exim4/config.autogenerated.tmp:
    main option “rt_transport” unknown
    Invalid new configfile /var/lib/exim4/config.autogenerated.tmp, not
    installing
    /var/lib/exim4/config.autogenerated.tmp to
    /var/lib/exim4/config.autogenerated

I know I must be doing something fundamentally wrong here but as an exim
noob, I can’t figure it out.

I am using RT 4.0.19 and exim4 4.82 both installed from the stock Ubuntu
14.04 (64 bit) packages.

Any ideas?

You probably need to run some command to regenerate your configs for Exim4
so that the transport can be detected. I only know how to use the
monolithic Exim4 configuration, not the split config. Maybe:

sudo dpkg-reconfigure exim4-configOn 14 September 2014 11:49, Theodotos Andreou theo@ubuntucy.org wrote:

Hi all,

I am trying to setup an RT 4.0 system with exim4. I want it to be queue
agnostic, so the manual advised to use this setup:

cat /etc/exim4/conf.d/main/90_exim4-config_requesttracker

RT_USER=www-data
RT_URL=https://logs.markouassociates.com

rt_transport:
driver = pipe
user = RT_USER
command = rt-mailgate
–action ‘${if def:local_part_suffix {comment}{correspond}}’
–queue “$local_part”
–url RT_URL --no-verify-ssl

rt_router:
driver = accept
local_part_prefix = rt-
administration
local_part_suffix_optional
local_part_suffix = -comment
transport = rt_transport

But when I try to restart exim4 this is what I get:

service exim4 restart

  • Stopping MTA for restart
    2014-09-14 10:06:32 Exim configuration error in line 218 of
    /var/lib/exim4/config.autogenerated.tmp:
    main option “rt_transport” unknown
    Invalid new configfile /var/lib/exim4/config.autogenerated.tmp, not
    installing
    /var/lib/exim4/config.autogenerated.tmp to /var/lib/exim4/config.
    autogenerated

I know I must be doing something fundamentally wrong here but as an exim
noob, I can’t figure it out.

I am using RT 4.0.19 and exim4 4.82 both installed from the stock Ubuntu
14.04 (64 bit) packages.

Any ideas?


RT Training - Boston, September 9-10
http://bestpractical.com/training

Best regards,
Odhiambo WASHINGTON,
Nairobi,KE
+254733744121/+254722743223
"I can’t hear you – I’m using the scrambler."

OK I used dpkg-reconfigure to switch to a monolithic format. Now I get:

dpkg-reconfigure exim4-config

  • Stopping MTA for restart
    …done.
  • Restarting MTA
    …done.
    ALERT: exim paniclog /var/log/exim4/paniclog has non-zero size, mail system possibly broken

The panilog says:

cat /var/log/exim4/paniclog

2014-09-13 08:20:06 Exim configuration error in line 218 of /var/lib/exim4/config.autogenerated.tmp:
main option “rt_transport” unknown
2014-09-14 04:00:43 Exim configuration error in line 218 of /var/lib/exim4/config.autogenerated.tmp:
main option “rt_transport” unknown
2014-09-14 10:06:32 Exim configuration error in line 218 of /var/lib/exim4/config.autogenerated.tmp:
main option “rt_transport” unknown

What now?On 14/09/2014 12:14 μμ, Odhiambo Washington wrote:

You probably need to run some command to regenerate your configs for
Exim4 so that the transport can be detected. I only know how to use
the monolithic Exim4 configuration, not the split config. Maybe:

sudo dpkg-reconfigure exim4-config

On 14 September 2014 11:49, Theodotos Andreou <theo@ubuntucy.org mailto:theo@ubuntucy.org> wrote:

Hi all,

I am trying to setup an RT 4.0 system with exim4. I want it to be
queue agnostic, so the manual advised to use this setup:

# cat /etc/exim4/conf.d/main/90_exim4-config_requesttracker
RT_USER=www-data
RT_URL=https://logs.markouassociates.com

rt_transport:
 driver = pipe
 user = RT_USER
 command = rt-mailgate \
 --action '${if def:local_part_suffix {comment}{correspond}}' \
 --queue "$local_part" \
 --url RT_URL --no-verify-ssl

rt_router:
 driver = accept
 local_part_prefix = rt-
 administration
 local_part_suffix_optional
 local_part_suffix = -comment
 transport = rt_transport

But when I try to restart exim4 this is what I get:

# service exim4 restart
 * Stopping MTA for restart
2014-09-14 10:06:32 Exim configuration error in line 218 of
/var/lib/exim4/config.autogenerated.tmp:
  main option "rt_transport" unknown
Invalid new configfile /var/lib/exim4/config.autogenerated.tmp,
not installing
/var/lib/exim4/config.autogenerated.tmp to
/var/lib/exim4/config.autogenerated

I know I must be doing something fundamentally wrong here but as
an exim noob, I can't  figure it out.

I am using RT 4.0.19 and exim4 4.82 both installed from the stock
Ubuntu 14.04 (64 bit) packages.

Any ideas?


-- 
RT Training - Boston, September 9-10
http://bestpractical.com/training


Best regards,
Odhiambo WASHINGTON,
Nairobi,KE
+254733744121/+254722743223
"I can’t hear you – I’m using the scrambler."

Can we take this offlist, please? I can help you set it up from there.

First I don’t understand why your file is named .tmp. In a monolithic
config, you should be getting something like 'error in line XXX of
exim4.config…

I am on skype as odhiambo@outlook.com or pipind. Please catch me on that if
possible, else let’s move into private e-mail I help you troubleshoot.On 14 September 2014 12:36, Theodotos Andreou theo@ubuntucy.org wrote:

OK I used dpkg-reconfigure to switch to a monolithic format. Now I get:

dpkg-reconfigure exim4-config

  • Stopping MTA for restart
    …done.
  • Restarting MTA
    …done.
    ALERT: exim paniclog /var/log/exim4/paniclog has non-zero size, mail system possibly broken

The panilog says:

cat /var/log/exim4/paniclog

2014-09-13 08:20:06 Exim configuration error in line 218 of /var/lib/exim4/config.autogenerated.tmp:
main option “rt_transport” unknown
2014-09-14 04:00:43 Exim configuration error in line 218 of /var/lib/exim4/config.autogenerated.tmp:
main option “rt_transport” unknown
2014-09-14 10:06:32 Exim configuration error in line 218 of /var/lib/exim4/config.autogenerated.tmp:
main option “rt_transport” unknown

What now?

On 14/09/2014 12:14 μμ, Odhiambo Washington wrote:

You probably need to run some command to regenerate your configs for Exim4
so that the transport can be detected. I only know how to use the
monolithic Exim4 configuration, not the split config. Maybe:

sudo dpkg-reconfigure exim4-config

On 14 September 2014 11:49, Theodotos Andreou theo@ubuntucy.org wrote:

Hi all,

I am trying to setup an RT 4.0 system with exim4. I want it to be queue
agnostic, so the manual advised to use this setup:

cat /etc/exim4/conf.d/main/90_exim4-config_requesttracker

RT_USER=www-data
RT_URL=https://logs.markouassociates.com

rt_transport:
driver = pipe
user = RT_USER
command = rt-mailgate
–action ‘${if def:local_part_suffix {comment}{correspond}}’
–queue “$local_part”
–url RT_URL --no-verify-ssl

rt_router:
driver = accept
local_part_prefix = rt-
administration
local_part_suffix_optional
local_part_suffix = -comment
transport = rt_transport

But when I try to restart exim4 this is what I get:

service exim4 restart

  • Stopping MTA for restart
    2014-09-14 10:06:32 Exim configuration error in line 218 of
    /var/lib/exim4/config.autogenerated.tmp:
    main option “rt_transport” unknown
    Invalid new configfile /var/lib/exim4/config.autogenerated.tmp, not
    installing
    /var/lib/exim4/config.autogenerated.tmp to
    /var/lib/exim4/config.autogenerated

I know I must be doing something fundamentally wrong here but as an exim
noob, I can’t figure it out.

I am using RT 4.0.19 and exim4 4.82 both installed from the stock Ubuntu
14.04 (64 bit) packages.

Any ideas?


RT Training - Boston, September 9-10
http://bestpractical.com/training


Best regards,
Odhiambo WASHINGTON,
Nairobi,KE
+254733744121/+254722743223
"I can’t hear you – I’m using the scrambler."

Best regards,
Odhiambo WASHINGTON,
Nairobi,KE
+254733744121/+254722743223
"I can’t hear you – I’m using the scrambler."

I did not mean to offend anyone. I just choose not to use skype. And
since we have the mailing, list I don’t see why this discussion cannot
happen on the mailing list. Or on RT’s IRC channel.

Anyway I figured it out eventually (with some help from the exim IRC
channel):

You need to revert the configuration back to split.

Then you need to create these two files:

 root@rt:~# cat /etc/exim4/conf.d/router/rt_router
 rt_router:
  driver = accept
  local_part_prefix = rt-
  local_part_suffix_optional
  local_part_suffix = -comment
  transport = rt_transport
  
 root@rt:~# cat /etc/exim4/conf.d/transport/rt_transport
 RT_USER=www-data
 RT_URL=https://rt.example.com
  
 rt_transport:
  driver = pipe
  user = RT_USER
  command = rt-mailgate \
  --action '${if def:local_part_suffix {comment}{correspond}}' \
  --queue "$local_part" \
  --url RT_URL --no-verify-ssl

and then restart exim.

Thanks guys.On 14/09/2014 01:23 οΏ½οΏ½, Odhiambo Washington wrote:

It’s okay if you do not need my help because of paranoia. I am on
Windows PC at the moment and I am not installing anything else.
I said use either ‘pipind’ or ‘odhiambo@outlook.com
mailto:odhiambo@outlook.com’ as my Skype names.

Maybe someone on the forum/list will take this up and help you.

On 14 September 2014 13:14, Theodotos Andreou <theo@ubuntucy.org mailto:theo@ubuntucy.org> wrote:

I'm too paranoid for Skype. I have no idea what is pipind :)

How about Tox (my
id:AF41728851B8C1CEFE85956D594991F752950BBE9D0F744ED03994534F7274283B3C52174898)
or plain old IRC?




On 14/09/2014 12:54 οΏ½οΏ½, Odhiambo Washington wrote:
Can we take this offlist, please? I can help you set it up from
there.

First I don't understand why your file is named .tmp. In a
monolithic config, you should be getting something like 'error in
line XXX of exim4.config....

I am on skype as odhiambo@outlook.com
<mailto:odhiambo@outlook.com> or pipind. Please catch me on that
if possible, else let's move into private e-mail I help you
troubleshoot.





On 14 September 2014 12:36, Theodotos Andreou <theo@ubuntucy.org <mailto:theo@ubuntucy.org>> wrote:

    OK I used dpkg-reconfigure to switch to a monolithic format.
    Now I get:

    # dpkg-reconfigure exim4-config
      * Stopping MTA for restart
        ...done.
      * Restarting MTA
        ...done.
    ALERT: exim paniclog /var/log/exim4/paniclog has non-zero size, mail system possibly broken

    The panilog says:

    # cat /var/log/exim4/paniclog
    2014-09-13 08:20:06 Exim configuration error in line 218 of /var/lib/exim4/config.autogenerated.tmp:
       main option "rt_transport" unknown
    2014-09-14 04:00:43 Exim configuration error in line 218 of /var/lib/exim4/config.autogenerated.tmp:
       main option "rt_transport" unknown
    2014-09-14 10:06:32 Exim configuration error in line 218 of /var/lib/exim4/config.autogenerated.tmp:
       main option "rt_transport" unknown

    What now?


    On 14/09/2014 12:14 οΏ½οΏ½, Odhiambo Washington wrote:
    You probably need to run some command to regenerate your
    configs for Exim4 so that the transport can be detected. I
    only know how to use the monolithic Exim4 configuration, not
    the split config. Maybe:

    sudo dpkg-reconfigure exim4-config





    On 14 September 2014 11:49, Theodotos Andreou <theo@ubuntucy.org <mailto:theo@ubuntucy.org>> wrote:

        Hi all,

        I am trying to setup an RT 4.0 system with exim4. I want
        it to be queue agnostic, so the manual advised to use
        this setup:

        # cat /etc/exim4/conf.d/main/90_exim4-config_requesttracker
        RT_USER=www-data
        RT_URL=https://logs.markouassociates.com

        rt_transport:
         driver = pipe
         user = RT_USER
         command = rt-mailgate \
         --action '${if def:local_part_suffix
        {comment}{correspond}}' \
         --queue "$local_part" \
         --url RT_URL --no-verify-ssl

        rt_router:
         driver = accept
         local_part_prefix = rt-
         administration
         local_part_suffix_optional
         local_part_suffix = -comment
         transport = rt_transport

        But when I try to restart exim4 this is what I get:

        # service exim4 restart
         * Stopping MTA for restart
        2014-09-14 10:06:32 Exim configuration error in line 218
        of /var/lib/exim4/config.autogenerated.tmp:
          main option "rt_transport" unknown
        Invalid new configfile
        /var/lib/exim4/config.autogenerated.tmp, not installing
        /var/lib/exim4/config.autogenerated.tmp to
        /var/lib/exim4/config.autogenerated

        I know I must be doing something fundamentally wrong
        here but as an exim noob, I can't  figure it out.

        I am using RT 4.0.19 and exim4 4.82 both installed from
        the stock Ubuntu 14.04 (64 bit) packages.

        Any ideas?


        -- 
        RT Training - Boston, September 9-10
        http://bestpractical.com/training




    -- 
    Best regards,
    Odhiambo WASHINGTON,
    Nairobi,KE
    +254733744121/+254722743223
    "I can't hear you -- I'm using the scrambler."
-- 
Best regards,
Odhiambo WASHINGTON,
Nairobi,KE
+254733744121/+254722743223
"I can't hear you -- I'm using the scrambler."


Best regards,
Odhiambo WASHINGTON,
Nairobi,KE
+254733744121/+254722743223
"I can’t hear you – I’m using the scrambler."

Another think to have in mind. The Reply and Comment email addresses
must have the following format in order to work:

rt-@rt.example.com
rt--comments@rt.example.comOn 14/09/2014 02:41 μμ, Theodotos Andreou wrote:

I did not mean to offend anyone. I just choose not to use skype. And
since we have the mailing, list I don’t see why this discussion cannot
happen on the mailing list. Or on RT’s IRC channel.

Anyway I figured it out eventually (with some help from the exim IRC
channel):

You need to revert the configuration back to split.

Then you need to create these two files:
root@rt:~# cat /etc/exim4/conf.d/router/rt_router
rt_router:
driver = accept
local_part_prefix = rt-
local_part_suffix_optional
local_part_suffix = -comment
transport = rt_transport

 root@rt:~# cat /etc/exim4/conf.d/transport/rt_transport
 RT_USER=www-data
 RT_URL=https://rt.example.com
  
 rt_transport:
  driver = pipe
  user = RT_USER
  command = rt-mailgate \
  --action '${if def:local_part_suffix {comment}{correspond}}' \
  --queue "$local_part" \
  --url RT_URL --no-verify-ssl

and then restart exim.

Thanks guys.

On 14/09/2014 01:23 μμ, Odhiambo Washington wrote:

It’s okay if you do not need my help because of paranoia. I am on
Windows PC at the moment and I am not installing anything else.
I said use either ‘pipind’ or ‘odhiambo@outlook.com
mailto:odhiambo@outlook.com’ as my Skype names.

Maybe someone on the forum/list will take this up and help you.

On 14 September 2014 13:14, Theodotos Andreou <theo@ubuntucy.org mailto:theo@ubuntucy.org> wrote:

I'm too paranoid for Skype. I have no idea what is pipind :)

How about Tox (my
id:AF41728851B8C1CEFE85956D594991F752950BBE9D0F744ED03994534F7274283B3C52174898)
or plain old IRC?




On 14/09/2014 12:54 μμ, Odhiambo Washington wrote:
Can we take this offlist, please? I can help you set it up from
there.

First I don't understand why your file is named .tmp. In a
monolithic config, you should be getting something like 'error
in line XXX of exim4.config....

I am on skype as odhiambo@outlook.com
<mailto:odhiambo@outlook.com> or pipind. Please catch me on that
if possible, else let's move into private e-mail I help you
troubleshoot.





On 14 September 2014 12:36, Theodotos Andreou <theo@ubuntucy.org <mailto:theo@ubuntucy.org>> wrote:

    OK I used dpkg-reconfigure to switch to a monolithic format.
    Now I get:

    # dpkg-reconfigure exim4-config
      * Stopping MTA for restart
        ...done.
      * Restarting MTA
        ...done.
    ALERT: exim paniclog /var/log/exim4/paniclog has non-zero size, mail system possibly broken

    The panilog says:

    # cat /var/log/exim4/paniclog
    2014-09-13 08:20:06 Exim configuration error in line 218 of /var/lib/exim4/config.autogenerated.tmp:
       main option "rt_transport" unknown
    2014-09-14 04:00:43 Exim configuration error in line 218 of /var/lib/exim4/config.autogenerated.tmp:
       main option "rt_transport" unknown
    2014-09-14 10:06:32 Exim configuration error in line 218 of /var/lib/exim4/config.autogenerated.tmp:
       main option "rt_transport" unknown

    What now?


    On 14/09/2014 12:14 μμ, Odhiambo Washington wrote:
    You probably need to run some command to regenerate your
    configs for Exim4 so that the transport can be detected. I
    only know how to use the monolithic Exim4 configuration,
    not the split config. Maybe:

    sudo dpkg-reconfigure exim4-config





    On 14 September 2014 11:49, Theodotos Andreou <theo@ubuntucy.org <mailto:theo@ubuntucy.org>> wrote:

        Hi all,

        I am trying to setup an RT 4.0 system with exim4. I
        want it to be queue agnostic, so the manual advised to
        use this setup:

        # cat /etc/exim4/conf.d/main/90_exim4-config_requesttracker
        RT_USER=www-data
        RT_URL=https://logs.markouassociates.com

        rt_transport:
         driver = pipe
         user = RT_USER
         command = rt-mailgate \
         --action '${if def:local_part_suffix
        {comment}{correspond}}' \
         --queue "$local_part" \
         --url RT_URL --no-verify-ssl

        rt_router:
         driver = accept
         local_part_prefix = rt-
         administration
         local_part_suffix_optional
         local_part_suffix = -comment
         transport = rt_transport

        But when I try to restart exim4 this is what I get:

        # service exim4 restart
         * Stopping MTA for restart
        2014-09-14 10:06:32 Exim configuration error in line
        218 of /var/lib/exim4/config.autogenerated.tmp:
          main option "rt_transport" unknown
        Invalid new configfile
        /var/lib/exim4/config.autogenerated.tmp, not installing
        /var/lib/exim4/config.autogenerated.tmp to
        /var/lib/exim4/config.autogenerated

        I know I must be doing something fundamentally wrong
        here but as an exim noob, I can't  figure it out.

        I am using RT 4.0.19 and exim4 4.82 both installed from
        the stock Ubuntu 14.04 (64 bit) packages.

        Any ideas?


        -- 
        RT Training - Boston, September 9-10
        http://bestpractical.com/training




    -- 
    Best regards,
    Odhiambo WASHINGTON,
    Nairobi,KE
    +254733744121/+254722743223
    "I can't hear you -- I'm using the scrambler."
-- 
Best regards,
Odhiambo WASHINGTON,
Nairobi,KE
+254733744121/+254722743223
"I can't hear you -- I'm using the scrambler."


Best regards,
Odhiambo WASHINGTON,
Nairobi,KE
+254733744121/+254722743223
"I can’t hear you – I’m using the scrambler."

Another think to have in mind. The Reply and Comment email addresses
must have the following format in order to work:

rt-@rt.example.com
rt--comments@rt.example.com

Not quite.

For Exim4 and RT since 3.x, here is what you need in Exim’s config when
using MySQL:

See http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=229052

Should work for RT4 with very minimal customizations.

Best regards,
Odhiambo WASHINGTON,
Nairobi,KE
+254733744121/+254722743223
"I can’t hear you – I’m using the scrambler."

Another think to have in mind. The Reply and Comment email
addresses must have the following format in order to work:

rt-<queue>@rt.example.com <http://rt.example.com>
rt-<queue>-comments@rt.example.com <mailto:comments@rt.example.com>

Not quite.

For Exim4 and RT since 3.x, here is what you need in Exim’s config
when using MySQL:

See http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=229052

Should work for RT4 with very minimal customizations.


Best regards,
Odhiambo WASHINGTON,
Nairobi,KE
+254733744121/+254722743223
"I can’t hear you – I’m using the scrambler."
Thanks Odhiambo,

It’s working now.