Problem setting up RT after changing hostname

Hi,

I have a problem with my ticket system. It was hosted on a private laptop,
connected to via DynDNS. For some reason, one colleague’s PC had a different
domain when used, and RT errored out every time he wanted to do something on
a ticket.

Now I changed the config files, and am stuck at “You haven’t yet configured
your webserver to run RT. You appear to have installed RT’s web interface
correctly, but haven’t yet configured your web server to “run” the RT server
which powers the web interface. The next step is to edit your webserver’s
configuration file to instruct it to use RT’s mod_perl or FastCGI handler.
If you need commercial support, please contact us at
sales@bestpractical.com.”, and I cannot figure out why.

Here are the three files in question:

httpd.conf:

            AddDefaultCharset UTF-8

DocumentRoot "/opt/rt4/share/html"
<Location />
	Order allow,deny
	Allow from all

	SetHandler modperl
	PerlResponseHandler Plack::Handler::Apache2
	PerlSetVar psgi_app /opt/rt4/sbin/rt-server
</Location>
<Perl>
	use Plack::Handler::Apache2;
	Plack::Handler::Apache2->preload("/opt/rt4/sbin/rt-server");
</Perl>

RT_SiteConfig.pm:

Set( $rtname, “MyDomain”);

Set( $LogToFile, ‘debug’);
Set( $LogToFileNamed, ‘rt.log’);
Set( $LogDir, ‘/opt/rt4/var/log’);

Set($WebDomain, “mydomain.dnsdynamic.com”);
Set( $WebPath, ‘’);

/etc/apache2/sites-available/default:

<VirtualHost *:80>
AddDefaultCharset UTF-8
DocumentRoot “/opt/rt4/share/html/”

Order allow,deny
Allow from all

<Directory /var/www/>
Order allow,deny
Allow from all


Order allow,deny
Allow from all
SetHandler modperl
PerlResponseHandler Plack::Handler::Apache2
PerlSetVar psgi_app /opt/rt4/sbin/rt-server


use Plack::Handler::Apache2;
Plack::Handler::Apache2->preload(“/opt/rt4/sbin/rt-server”);

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory “/usr/lib/cgi-bin”>
AllowOverride None
Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all

ErrorLog ${APACHE_LOG_DIR}/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog ${APACHE_LOG_DIR}/access.log combined

Alias /doc/ "/usr/share/doc/"
<Directory "/usr/share/doc/">
    Options Indexes MultiViews FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all
    Allow from 127.0.0.0/255.0.0.0 ::1/128
</Directory>

It used to work, but I cannot get it to work again, does anyone have an idea
what may be wrong here?

Thanks,
Anton

Check your log files Anton. 9/10 times the answer is there.

Also, your Apache config seems slightly mad. You have the ghost effectively defined twice, once in httpd.conf and then once as an include within ‘/etc/apache2/sites-available/default’. You should only need one of these.

Your statements don’t seem correct either. <Directory /opt/rt4/share/html> is more likely what you want.

I’d go back to the docs relating to configuring the web server and start over. Your issue is more than likely to do with the above.

Nick
Nick Fennell
ApplianSys Support Team Leader

ApplianSys Limited
University of Warwick Science Park
Business Innovation Centre
Harry Weston Road
Coventry CV3 2TX

t: +44 (0) 870 7707 789
s: nick-fennell

Our sales team sells by referral:
Less time looking for customers, more time looking after them

Subscribe: EepURL - A Mailchimp Service 27 Nov 2012, at 14:52, Anton Roth Anton_Roth@gmx.de wrote:

Hi,

I have a problem with my ticket system. It was hosted on a private laptop, connected to via DynDNS. For some reason, one colleague’s PC had a different domain when used, and RT errored out every time he wanted to do something on a ticket.

Now I changed the config files, and am stuck at “You haven’t yet configured your webserver to run RT. You appear to have installed RT’s web interface correctly, but haven’t yet configured your web server to “run” the RT server which powers the web interface. The next step is to edit your webserver’s configuration file to instruct it to use RT’s mod_perl or FastCGI handler. If you need commercial support, please contact us at sales@bestpractical.com.”, and I cannot figure out why.

Here are the three files in question:

httpd.conf:

          AddDefaultCharset UTF-8

DocumentRoot “/opt/rt4/share/html”

Order allow,deny
Allow from all

  SetHandler modperl
  PerlResponseHandler Plack::Handler::Apache2
  PerlSetVar psgi_app /opt/rt4/sbin/rt-server
use Plack::Handler::Apache2; Plack::Handler::Apache2->preload("/opt/rt4/sbin/rt-server");

RT_SiteConfig.pm:

Set( $rtname, “MyDomain”);

Set( $LogToFile, ‘debug’);
Set( $LogToFileNamed, ‘rt.log’);
Set( $LogDir, ‘/opt/rt4/var/log’);

Set($WebDomain, “mydomain.dnsdynamic.com”);
Set( $WebPath, ‘’);

/etc/apache2/sites-available/default:

<VirtualHost *:80>
AddDefaultCharset UTF-8
DocumentRoot “/opt/rt4/share/html/”

Order allow,deny
Allow from all

<Directory /var/www/>
Order allow,deny
Allow from all


Order allow,deny
Allow from all
SetHandler modperl
PerlResponseHandler Plack::Handler::Apache2
PerlSetVar psgi_app /opt/rt4/sbin/rt-server


use Plack::Handler::Apache2;
Plack::Handler::Apache2->preload(“/opt/rt4/sbin/rt-server”);

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory “/usr/lib/cgi-bin”>
AllowOverride None
Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all

ErrorLog ${APACHE_LOG_DIR}/error.log

Possible values include: debug, info, notice, warn, error, crit,

alert, emerg.

LogLevel warn

CustomLog ${APACHE_LOG_DIR}/access.log combined

Alias /doc/ “/usr/share/doc/”
<Directory “/usr/share/doc/”>
Options Indexes MultiViews FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
Allow from 127.0.0.0/255.0.0.0 ::1/128

It used to work, but I cannot get it to work again, does anyone have an idea what may be wrong here?

Thanks,
Anton

We’re hiring! http://bestpractical.com/jobs