Problem logging out of RT from Opera

Hi

I’ve only just started playing with RT (got my test install running today…),
so apologies if this is down to inexperience or bad configuration on my part…

I’ve found a problem when using WebRT from an Opera browser - it’s very
difficult to log out - you hit the ‘Logout’ link, and it says “you’ve been
logged out”, but then you immediately get logged back in again!
The problem does not occur on Mozilla.

My guess is that the browser is caching pages more than it ought to (I don’t
think it should be caching at all)

I’ve found a fix which appears to work for me - I’ve added the following
(apologies if this gets mangled in the mail):

<%INIT>
# ask the browser not to cache our content
$r->headers_out->add('Pragma' => 'no-cache'); # HTTP/1.0
$r->headers_out->add('Cache-Control' => 'no-cache, must-revalidate'); #

HTTP/1.1
</%INIT>

to “local/WebRT/html/NoAuth/Logout.html”, and something to the same effect in
"local/WebRT/html/Elements/Header" ,after having copied the files from the
non-local part of the tree.

Steve Bennett, Systems Support, Lancaster University

I’ve found a problem when using WebRT from an Opera browser - it’s very
difficult to log out - you hit the ‘Logout’ link, and it says “you’ve been
logged out”, but then you immediately get logged back in again!

Known problem (I got bit by it before). The solution is in the
Preferences, Network, History and Cache, and making sure that it Always
checks to see whether a document has been modified.

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

And the FAQ has been updated with the Opera question.

Regards,

                         Bruce Campbell                            RIPE
               Systems/Network Engineer                             NCC
             www.ripe.net - PGP562C8B1B                      Operations

I’ve found a problem when using WebRT from an Opera browser - it’s
very difficult to log out - you hit the ‘Logout’ link, and it says
"you’ve been logged out", but then you immediately get logged back
in again!

Known problem (I got bit by it before). The solution is in the
Preferences, Network, History and Cache, and making sure that it
Always checks to see whether a document has been modified.

As opposed to having the page itself ask the browser not to cache?
That seems like a bad idea. I’m not turning off all caching just for
one product.

-Robin

http://www.digitalkingdom.org/~rlpowell/ BTW, I’m male, honest.
le datni cu djica le nu zifre .iku’i .oi le so’e datni cu to’e te pilno
je xlali – RLP http://www.lojban.org/

Ah. My bad.

-RobinOn Fri, May 03, 2002 at 10:26:34AM -0700, Russ Johnson wrote:

It’s an Opera problem. Opera ignores “No Cache” directives in web pages.

There is a no cache in the RT webpages.

Here it is:

RT/tripwire_ticket: Start page

At 10:14 AM 5/3/2002 -0700, you wrote:

As opposed to having the page itself ask the browser not to cache?
That seems like a bad idea. I’m not turning off all caching just for
one product.

Russ Johnson
http://www.dimstar.net

Stewardesses is the longest word that is typed with only the left hand

http://www.digitalkingdom.org/~rlpowell/ BTW, I’m male, honest.
le datni cu djica le nu zifre .iku’i .oi le so’e datni cu to’e te pilno
je xlali – RLP http://www.lojban.org/

“RLP” == Robin Lee Powell rlpowell@digitalkingdom.org writes:

Known problem (I got bit by it before). The solution is in the
Preferences, Network, History and Cache, and making sure that it
Always checks to see whether a document has been modified.

RLP> As opposed to having the page itself ask the browser not to cache?
RLP> That seems like a bad idea. I’m not turning off all caching just for
RLP> one product.

No, it is a bug/feature in Opera. It ignores the expires header a
page may send if it falls within the time it has configured for not to
check for modifications.

There is a no cache in the RT webpages.

Here it is:

I’m not sure why this is being sent embedded in the HTML rather than as a real
HTTP header. I do know that the change I posted fixes a real problem for me, so
maybe some browsers don’t honour embedded directives like this.

Maybe this is a good reason for using real headers instead of HTML ‘META’ tags.

Steve Bennett
Systems Support, Lancaster University