Problem installing latest RT from GIT

Hi Group
just tried to install latest rt from git and i’m getting confused:

config:

./configure --enable-graphviz --enable-gd --with-web-handler=fastcgi
–with-db-rt-pass=apassword --with-web-user=apache --with-web-group=apache

So, no GPG, after fixing all deps (mostly via rpm/yum) i get the following
from make testdeps:

SOME DEPENDENCIES WERE MISSING.
GPG missing dependencies:
GnuPG::Interface …MISSING

OK, i thought i don’t use GPG but let me install it:

[root@rt3 bestpractical-rt-cb95899]# perl -MCPAN -e ‘install
GnuPG::Interface’
CPAN: Storable loaded ok
Going to read /root/.cpan/Metadata
Database was generated on Sun, 21 Mar 2010 13:50:09 GMT
GnuPG::Interface is up to date.

make testdeps still shows the error.

Tried later with --disable-gpg works well. So it looks like i have to
disable it to get all working, correct or and error?

Any ideas?

MFG

Torsten Brumm

http://www.brumm.me

Hi Group
just tried to install latest rt from git and i’m getting confused:

config:

./configure --enable-graphviz --enable-gd --with-web-handler=fastcgi
–with-db-rt-pass=apassword --with-web-user=apache --with-web-group=apache

So, no GPG, after fixing all deps (mostly via rpm/yum) i get the following
from make testdeps:

SOME DEPENDENCIES WERE MISSING.
GPG missing dependencies:
GnuPG::Interface …MISSING

OK, i thought i don’t use GPG but let me install it:

[root@rt3 bestpractical-rt-cb95899]# perl -MCPAN -e 'install
GnuPG::Interface’
CPAN: Storable loaded ok
Going to read /root/.cpan/Metadata
Database was generated on Sun, 21 Mar 2010 13:50:09 GMT
GnuPG::Interface is up to date.

What versions of gpg and GPG::Interface do you have installed?

What does perl -e’use GnuPG::Interface 99999’ say?

-j

Hi Group
just tried to install latest rt from git and i’m getting confused:

config:

./configure --enable-graphviz --enable-gd --with-web-handler=fastcgi
–with-db-rt-pass=apassword --with-web-user=apache --with-web-group=apache

So, no GPG, after fixing all deps (mostly via rpm/yum) i get the
following from make testdeps:

SOME DEPENDENCIES WERE MISSING.
GPG missing dependencies:
GnuPG::Interface …MISSING

OK, i thought i don’t use GPG but let me install it:

[root@rt3 bestpractical-rt-cb95899]# perl -MCPAN -e 'install
GnuPG::Interface’
CPAN: Storable loaded ok
Going to read /root/.cpan/Metadata
Database was generated on Sun, 21 Mar 2010 13:50:09 GMT
GnuPG::Interface is up to date.

make testdeps still shows the error.

Tried later with --disable-gpg works well. So it looks like i have to
disable it to get all working, correct or and error?

Any ideas?

Hi Torsten,

gpg support is by default enabled,
so you have to satisfy the gpg dependencies.
If you don’t have all gpg dependencies installed and
don’t want to use gpg, you have to disable gpg.
It’s not a bug, it’s a feature :wink:

Chris