Problem initializing database

[root@rt3 ~]# /usr/sbin/rt-setup-database --action init --dba root
–prompt-for-dba-password
In order to create or update your RT database,this script needs to
connect to your mysql instance on 10.12.14.149 as root.
Please specify that user’s database password below. If the user has no
database
password, just press return.

Password:
Now creating a database for RT.
Creating mysql database rt3.
Now populating database schema.
Creating database schema.
readline() on closed filehandle SCHEMA_LOCAL at
/usr/sbin/rt-setup-database line 192.
Done setting up database schema.
Now inserting database ACLs
DBD::mysql::st execute failed: Access denied for user
’root’@‘10.12.14.164’ to database ‘rt3’ at /usr/sbin/rt-setup-database
line 345.
Problem with statement:
GRANT SELECT,INSERT,CREATE,INDEX,UPDATE,DELETE ON rt3.* TO
rt_user@‘10.12.14.164’ IDENTIFIED BY ‘***********’;
Access denied for user ‘root’@‘10.12.14.164’ to database ‘rt3’ at
/usr/sbin/rt-setup-database line 346.

On the MySQL server, I did:

grant all on . to ‘root’@‘10.12.14.164’ identified by ‘********’

but am still getting that error.

I’m aware that this is almost certainly a MySQL error, but I don’t think
I’ll get much help from any MySQL forums since I can’t tell them exactly
what /usr/sbin/rt-setup-database is doing.

John, here is my response the last time you asked the same question:

What I wanted you to figure out was if you could connect to the db server
from the RT server using the ‘root’ user via mysql client. From the RT
server try:

mysql -u root -p -h 10.12.14.149

What about:

mysql -u root -p -h 10.12.14.149 rt3

If you can connect successfully to the rt3 database using the 2nd command
above, try creating a test table:

mysql> create table testing123;

If your manual connection attempts to the mysql database or your table
creation attempt fails, then you simply haven’t set your permissions
correctly for the root user. At that point, I would suggest you read the
mysql help pages regarding grant permission syntax:

http://dev.mysql.com/doc/refman/5.0/en/grant.html

Also, disable selinux on the DB server, if applicable.

James Moseley

         John Oliver                                                   
         <joliver@john-oli                                             
         ver.net>                                                   To 
         Sent by:                  rt-users@lists.bestpractical.com    
         rt-users-bounces@                                          cc 
         lists.bestpractic                                             
         al.com                                                Subject 
                                   [rt-users] Problem initializing     
                                   database                            
         08/07/2007 12:45                                              
         PM                                                            

[root@rt3 ~]# /usr/sbin/rt-setup-database --action init --dba root
–prompt-for-dba-password
In order to create or update your RT database,this script needs to
connect to your mysql instance on 10.12.14.149 as root.
Please specify that user’s database password below. If the user has no
database
password, just press return.

Password:
Now creating a database for RT.
Creating mysql database rt3.
Now populating database schema.
Creating database schema.
readline() on closed filehandle SCHEMA_LOCAL at
/usr/sbin/rt-setup-database line 192.
Done setting up database schema.
Now inserting database ACLs
DBD::mysql::st execute failed: Access denied for user
‘root’@‘10.12.14.164’ to database ‘rt3’ at /usr/sbin/rt-setup-database
line 345.
Problem with statement:
GRANT SELECT,INSERT,CREATE,INDEX,UPDATE,DELETE ON rt3.* TO
rt_user@‘10.12.14.164’ IDENTIFIED BY ‘***********’;
Access denied for user ‘root’@‘10.12.14.164’ to database ‘rt3’ at
/usr/sbin/rt-setup-database line 346.

On the MySQL server, I did:

grant all on . to ‘root’@‘10.12.14.164’ identified by ‘********’

but am still getting that error.

I’m aware that this is almost certainly a MySQL error, but I don’t think
I’ll get much help from any MySQL forums since I can’t tell them exactly
what /usr/sbin/rt-setup-database is doing.

http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

grant all on . to ‘root’@‘10.12.14.164’ identified by ‘********’

This is almost proper syntax.

Try this instead…

GRANT ALL ON . TO ‘root’@‘10.12.14.164’ IDENTIFIED BY ‘’ WITH
GRANT OPTION

Good luck!

Scott

grant all on . to ‘root’@‘10.12.14.164’ identified by ‘********’

This is almost proper syntax.

Try this instead…

GRANT ALL ON . TO ‘root’@‘10.12.14.164’ IDENTIFIED BY ‘’ WITH
GRANT OPTION

THAT DID IT!!!

Thank you! :slight_smile: