Problem in RT

Hi
When I change the login page ( for example I want to edit “username” to “user” ) I have a problem, when I want to login to RT with every device I have redirected to selfservice automatically. Please help me that why this happened?
Thanks for your attention.

If I understand you correctly, you need to make your user "privileged."
Unprivileged users are forced to use the Self Service area.

I don’t know what you mean by ‘edit “username” to “user”’. Are you trying
to change the visible wording on the login page?On Wed, 14 Jan 2015 12:56 am Shahab Sharifzadeh sshguard@ymail.com wrote:

Hi
When I change the login page ( for example I want to edit “username” to
"user" ) I have a problem, when I want to login to RT with every device I
have redirected to selfservice automatically. Please help me that why this
happened?
Thanks for your attention.

Hello,

I have this issue with my RT most often the RT looses connectivity the RT
database and when that happens I have to change the permission of the file
RT_SitecConfig.pm in the /opt/rt4/etc folder.
I want to fix that problem once and for all, please help

thanks for your attentionOn Tue, Jan 13, 2015 at 11:22 PM, Alex Peters alex@peters.net wrote:

If I understand you correctly, you need to make your user "privileged."
Unprivileged users are forced to use the Self Service area.

I don’t know what you mean by ‘edit “username” to “user”’. Are you trying
to change the visible wording on the login page?

On Wed, 14 Jan 2015 12:56 am Shahab Sharifzadeh sshguard@ymail.com wrote:

Hi
When I change the login page ( for example I want to edit “username” to
"user" ) I have a problem, when I want to login to RT with every device I
have redirected to selfservice automatically. Please help me that why this
happened?
Thanks for your attention.

It sounds like something is repeatedly modifying the permission of your
RT_SiteConfig.pm file such that RT can’t read it. I don’t think RT would
be doing that. How often is this happening for you? Are you performing
any particular steps before this occurs?On Wed, 14 Jan 2015 8:48 pm Lorraine Johnson rraineyjay@gmail.com wrote:

Hello,

I have this issue with my RT most often the RT looses connectivity the RT
database and when that happens I have to change the permission of the file
RT_SitecConfig.pm in the /opt/rt4/etc folder.
I want to fix that problem once and for all, please help

thanks for your attention

On Tue, Jan 13, 2015 at 11:22 PM, Alex Peters alex@peters.net wrote:

If I understand you correctly, you need to make your user "privileged."
Unprivileged users are forced to use the Self Service area.

I don’t know what you mean by ‘edit “username” to “user”’. Are you
trying to change the visible wording on the login page?

On Wed, 14 Jan 2015 12:56 am Shahab Sharifzadeh sshguard@ymail.com wrote:

Hi
When I change the login page ( for example I want to edit “username” to
"user" ) I have a problem, when I want to login to RT with every device I
have redirected to selfservice automatically. Please help me that why this
happened?
Thanks for your attention.

To be clear, the UNIX permissions of that file are changing almost every
morning?

What are they changing to in order to cause RT to fail, and what are you
changing them back to?On Thu, 15 Jan 2015 3:19 am Lorraine Johnson rraineyjay@gmail.com wrote:

This happens mostly in the mornings when i go to the office, even before
the day’s work starts.

On Wed, Jan 14, 2015 at 1:35 PM, Alex Peters alex@peters.net wrote:

It sounds like something is repeatedly modifying the permission of your
RT_SiteConfig.pm file such that RT can’t read it. I don’t think RT would
be doing that. How often is this happening for you? Are you performing
any particular steps before this occurs?

On Wed, 14 Jan 2015 8:48 pm Lorraine Johnson rraineyjay@gmail.com wrote:

Hello,

I have this issue with my RT most often the RT looses connectivity the
RT database and when that happens I have to change the permission of the
file RT_SitecConfig.pm in the /opt/rt4/etc folder.
I want to fix that problem once and for all, please help

thanks for your attention

On Tue, Jan 13, 2015 at 11:22 PM, Alex Peters alex@peters.net wrote:

If I understand you correctly, you need to make your user
"privileged." Unprivileged users are forced to use the Self Service area.

I don’t know what you mean by ‘edit “username” to “user”’. Are you
trying to change the visible wording on the login page?

On Wed, 14 Jan 2015 12:56 am Shahab Sharifzadeh sshguard@ymail.com wrote:

Hi
When I change the login page ( for example I want to edit "username"
to “user” ) I have a problem, when I want to login to RT with every device
I have redirected to selfservice automatically. Please help me that why
this happened?
Thanks for your attention.

I change the permissions to 775 then it’s able to connect to db and work

thanksOn Wed, Jan 14, 2015 at 10:40 PM, Alex Peters alex@peters.net wrote:

To be clear, the UNIX permissions of that file are changing almost every
morning?

What are they changing to in order to cause RT to fail, and what are you
changing them back to?

On Thu, 15 Jan 2015 3:19 am Lorraine Johnson rraineyjay@gmail.com wrote:

This happens mostly in the mornings when i go to the office, even before
the day’s work starts.

On Wed, Jan 14, 2015 at 1:35 PM, Alex Peters alex@peters.net wrote:

It sounds like something is repeatedly modifying the permission of your
RT_SiteConfig.pm file such that RT can’t read it. I don’t think RT would
be doing that. How often is this happening for you? Are you performing
any particular steps before this occurs?

On Wed, 14 Jan 2015 8:48 pm Lorraine Johnson rraineyjay@gmail.com wrote:

Hello,

I have this issue with my RT most often the RT looses connectivity the
RT database and when that happens I have to change the permission of the
file RT_SitecConfig.pm in the /opt/rt4/etc folder.
I want to fix that problem once and for all, please help

thanks for your attention

On Tue, Jan 13, 2015 at 11:22 PM, Alex Peters alex@peters.net wrote:

If I understand you correctly, you need to make your user
"privileged." Unprivileged users are forced to use the Self Service area.

I don’t know what you mean by ‘edit “username” to “user”’. Are you
trying to change the visible wording on the login page?

On Wed, 14 Jan 2015 12:56 am Shahab Sharifzadeh sshguard@ymail.com wrote:

Hi
When I change the login page ( for example I want to edit "username"
to “user” ) I have a problem, when I want to login to RT with every device
I have redirected to selfservice automatically. Please help me that why
this happened?
Thanks for your attention.

What are you changing the permissions from? What is the file’s owning
user/group?

It sounds like something is repeatedly changing the permissions on this
file. To my knowledge, RT doesn’t do that. Is someone else logging in and
doing it? Do you have some sort of cron job or automated system
configuration toolkit running on the system (e.g. Puppet, Ansible, Chef,
Salt)?

What user does RT run as? If you change ownership of this file to that
user, you should find that you don’t need to keep resetting the
permissions to something overly generous.

Still, it would be good to understand what’s actually repeatedly touching
your config file— especially if it’s something automated, because that
would need correcting.On Thu, 15 Jan 2015 9:43 pm Lorraine Johnson rraineyjay@gmail.com wrote:

I change the permissions to 775 then it’s able to connect to db and work

thanks

On Wed, Jan 14, 2015 at 10:40 PM, Alex Peters alex@peters.net wrote:

To be clear, the UNIX permissions of that file are changing almost every
morning?

What are they changing to in order to cause RT to fail, and what are you
changing them back to?

On Thu, 15 Jan 2015 3:19 am Lorraine Johnson rraineyjay@gmail.com wrote:

This happens mostly in the mornings when i go to the office, even before
the day’s work starts.

On Wed, Jan 14, 2015 at 1:35 PM, Alex Peters alex@peters.net wrote:

It sounds like something is repeatedly modifying the permission of your
RT_SiteConfig.pm file such that RT can’t read it. I don’t think RT would
be doing that. How often is this happening for you? Are you performing
any particular steps before this occurs?

On Wed, 14 Jan 2015 8:48 pm Lorraine Johnson rraineyjay@gmail.com wrote:

Hello,

I have this issue with my RT most often the RT looses connectivity the
RT database and when that happens I have to change the permission of the
file RT_SitecConfig.pm in the /opt/rt4/etc folder.
I want to fix that problem once and for all, please help

thanks for your attention

On Tue, Jan 13, 2015 at 11:22 PM, Alex Peters alex@peters.net wrote:

If I understand you correctly, you need to make your user
"privileged." Unprivileged users are forced to use the Self Service area.

I don’t know what you mean by ‘edit “username” to “user”’. Are you
trying to change the visible wording on the login page?

On Wed, 14 Jan 2015 12:56 am Shahab Sharifzadeh sshguard@ymail.com wrote:

Hi
When I change the login page ( for example I want to edit "username"
to “user” ) I have a problem, when I want to login to RT with every device
I have redirected to selfservice automatically. Please help me that why
this happened?
Thanks for your attention.

If I understand you correctly, you need to make your user "privileged."
Unprivileged users are forced to use the Self Service area.

I don’t know what you mean by ‘edit “username” to “user”’. Are you trying
to change the visible wording on the login page?

Yes i want to change visible wording on the login page.
i have changed permission RT_SitecConfig.pm (775 & 777) but it doesn’t work.
what i have to do?

To change the HTML of the Login page:

  1. Copy share/html/Elements/Login.html to
    local/share/html/Elements/Login.html.
  2. Modify local/share/html/Elements/Login.html as desired.
  3. Clean the Mason cache
    http://requesttracker.wikia.com/wiki/CleanMasonCache and restart RT to
    see your changes.

To make an RT user “privileged,” log into RT as a superuser (such as
"root") and tick the “Let this user be granted rights (Privileged)” option
for the user to be privileged (Admin > Users > Select > user).

Note that RT user rights/privileges and UNIX permissions are different
things. As such, you should not be giving your RT_SiteConfig.pm file
executable permissions.On 18 January 2015 at 21:37, Shahab Sharifzadeh sshguard@ymail.com wrote:

If I understand you correctly, you need to make your user "privileged."
Unprivileged users are forced to use the Self Service area.

I don’t know what you mean by ‘edit “username” to “user”’. Are you trying
to change the visible wording on the login page?

Yes i want to change visible wording on the login page.

i have changed permission RT_SitecConfig.pm (775 & 777) but it doesn’t
work.

what i have to do?

hiI have done the following things:

1- Copy /usr/share/request-tracker4/html/Elements/login.html to /usr/local/share/request-tracker4/html/Elements/login.html
2- Modify /usr/local/share/request-tracker4/html/Elements/login.html as desired.
3- Clean the Mason Cache and restart.
but so forward to Selfservice page whenever login to rt.
help me plz…

To change the HTML of the Login page:

  • Copy share/html/Elements/Login.html to local/share/html/Elements/Login.html.

  • Modify local/share/html/Elements/Login.html as desired.

  • Clean the Mason cache and restart RT to see your changes.
    To make an RT user “privileged,” log into RT as a superuser (such as “root”) and tick the “Let this user be granted rights (Privileged)” option for the user to be privileged (Admin > Users > Select > user).
    Note that RT user rights/privileges and UNIX permissions are different things. As such, you should not be giving your RT_SiteConfig.pm file executable permissions.On 18 January 2015 at 21:37, Shahab Sharifzadeh sshguard@ymail.com wrote:

If I understand you correctly, you need to make your user "privileged."
Unprivileged users are forced to use the Self Service area.

I don’t know what you mean by ‘edit “username” to “user”’. Are you trying
to change the visible wording on the login page?

Yes i want to change visible wording on the login page.
i have changed permission RT_SitecConfig.pm (775 & 777) but it doesn’t work.
what i have to do?

You have raised two separate problems. I have answered both. Please
follow my other instructions regarding rights.On 27 Jan 2015 8:45 pm, “Shahab Sharifzadeh” sshguard@ymail.com wrote:

hi
I have done the following things:

1- Copy /usr/share/request-tracker4/html/Elements/login.html
to /usr/local/share/request-tracker4/html/Elements/login.html

2- Modify /usr/local/share/request-tracker4/html/Elements/login.html as
desired.

3- Clean the Mason Cache and restart.

but so forward to Selfservice page whenever login to rt.

help me plz…

On Sunday, January 18, 2015 2:13 PM, Alex Peters alex@peters.net wrote:

To change the HTML of the Login page:

  1. Copy share/html/Elements/Login.html to
    local/share/html/Elements/Login.html.
  2. Modify local/share/html/Elements/Login.html as desired.
  3. Clean the Mason cache
    http://requesttracker.wikia.com/wiki/CleanMasonCache and restart RT
    to see your changes.

To make an RT user “privileged,” log into RT as a superuser (such as
"root") and tick the “Let this user be granted rights (Privileged)” option
for the user to be privileged (Admin > Users > Select > user).

Note that RT user rights/privileges and UNIX permissions are different
things. As such, you should not be giving your RT_SiteConfig.pm file
executable permissions.

On 18 January 2015 at 21:37, Shahab Sharifzadeh sshguard@ymail.com wrote:

If I understand you correctly, you need to make your user "privileged."
Unprivileged users are forced to use the Self Service area.

I don’t know what you mean by ‘edit “username” to “user”’. Are you trying
to change the visible wording on the login page?

Yes i want to change visible wording on the login page.

i have changed permission RT_SitecConfig.pm (775 & 777) but it doesn’t
work.

what i have to do?

HiI do everything that you say and i do your instructions but my problem is yet.Your solution didnt work correctly for me,please give me another solution.

I have to say that by your solution i could change and edit the word " username" to “user” in login page but after this, every user (even root) i have redirected to selfservice page.i think that every user even ROOT change to the unpreviledge user or my connection to DB was disconnected.On Tuesday, January 27, 2015 5:19 PM, Shahab Sharifzadeh sshguard@ymail.com wrote:

HiI do everything that you say and i do your instructions but my problem is yet.Your solution didnt work correctly for me,please give me another solution.

That is very strange. User “root” should not redirect to Self Service.
Perhaps your DB has in fact been corrupted somehow. Maybe someone else can
offer another solution.On 28 Jan 2015 1:03 am, “Shahab Sharifzadeh” sshguard@ymail.com wrote:

I have to say that by your solution i could change and edit the word “
username” to “user” in login page but after this, every user (even root) i
have redirected to selfservice page.
i think that every user even ROOT change to the unpreviledge user or my
connection to DB was disconnected.

On Tuesday, January 27, 2015 5:19 PM, Shahab Sharifzadeh < sshguard@ymail.com> wrote:

Hi
I do everything that you say and i do your instructions but my problem is
yet.
Your solution didnt work correctly for me,please give me another solution.

now what i have to do?when i edit login page all of my users even root was redirected to selfservice page.On Tuesday, January 27, 2015 11:13 PM, Alex Peters alex@peters.net wrote:

That is very strange. User “root” should not redirect to Self Service. Perhaps your DB has in fact been corrupted somehow. Maybe someone else can offer another solution.On 28 Jan 2015 1:03 am, “Shahab Sharifzadeh” sshguard@ymail.com wrote:

I have to say that by your solution i could change and edit the word " username" to “user” in login page but after this, every user (even root) i have redirected to selfservice page.i think that every user even ROOT change to the unpreviledge user or my connection to DB was disconnected.

 On Tuesday, January 27, 2015 5:19 PM, Shahab Sharifzadeh <sshguard@ymail.com> wrote:

HiI do everything that you say and i do your instructions but my problem is yet.Your solution didnt work correctly for me,please give me another solution.

If this issue is only occurring after you modify the Login page, then you
have made an incorrect modification. Delete the copy of the Login page in
the “local” directory, clean the Mason cache, restart RT and try again.

If the issue still occurs, then something else is wrong. Possibly the
included “rt-validator” tool will help. If not, besides deleting and
reinstalling RT, I personally don’t have any other suggestions.On 31 Jan 2015 8:56 pm, “Shahab Sharifzadeh” sshguard@ymail.com wrote:

now what i have to do?
when i edit login page all of my users even root was redirected to
selfservice page
.

On Tuesday, January 27, 2015 11:13 PM, Alex Peters alex@peters.net wrote:

That is very strange. User “root” should not redirect to Self Service.
Perhaps your DB has in fact been corrupted somehow. Maybe someone else can
offer another solution.
On 28 Jan 2015 1:03 am, “Shahab Sharifzadeh” sshguard@ymail.com wrote:

I have to say that by your solution i could change and edit the word “
username” to “user” in login page but after this, every user (even root) i
have redirected to selfservice page.
i think that every user even ROOT change to the unpreviledge user or my
connection to DB was disconnected.

On Tuesday, January 27, 2015 5:19 PM, Shahab Sharifzadeh < sshguard@ymail.com> wrote:

Hi
I do everything that you say and i do your instructions but my problem is
yet.
Your solution didnt work correctly for me,please give me another solution.

HiThannks for your attention,my problem had succesfully solved…This problem was from my RTOn Sunday, February 1, 2015 6:50 AM, Alex Peters alex@peters.net wrote:

If this issue is only occurring after you modify the Login page, then you have made an incorrect modification. Delete the copy of the Login page in the “local” directory, clean the Mason cache, restart RT and try again.If the issue still occurs, then something else is wrong. Possibly the included “rt-validator” tool will help. If not, besides deleting and reinstalling RT, I personally don’t have any other suggestions.On 31 Jan 2015 8:56 pm, “Shahab Sharifzadeh” sshguard@ymail.com wrote:

now what i have to do?when i edit login page all of my users even root was redirected to selfservice page.

 On Tuesday, January 27, 2015 11:13 PM, Alex Peters <alex@peters.net> wrote:

That is very strange. User “root” should not redirect to Self Service. Perhaps your DB has in fact been corrupted somehow. Maybe someone else can offer another solution.On 28 Jan 2015 1:03 am, “Shahab Sharifzadeh” sshguard@ymail.com wrote:

I have to say that by your solution i could change and edit the word " username" to “user” in login page but after this, every user (even root) i have redirected to selfservice page.i think that every user even ROOT change to the unpreviledge user or my connection to DB was disconnected.

 On Tuesday, January 27, 2015 5:19 PM, Shahab Sharifzadeh <sshguard@ymail.com> wrote:

HiI do everything that you say and i do your instructions but my problem is yet.Your solution didnt work correctly for me,please give me another solution.