Problem getting fcgi to work with new RT 5.0.2 installation

I’m having a problem getting my Ubuntu 22.04 LTS with Apache 2.4 working with the fcgi configuration.

I get the basic “You’re almost there” RT web page, but I haven’t figured out my problem yet.

My apache config file for rt5 is below.

Any suggestions? I think it’s just something basic that I’ve missed.

<VirtualHost rt.example.com:80>
        ErrorLog /opt/rt5/var/log/apache2.error
        TransferLog /opt/rt5/var/log/apache2.access
        LogLevel debug

        AddDefaultCharset UTF-8

        Alias /rt/NoAuth/images /opt/rt5/share/html/NoAuth/images/

        ServerName rt.example.com
        ServerAdmin admin@example.com

        #Alias /rt "/opt/rt5/share/html/"

        ScriptAlias /rt /opt/rt5/sbin/rt-server.fcgi/

        DocumentRoot "/opt/rt5/share/html"
        <Location /rt>
            Require all granted
            Options +ExecCGI
            AddHandler fcgid-script fcgi
        </Location>
</VirtualHost>

Do you have anything in the Apache error log when you try to access it?

Are you at /rt one thought is the /rt location is doing something funky

In the process of trying to figure out the problem and made try something else, it’s working now.

I switched the apache mpm to mpm_prefork and I had also enabled the apache modules proxy and proxy_fcgi.

I’m trying an installation with my Ansible script for RT installation to see if these are why it’s working.