Postfix: 405 Method Not Allowed

Hi. First of all congratulations to the team who built RT.
It’s a great tool, and I just started using it for a couple
of days.

I can’t make work the mailgate.
This is redhat-8.0 with apache-1.3.27 perl-5.8.0 rpm.
I built mod_perl-1.27 from sources. This works from the web
client, but when I try to send a mail to it I get:

status=deferred (temporary failure. Command output: An Error Occurred
================= 405 Method Not Allowed )

I htdigged the archives but I found nothing.

Please, can someone give me any hint ?
thank you for your time.

I second that. I can’t make the mailgate work either.
If I cat an email to the rt2 mailgate it sends out a “ticket created” e-mail.
If I cat an email to the rt3 mailgate I get the following:

[root@omart mqueue]# cat ray | /opt/rt3/bin/rt-mailgate --queue ‘General’ --action correspond --url http://omart.omaha.bozell.com
An Error Occurred

401 Authorization Required
[root@omart mqueue]#

And the maillog has this from e-mail sent to RT3:

Apr 8 14:29:49 omart sendmail[13898]: h38Fqma13093: to="|rt-mailgate --queue ‘General’ --action correspond --url http://omart.omaha.bozell.com", ctladdr=hrsupport@omart.omaha.bozell.com (8/0), delay=03:37:01, xdelay=00:00:01, mailer=prog, pri=570160, dsn=4.0.0, stat=Deferred: prog mailer (/usr/sbin/smrsh) exited with EX_TEMPFAIL

RHL 7.3
RT 3.0.0
Mysql 3.23.54
Perl v5.6.1
Apache 1.3.27

Ray Thompson

[Charset iso-8859-1 unsupported, filtering to ASCII…]

I second that. I can’t make the mailgate work either.
If I cat an email to the rt2 mailgate it sends out a “ticket created” e-mail.
If I cat an email to the rt3 mailgate I get the following:

[root@omart mqueue]# cat ray | /opt/rt3/bin/rt-mailgate --queue ‘General’ --action correspond --url http://omart.omaha.bozell.com
An Error Occurred

401 Authorization Required
[root@omart mqueue]#

And the maillog has this from e-mail sent to RT3:

Apr 8 14:29:49 omart sendmail[13898]: h38Fqma13093: to="|rt-mailgate --queue ‘General’ --action correspond --url http://omart.omaha.bozell.com", ctladdr=hrsupport@omart.omaha.bozell.com (8/0), delay=03:37:01, xdelay=00:00:01, mailer=prog, pri=570160,
dsn=4.0.0, stat=Deferred: prog mailer (/usr/sbin/smrsh) exited with EX_TEMPFAIL

RHL 7.3
RT 3.0.0
Mysql 3.23.54
Perl v5.6.1
Apache 1.3.27


Ray Thompson

-----Original Message-----
From: rt-users-admin@lists.fsck.com
[mailto:rt-users-admin@lists.fsck.com] On Behalf Of Francesc
Guasch Ortiz
Sent: Tuesday, April 08, 2003 2:25 PM
To: rt-users@lists.fsck.com
Subject: [rt-users] postfix: 405 Method Not Allowed

Hi. First of all congratulations to the team who built RT.
It’s a great tool, and I just started using it for a couple
of days.

I can’t make work the mailgate.
This is redhat-8.0 with apache-1.3.27 perl-5.8.0 rpm.
I built mod_perl-1.27 from sources. This works from the web
client, but when I try to send a mail to it I get:

status=deferred (temporary failure. Command output: An
Error Occurred
================= 405 Method Not Allowed )

I htdigged the archives but I found nothing.

Please, can someone give me any hint ?
thank you for your time.


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-> users

Have you
read the FAQ? The RT FAQ Manager lives at
http://fsck.com/rtfm


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

Hi, This problem has been handled before. I had the same problem when moving from rt2 to rt3.

It’s the Apache config which probably still contains a “Filematch” directive from the RT2 install.

Read the README or the 3.0 draftmanual where you will see in the install section that the Apache config has
changed slightly.

Hope this help

Jansen Robert
Network Manager VUB, Brussels, Belgium, Europe.

Hi, This problem has been handled before. I had the same
problem when moving from rt2 to rt3.

It’s the Apache config which probably still contains a
"Filematch" directive from the RT2 install.

Read the README or the 3.0 draftmanual where you will see in
the install section that the Apache config has
changed slightly.

Hope this help

Read both the README and the draftmanual.
The closest thing I found in the archives is http://lists.fsck.com/pipermail/rt-devel/2003-March/003504.html but that ended up being an SSL thing.

I search for Filematch in httpd.conf but didn’t find any reference.
Blurb from httpd.conf:

<VirtualHost 144.210.2.242>
ServerName omart.omaha.bozell.com
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl
ErrorLog logs/error_log_rt3
CustomLog logs/access_log_rt3 combined
PerlFreshRestart On

<Location />
    SetHandler perl-script
    PerlHandler RT::Mason
    AuthName "RT Web Users"
    AuthType Basic
    AuthLDAPURL ldap://chidir1.truenorth.com/o=True North?uid?sub
    require valid-user
</Location>

[root@omart etc]# diff RT_Config.pm RT_SiteConfig.pm
27c27
< Set($rtname , “example.com”);

Set($rtname , “IPG Shared Services”);
33c33
< Set($Organization , “example.com”);
Set($Organization , “interpublic.com”);
41c41
< Set($Timezone , ‘US/Eastern’);
Set($Timezone , ‘US/Central’);
57,58c57,60
< Set($DatabaseHost , ‘localhost’);
< Set($DatabaseRTHost , ‘localhost’);
#Set($DatabaseHost , ‘localhost’);
#Set($DatabaseRTHost , ‘localhost’);
Set($DatabaseHost , ‘’);
Set($DatabaseRTHost , ‘’);
68c70
< Set($DatabasePassword , ‘rt_pass’);
Set($DatabasePassword , ‘foo-bar’);
153c155
< Set($SenderMustExistInExternalDatabase , undef);
Set($SenderMustExistInExternalDatabase , ‘true’);
167c169
< Set($CorrespondAddress , ‘RT::CorrespondAddress.not.set’);
Set($CorrespondAddress , ‘RT::hrsupport.omart.omaha.bozell.com’);
169c171
< Set($CommentAddress , ‘RT::CommentAddress.not.set’);
Set($CommentAddress , ‘RT::hrsupport-comment.omart.omaha.bozell.com’);
252c254
< Set($WebBaseURL , “http://RT::WebBaseURL.not.configured:80”);
Set($WebBaseURL , “http://omart.omaha.bozell.com”);
275c277
< Set($WebExternalAuth , undef);
Set($WebExternalAuth , ‘true’);
280c282
< Set($WebFallbackToInternalAuth , undef);
Set($WebFallbackToInternalAuth , ‘false’);
290c292
< Set($WebExternalAuto , undef);
Set($WebExternalAuto , “true”);
[root@omart etc]#

“RT” == Ray Thompson rthompson@interpublic.com writes:

RT>
RT> SetHandler perl-script
RT> PerlHandler RT::Mason
RT> AuthName "RT Web Users"
RT> AuthType Basic
RT> AuthLDAPURL ldap://chidir1.truenorth.com/o=True North?uid?sub
RT> require valid-user
RT>

So every single page on your rt web site requires authorization,
even the stuff inside /NoAuth/.

Did you give credentials to the mailgate program to pass this
requirement? I don’t even know if you can do that…

oh, my copy of XP showed up today :)On Tue, Apr 08, 2003 at 05:39:23PM -0400, Vivek Khera wrote:

“RT” == Ray Thompson rthompson@interpublic.com writes:

RT>
RT> SetHandler perl-script
RT> PerlHandler RT::Mason
RT> AuthName "RT Web Users"
RT> AuthType Basic
RT> AuthLDAPURL ldap://chidir1.truenorth.com/o=True North?uid?sub
RT> require valid-user
RT>

So every single page on your rt web site requires authorization,
even the stuff inside /NoAuth/.

Did you give credentials to the mailgate program to pass this
requirement? I don’t even know if you can do that…


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

http://www.bestpractical.com/rt – Trouble Ticketing. Free.

RT>
RT> SetHandler perl-script
RT> PerlHandler RT::Mason
RT> AuthName "RT Web Users"
RT> AuthType Basic
RT> AuthLDAPURL ldap://chidir1.truenorth.com/o=True
North?uid?sub
RT> require valid-user
RT>

So every single page on your rt web site requires
authorization, even the stuff inside /NoAuth/.

That was it. I removed the LDAP auth requirements and was spam’d with AutoReplys from all of my test e-mails that had queued up.

Thank you for the insight. Or pointing out the obvious… :slight_smile:

Robert Jansen wrote:

Hi Robert, Ray and the others who answered. Thank you for trying
but I still can’t make it work.

From: rt-users-admin@lists.fsck.com
[mailto:rt-users-admin@lists.fsck.com] On Behalf Of Francesc
Guasch Ortiz

I can’t make work the mailgate.
This is redhat-8.0 with apache-1.3.27 perl-5.8.0 rpm.
I built mod_perl-1.27 from sources. This works from the web
client, but when I try to send a mail to it I get:

status=deferred (temporary failure. Command output: An
Error Occurred
================= 405 Method Not Allowed )

Hi, This problem has been handled before. I had the same problem when moving from rt2 to rt3.
It’s the Apache config which probably still contains a “Filematch” directive from the RT2 install.

I haven’t upgraded, this is a fresh installataion of RT3.0

Read the README or the 3.0 draftmanual where you will see in the install section that the Apache config has
changed slightly.

I followed the draftmanual when I installed it.

I had a problem and I can’t run RT from the VirtualHost, so the
whole site serves the RT. I hope this isn’t what brings the
problem. I have built some mod_perl servers before.

Instead of putting the directives in the VirtualHost, I changed
the global variables. This is what I got:

ServerName theserver.name.com
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

Options FollowSymLinks AllowOverride None

PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl
DirectoryIndex index.html

AddHandler perl-script .html PerlHandler RT::Mason Options Indexes

I didn’t copied here some default config parameters
from the redhat rpm installation.

What am I missing ?

Ray Thompson escribi�::

AddHandler perl-script .html

Maybe try
SetHandler perl-script
Instead of
AddHandler perl-script .html

Great ! it worked.
Thank you very much, Ray.