Post install permission problems


#1

After installing rt-1.0.7 I get an error any time I try to connect
via the cli or the web interface. (relevant info below)
This problem
is mentioned in the archives here
http://lists.fsck.com/pipermail/rt-users/2001-March/001836.html
with no resolution.

I gave the rt user absolute permissions in mysql just to make sure.
but I still see this in the apache error_logs.

Mysql->connect(database=rt;host=localhost) failed: Access denied for
user: ‘rt@loc
alhost’ (Using password: YES) at /usr/local/rt/lib/rt/database.pm line
24
[connectdb] Database connect failed: Access denied for user:
‘rt@localhost’ (Using
password: YES)
Compilation failed in require at /usr/local/rt/lib/rt/ui/web/auth.pm
line 9.
Compilation failed in require at /usr/local/rt/bin/rtmux.pl line 57.
[Mon May 7 17:04:48 2001] [error] [client 127.0.0.1] Premature end of
script head
ers: /usr/local/rt/bin/cgi/admin-webrt.cgi

I even tried opening the permissions up on the dir structure. As well as
checking
user and group level perms
.

Relevant info.

./bin/mysqld Ver 3.23.37 for pc-linux-gnu on i686
erver version: Apache/1.3.19 (Unix)
Server built: May 7 2001 15:19:54
[root@faust mysql]# /usr/local/apache/bin/httpd -l
Compiled-in modules:
http_core.c
mod_env.c
mod_log_config.c
mod_mime.c
mod_negotiation.c
mod_status.c
mod_include.c
mod_autoindex.c
mod_dir.c
mod_cgi.c
mod_asis.c
mod_imap.c
mod_actions.c
mod_userdir.c
mod_alias.c
mod_access.c
mod_auth.c
mod_so.c
mod_setenvif.c
mod_ssl.c
mod_perl.c
mod_dav.c
mod_php4.c
suexec: enabled; valid wrapper /usr/local/apache/bin/suexec

./testdeps.pl -warn
Checking for DBI…found
Checking for Digest::MD5…found
Checking for CGI 2.71 …found
Checking for CGI::Cookie 1.16 …found

Thanks in advance… I’ve been beating my brains out on this.

Edward Brookhouse
ebrookhouse@phillips.com


#2

for kicks, try “mysqladmin reload” from root’s shell.

also, does mysql -u rt -p rt
(it will prompt you for rt’s mysql password)

Does your rt mysql password include any shell metacharacters?

    -jOn Mon, May 07, 2001 at 05:19:46PM -0400, EB wrote:

After installing rt-1.0.7 I get an error any time I try to connect
via the cli or the web interface. (relevant info below)
This problem
is mentioned in the archives here
http://lists.fsck.com/pipermail/rt-users/2001-March/001836.html
with no resolution.

I gave the rt user absolute permissions in mysql just to make sure.
but I still see this in the apache error_logs.

Mysql->connect(database=rt;host=localhost) failed: Access denied for
user: ‘rt@loc
alhost’ (Using password: YES) at /usr/local/rt/lib/rt/database.pm line
24
[connectdb] Database connect failed: Access denied for user:
‘rt@localhost’ (Using
password: YES)
Compilation failed in require at /usr/local/rt/lib/rt/ui/web/auth.pm
line 9.
Compilation failed in require at /usr/local/rt/bin/rtmux.pl line 57.
[Mon May 7 17:04:48 2001] [error] [client 127.0.0.1] Premature end of
script head
ers: /usr/local/rt/bin/cgi/admin-webrt.cgi

I even tried opening the permissions up on the dir structure. As well as
checking
user and group level perms
.

Relevant info.

./bin/mysqld Ver 3.23.37 for pc-linux-gnu on i686
erver version: Apache/1.3.19 (Unix)
Server built: May 7 2001 15:19:54
[root@faust mysql]# /usr/local/apache/bin/httpd -l
Compiled-in modules:
http_core.c
mod_env.c
mod_log_config.c
mod_mime.c
mod_negotiation.c
mod_status.c
mod_include.c
mod_autoindex.c
mod_dir.c
mod_cgi.c
mod_asis.c
mod_imap.c
mod_actions.c
mod_userdir.c
mod_alias.c
mod_access.c
mod_auth.c
mod_so.c
mod_setenvif.c
mod_ssl.c
mod_perl.c
mod_dav.c
mod_php4.c
suexec: enabled; valid wrapper /usr/local/apache/bin/suexec

./testdeps.pl -warn
Checking for DBI…found
Checking for Digest::MD5…found
Checking for CGI 2.71 …found
Checking for CGI::Cookie 1.16 …found

Thanks in advance… I’ve been beating my brains out on this.

Edward Brookhouse
ebrookhouse@phillips.com

jesse reed vincent – root@eruditorum.orgjesse@fsck.com
70EBAC90: 2A07 FC22 7DB4 42C1 9D71 0108 41A3 3FB3 70EB AC90

“Bother,” said Pooh, “Eeyore, ready two photon torpedoes and lock
phasers on the Heffalump, Piglet, meet me in transporter room three”


#3

Tried it just for grins, then removed the mysql installation and
re-installed. Fresh new rt db, and still same error exactly.

the mysql -u rt -p rt drops me to the monitor…

thanks though …

E

#-----Original Message-----
#From: Jesse [mailto:jesse@fsck.com]
#Sent: Monday, May 07, 2001 5:55 PM
#To: EB
#Cc: rt-users@lists.fsck.com
#Subject: Re: [rt-users] Post install permission problems
#for kicks, try “mysqladmin reload” from root’s shell.
#also, does mysql -u rt -p rt
#(it will prompt you for rt’s mysql password)
#Does your rt mysql password include any shell metacharacters?

-j

#On Mon, May 07, 2001 at 05:19:46PM -0400, EB wrote:
#> After installing rt-1.0.7 I get an error any time I try to connect
#> via the cli or the web interface. (relevant info below) � This problem
#> is mentioned in the archives here
#> http://lists.fsck.com/pipermail/rt-users/2001-March/001836.html
#> with no resolution.
#>
#> I gave the rt user absolute permissions in mysql just to make sure.
#> but I still see this in the apache error_logs.
#>
#> Mysql->connect(database=rt;host=localhost) failed: Access denied for
#> user: ‘rt@loc
#> alhost’ (Using password: YES) at /usr/local/rt/lib/rt/database.pm line
#> 24
#> [connectdb] Database connect failed: Access denied for user:
#> ‘rt@localhost’ (Using
#> password: YES)
#> Compilation failed in require at /usr/local/rt/lib/rt/ui/web/auth.pm
#> line 9.
#> Compilation failed in require at /usr/local/rt/bin/rtmux.pl line 57.
#> [Mon May 7 17:04:48 2001] [error] [client 127.0.0.1] Premature end of
#> script head
#> ers: /usr/local/rt/bin/cgi/admin-webrt.cgi
#>
#> I even tried opening the permissions up on the dir structure. As well as
#> checking
#> user and group level perms�.
#>
#>
#> Relevant info.
#>
#> ./bin/mysqld Ver 3.23.37 for pc-linux-gnu on i686
#> erver version: Apache/1.3.19 (Unix)
#> Server built: May 7 2001 15:19:54
#> [root@faust mysql]# /usr/local/apache/bin/httpd -l
#> Compiled-in modules:
#> http_core.c
#> mod_env.c
#> mod_log_config.c
#> mod_mime.c
#> mod_negotiation.c
#> mod_status.c
#> mod_include.c
#> mod_autoindex.c
#> mod_dir.c
#> mod_cgi.c
#> mod_asis.c
#> mod_imap.c
#> mod_actions.c
#> mod_userdir.c
#> mod_alias.c
#> mod_access.c
#> mod_auth.c
#> mod_so.c
#> mod_setenvif.c
#> mod_ssl.c
#> mod_perl.c
#> mod_dav.c
#> mod_php4.c
#> suexec: enabled; valid wrapper /usr/local/apache/bin/suexec
#>
#>
#> ./testdeps.pl -warn
#> Checking for DBI…found
#> Checking for Digest::MD5…found
#> Checking for CGI 2.71 …found
#> Checking for CGI::Cookie 1.16 …found
#>
#>
#>
#>
#> Thanks in advance… I�ve been beating my brains out on this.
#>
#>
#>
#> Edward Brookhouse
#> ebrookhouse@phillips.com
#>
#jesse reed vincent – root@eruditorum.orgjesse@fsck.com
#70EBAC90: 2A07 FC22 7DB4 42C1 9D71 0108 41A3 3FB3 70EB AC90
#“Bother,” said Pooh, “Eeyore, ready two photon torpedoes and lock
#phasers on the Heffalump, Piglet, meet me in transporter room three”