POST/GET errors when using RT

Hi,

it took me quite some time to get the configuration of RT as I needed
it. Except for 2 issues, it now works fine for me. But these two issues
are really annoying.

First, there are a whole lot of POST/GET error messages coming up. Lots
of clicks end up in an error page, that looks like coming from apache to
me, saying that there is a “Proxy Error” and “The proxy server could not
handle the request GET /rt2/NoAuth/webrt.css.”. Reason stated is
"Document contains no data". Pressing the back button on my browser gets
me to the page I called. Sometimes, pressing “Back” has to be redone
several times.

Second, I still can’t go to all those pages called "index.html"
directly. Doing any action, that would go to one of these pages only
shows me the content of the directory the page comes from. Clicking on
the index.html entry brings me to the desired page, but all parameters
are lost. This is really annoying. I’m sure that there is something
wrong either in my apache or RT configuration, but I can’t figure out,
what it is.

My configuration is Mandrake 7.2, Perl 5.6.0, Apache 1.3.14, RT 2.0.8

httpd.conf:

ProxyPass /perl/ http://127.0.0.1:8200/
ProxyPass /rt2/ http://127.0.0.1:8200/rt2/
ProxyPass /rt2 http://127.0.0.1:8200/rt2/
ProxyPassReverse /perl/ http://127.0.0.1:8200/
ProxyPassReverse /rt2/ http://127.0.0.1:8200/rt2/
ProxyPassReverse /rt2 http://127.0.0.1:8200/rt2/

httpd-perl.conf:

Alias /icons/ /var/www/icons/
Alias /rt2 /opt/rt2/WebRT/html
PerlModule Apache::DBI
PerlFreshRestart On
PerlRequire /opt/rt2/bin/webmux.pl
<Location /rt2>
    DirectoryIndex index.html
    SetHandler perl-script
    PerlHandler RT::Mason
    Options +Indexes
</Location>

Several locations of “Options +Indexes” and "DirectoryIndex index.html"
have been tested, but none of them worked.

Please help. I really like using RT , but these problem drive me crazy.

Thanks,

Thorsten

First, there are a whole lot of POST/GET error messages coming up. Lots
of clicks end up in an error page, that looks like coming from apache to
me, saying that there is a “Proxy Error” and “The proxy server could not
handle the request GET /rt2/NoAuth/webrt.css.”. Reason stated is
"Document contains no data". Pressing the back button on my browser gets
me to the page I called. Sometimes, pressing “Back” has to be redone
several times.

I have a feeling this is due to the segfault problem that has plauged

prebuilt RPM installs of Apache when used with RT… To the best of my
knowledge, noone has tracked down the issue completely, other than compiling
apache, perl, modperl, etc from source. This seems to solve that problem.

Second, I still can’t go to all those pages called "index.html"
directly. Doing any action, that would go to one of these pages only
shows me the content of the directory the page comes from. Clicking on
the index.html entry brings me to the desired page, but all parameters
are lost. This is really annoying. I’m sure that there is something
wrong either in my apache or RT configuration, but I can’t figure out,
what it is.

This problem seems to be with the indexing directives in your apache

configuration… If you have mod_dir enabled make sure you have a line
similar to the following in your httpd.conf file… ps, note the presence of
index.html…

DirectoryIndex index.html index.htm index.php index.php3

Jay Kramer

My configuration is Mandrake 7.2, Perl 5.6.0, Apache 1.3.14, RT 2.0.8

httpd.conf:

ProxyPass /perl/ http://127.0.0.1:8200/
ProxyPass /rt2/ http://127.0.0.1:8200/rt2/
ProxyPass /rt2 http://127.0.0.1:8200/rt2/
ProxyPassReverse /perl/ http://127.0.0.1:8200/
ProxyPassReverse /rt2/ http://127.0.0.1:8200/rt2/
ProxyPassReverse /rt2 http://127.0.0.1:8200/rt2/

httpd-perl.conf:

Alias /icons/ /var/www/icons/
Alias /rt2 /opt/rt2/WebRT/html
PerlModule Apache::DBI
PerlFreshRestart On
PerlRequire /opt/rt2/bin/webmux.pl
<Location /rt2>
    DirectoryIndex index.html
    SetHandler perl-script
    PerlHandler RT::Mason
    Options +Indexes
</Location>

Several locations of “Options +Indexes” and "DirectoryIndex index.html"
have been tested, but none of them worked.

Please help. I really like using RT , but these problem drive me crazy.

Thanks,

Thorsten
��������������������������������������z�&j)bz
b��������S�l��"�(sem���-±ï¿½ï¿½ï¿½rOÜ¢o�j)fj�S�b��?�����