Permissions for saved search on RT at a Glance

Hi,

I have a new install of RT and would like to change the default
RT-at-a-Glance for everyone.

I followed the instructions on the wiki here and I have it working for
the root user.
http://wiki.bestpractical.com/view/ChangeDefaultRTAtAGlance

I created a ‘support’ group and added 4 users to that group.
I also created an ‘Approvers’ group but no-one is in that yet.

I saved my custom query as ‘RT System saved searches > My Service Requests’.

In Config > Groups > ‘Support’ > Group Rights
I added ‘ShowSavedSearches’ to both the ‘System Privileged’ group and
the ‘User defined - Support’ group.

Unfortunately I get the error “Predefined search My Service Requests not
found” when logging in as the Support user Phil.

Have I missed something simple with my Permissions settings?

Thanks in advance,

Alister

Alister West alister@gossamer-threads.com
w: http://www.gossamer-threads.com

I found my Permission setting and now everything works as expected.

It was the global config that I needed to change.

Config > Global > Groups > Privileged > ShowSavedSearches.

I have updated the wiki to make this more clear.
http://wiki.bestpractical.com/view/ChangeDefaultRTAtAGlance

Cheers,

Alister West alister@gossamer-threads.comOn 10-08-20 10:58 AM, Alister West wrote:

Hi,

I have a new install of RT and would like to change the default
RT-at-a-Glance for everyone.

I followed the instructions on the wiki here and I have it working for
the root user.
http://wiki.bestpractical.com/view/ChangeDefaultRTAtAGlance

I created a ‘support’ group and added 4 users to that group.
I also created an ‘Approvers’ group but no-one is in that yet.

I saved my custom query as ‘RT System saved searches > My Service
Requests’.

In Config > Groups > ‘Support’ > Group Rights
I added ‘ShowSavedSearches’ to both the ‘System Privileged’ group and
the ‘User defined - Support’ group.

Unfortunately I get the error “Predefined search My Service Requests not
found” when logging in as the Support user Phil.

Have I missed something simple with my Permissions settings?

Thanks in advance,

Alister

Alister,

What we did was grant all the Search privileges (Show, Save, Modify,
etc) *Globally
to all “Privileged” *
Users. This did NOT affect Personal Searches. For Groups, it allows those
rights IF AND ONLY IF they are a member of said group. By doing it this
way, we saved ourselves a WHOLE BUNCH of maintenance.

Just a thought on rights management.

Kenn
LBNLOn Fri, Aug 20, 2010 at 11:24 AM, Alister West <alister@gossamer-threads.com wrote:

I found my Permission setting and now everything works as expected.

It was the global config that I needed to change.

Config > Global > Groups > Privileged > ShowSavedSearches.

I have updated the wiki to make this more clear.

http://wiki.bestpractical.com/view/ChangeDefaultRTAtAGlance

Cheers,

Alister West alister@gossamer-threads.com

On 10-08-20 10:58 AM, Alister West wrote:

Hi,

I have a new install of RT and would like to change the default
RT-at-a-Glance for everyone.

I followed the instructions on the wiki here and I have it working for
the root user.
http://wiki.bestpractical.com/view/ChangeDefaultRTAtAGlance

I created a ‘support’ group and added 4 users to that group.
I also created an ‘Approvers’ group but no-one is in that yet.

I saved my custom query as ‘RT System saved searches > My Service
Requests’.

In Config > Groups > ‘Support’ > Group Rights
I added ‘ShowSavedSearches’ to both the ‘System Privileged’ group and
the ‘User defined - Support’ group.

Unfortunately I get the error “Predefined search My Service Requests not
found” when logging in as the Support user Phil.

Have I missed something simple with my Permissions settings?

Thanks in advance,

Alister

RT Training in Washington DC, USA on Oct 25 & 26 2010
Last one this year – Learn how to get the most out of RT!