Permission Denied to one user to create new ticket via email

We are using RT5.0.2
One xyz user was added to one Queue and was able to perform all kind of operations. Couple of months ago this user change the department and we have to remove this user from the queue.
Now this user tried to create a ticket via email but system denied her request.

Everyone else is able to create tickets with no issues via email.

[116272] [Mon Jan 24 18:58:59 2022] [crit]: Failed attempt to create a ticket by email, from attempted to create a ticket via email in the queue DEVREQ; you might need to grant ‘Everyone’ the CreateTicket right. (/opt/rt5/sbin/…/lib/RT/Interface/

[116272] [Mon Jan 24 18:59:00 2022] [crit]: Permission Denied: has no right to create tickets in queue DEVREQ (/opt/rt5/sbin/…/lib/RT/Interface/

Please suggest.

You need top grant the user the create ticket right for that queue

Thank you Knation for the response. Can you please elaborate where to go in the menu and give this rights?

You can do it globally Admin->Global->Group rights/User rights or per queue Admin->Queues->Some queue-> User/Group rights

I have tried to add rights for this user but system says “Invalid Username”. I have checked in the database table “users” and see the user entry there.

Does autocomplete show an option for the user you’re trying to add rights for?

No, the autocomplete doesn’t show any.

If you search the user on the Admin->Users page make sure to search ‘all’ in the Include section and maybe disabled to make sure the user is actually there and active?

There also I can’t see this user. Did removing her from the queue made something wrong?

My guess is that the user is not enabled or not privileged and your search is limiting based on one of those two values. Can you confirm that you’re

If you limit the scope to 'Include:Privileged" do they still show up?
I.e. under Access Control for the user is “Let this user be granted rights (Privileged)” checked?
By default the Rights pages only deal with privileged users except for the unprivileged group.

Thanks for this screen shot. I now see the user is marked as “Disabled”.