Perl version

To list,

Does anyone know what the latest viable Perl versio we can use for RT
3.8.x is? We trying to get grid of a bunch of perl versions here and I
want to ensure we are using the latest for RT. Thanks.

Kenn
LBNL

To list,

Does anyone know what the latest viable Perl versio we can use for RT
3.8.x is? We trying to get grid of a bunch of perl versions here and I
want to ensure we are using the latest for RT. Thanks.

5.8.9 or 5.10.1 should be fine. 5.10.0 should be avoided.

Jesse,

Thanks.

KennOn 9/15/2009 8:47 AM, Jesse Vincent wrote:

On Tue, Sep 15, 2009 at 08:46:15AM -0700, Ken Crocker wrote:

To list,

Does anyone know what the latest viable Perl versio we can use for RT
3.8.x is? We trying to get grid of a bunch of perl versions here and I
want to ensure we are using the latest for RT. Thanks.

5.8.9 or 5.10.1 should be fine. 5.10.0 should be avoided.


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

To list,

Does anyone know what the latest viable Perl versio we can use for RT
3.8.x is? We trying to get grid of a bunch of perl versions here and I
want to ensure we are using the latest for RT. Thanks.

5.8.9 or 5.10.1 should be fine. 5.10.0 should be avoided.

Could you give any more information on this? I ask because we’re
supporting users running RT 3.6 in Debian stable with Perl 5.10.0,
as well as RT 3.6 in Debian oldstable with Perl 5.8.8,
and I’m curious as to what possible problems we might be in for
(though we’ve seen none).

Here at work we’re also running RT 3.8 with perl 5.8.8 and haven’t
seen any problems.

Cheers,
Dominic.

Dominic Hargreaves, Systems Development and Support Team
Computing Services, University of Oxford

Could you give any more information on this? I ask because we’re
supporting users running RT 3.6 in Debian stable with Perl 5.10.0,
as well as RT 3.6 in Debian oldstable with Perl 5.8.8,
and I’m curious as to what possible problems we might be in for
(though we’ve seen none).

Here at work we’re also running RT 3.8 with perl 5.8.8 and haven’t
seen any problems.

He did ask about ‘latest’ versions :wink: Anything 5.8.3 or newer should
work just fine. 5.8.3-5.8.9 are all great.

5.10.0 shipped with…many bugs and inconsitencies. When last I looked,
debian’s 5.10.0 is somewhat patched up for the worst of these. I
wouldn’t worry about running RT on Debian 5.10.0. But if you’re
sourcebuilding a new perl for RT, my recommendation would be to skip
vanilla 5.10.0.