Perl install problems

I’m having some issues getting rt installed on my box. I’m using apache
2.0.51 on fedora core1 with Mod Perl 2

I followed the Fedora core 1 install guide which I feel is lacking
something.

If I follow the guide to the letter then I get

[Thu Jul 14 09:31:57 2005] [error] failed to resolve handler `RT::Mason’
[Thu Jul 14 09:31:57 2005] [error] [client 66.62.165.53] Can’t locate
RT/Mason.pm in @INC (@INC contains:
/usr/lib/perl5/5.8.3/i386-linux-thread-multi /usr/lib/perl5/5.8.3
/usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.2/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.1/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2
/usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0
/usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.2/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.1/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.3 /usr/lib/perl5/vendor_perl/5.8.2
/usr/lib/perl5/vendor_perl/5.8.1 /usr/lib/perl5/vendor_perl/5.8.0
/usr/lib/perl5/vendor_perl . /etc/httpd/ /etc/httpd/lib/perl) at (eval 8)
line 3.\n

While this doesn’t stop apache from operating it doesn’t let RT run either.I
figured this came from the lack of

PerlRequire /usr/local/rt3/bin/webmux.pl

In the conf.d/rt.conf

So I added that line, then I would get:

[Thu Jul 14 09:02:30 2005] [error] Can’t locate Apache.pm in @INC (@INC
contains: /usr/lib/perl5/5.8.3/i386-linux-thread-multi /usr/lib/perl5/5.8.3
/usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.2/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.1/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2
/usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0
/usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.2/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.1/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.3 /usr/lib/perl5/vendor_perl/5.8.2
/usr/lib/perl5/vendor_perl/5.8.1 /usr/lib/perl5/vendor_perl/5.8.0
/usr/lib/perl5/vendor_perl . /etc/httpd/ /etc/httpd/lib/perl) at
/usr/lib/perl5/5.8.3/CGI.pm line 190.\nCompilation failed in require at
/usr/local/rt3/bin/webmux.pl line 56.\nBEGIN failed–compilation aborted at
/usr/local/rt3/bin/webmux.pl line 56.\nCompilation failed in require at
(eval 1) line 1.\n
[Thu Jul 14 09:02:30 2005] [error] Can’t load Perl file:
/usr/local/rt3/bin/webmux.pl for server rt.garnetweb.com:80, exiting…\n

I’m really lost as to which way to proceed on this one. I installed your
system about 2 years ago, and was pretty happy with it, and would like to
get it running again.

Here is my conf.d/rt.conf commented out lines just represent attempts to
try different things. Thanks.

ServerName rt.host.com:80 ServerAdmin "email@com.com" DocumentRoot /usr/local/rt3/share/html
    <IfModule mod_ssl.c>
            SSLEngine off
    </IfModule>
       # these four lines apply to Apache2+mod_perl2 only: {{{
    PerlSetVar MasonArgsMethod CGI
    PerlModule Apache2 Apache::compat
    RewriteEngine On
    RewriteRule ^(.*)/$ $1/index.html
    # }}}

    PerlModule Apache::DBI
    #PerlRequire /usr/local/rt3/bin/webmux.pl
    <Location />
            SetHandler perl-script
            PerlHandler ModPerl::Registry
            Options ExecCGI
            #PerlHandler RT::Mason
    </Location>
    <Directory /usr/local/rt3/share/html>
            Options -Includes +ExecCGI
    </Directory>

I’m having some issues getting rt installed on my box. I’m using apache
2.0.51 on fedora core1 with Mod Perl 2

I followed the Fedora core 1 install guide which I feel is lacking
something.

If I follow the guide to the letter then I get

[Thu Jul 14 09:31:57 2005] [error] failed to resolve handler `RT::Mason’
[Thu Jul 14 09:31:57 2005] [error] [client 66.62.165.53] Can’t locate
RT/Mason.pm in @INC (@INC contains:
/usr/lib/perl5/5.8.3/i386-linux-thread-multi /usr/lib/perl5/5.8.3
/usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.2/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.1/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2
/usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0
/usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.2/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.1/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.3 /usr/lib/perl5/vendor_perl/5.8.2
/usr/lib/perl5/vendor_perl/5.8.1 /usr/lib/perl5/vendor_perl/5.8.0
/usr/lib/perl5/vendor_perl . /etc/httpd/ /etc/httpd/lib/perl) at (eval 8)
line 3.\n

While this doesn’t stop apache from operating it doesn’t let RT run either.I
figured this came from the lack of

PerlRequire /usr/local/rt3/bin/webmux.pl

In the conf.d/rt.conf

So I added that line, then I would get:

[Thu Jul 14 09:02:30 2005] [error] Can’t locate Apache.pm in @INC (@INC
contains: /usr/lib/perl5/5.8.3/i386-linux-thread-multi /usr/lib/perl5/5.8.3
/usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.2/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.1/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2
/usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0
/usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.2/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.1/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.3 /usr/lib/perl5/vendor_perl/5.8.2
/usr/lib/perl5/vendor_perl/5.8.1 /usr/lib/perl5/vendor_perl/5.8.0
/usr/lib/perl5/vendor_perl . /etc/httpd/ /etc/httpd/lib/perl) at
/usr/lib/perl5/5.8.3/CGI.pm line 190.\nCompilation failed in require at
/usr/local/rt3/bin/webmux.pl line 56.\nBEGIN failed–compilation aborted at
/usr/local/rt3/bin/webmux.pl line 56.\nCompilation failed in require at
(eval 1) line 1.\n
[Thu Jul 14 09:02:30 2005] [error] Can’t load Perl file:
/usr/local/rt3/bin/webmux.pl for server rt.garnetweb.com:80, exiting…\n

I’m really lost as to which way to proceed on this one. I installed your
system about 2 years ago, and was pretty happy with it, and would like to
get it running again.

Here is my conf.d/rt.conf commented out lines just represent attempts to
try different things. Thanks.

ServerName rt.host.com:80 ServerAdmin "email@com.com" DocumentRoot /usr/local/rt3/share/html
    <IfModule mod_ssl.c>
            SSLEngine off
    </IfModule>
       # these four lines apply to Apache2+mod_perl2 only: {{{
    PerlSetVar MasonArgsMethod CGI
    PerlModule Apache2 Apache::compat
    RewriteEngine On
    RewriteRule ^(.*)/$ $1/index.html
    # }}}

    PerlModule Apache::DBI
    #PerlRequire /usr/local/rt3/bin/webmux.pl
    <Location />
            SetHandler perl-script
            PerlHandler ModPerl::Registry
            Options ExecCGI
            #PerlHandler RT::Mason
    </Location>
    <Directory /usr/local/rt3/share/html>
            Options -Includes +ExecCGI
    </Directory>

http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Miles Scruggs wrote:

I’m having some issues getting rt installed on my box. I’m using apache
2.0.51 on fedora core1 with Mod Perl 2

With mod_perl2, you can’t rely on the standard ‘make fixdeps’ after
running configure. Re-run configure with the appropriate options, the
from the prompt run ‘perl sbin/rt-test-dependencies --with-mysql
–with-modperl2 --install’

I followed the Fedora core 1 install guide which I feel is lacking
something.

If I follow the guide to the letter then I get

[Thu Jul 14 09:31:57 2005] [error] failed to resolve handler `RT::Mason’
[Thu Jul 14 09:31:57 2005] [error] [client 66.62.165.53] Can’t locate
RT/Mason.pm in @INC (@INC contains:
/usr/lib/perl5/5.8.3/i386-linux-thread-multi /usr/lib/perl5/5.8.3
/usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.2/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.1/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2
/usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0
/usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.2/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.1/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.3 /usr/lib/perl5/vendor_perl/5.8.2
/usr/lib/perl5/vendor_perl/5.8.1 /usr/lib/perl5/vendor_perl/5.8.0
/usr/lib/perl5/vendor_perl . /etc/httpd/ /etc/httpd/lib/perl) at (eval 8)
line 3.\n

While this doesn’t stop apache from operating it doesn’t let RT run either.I
figured this came from the lack of

PerlRequire /usr/local/rt3/bin/webmux.pl

In the conf.d/rt.conf

So I added that line, then I would get:

[Thu Jul 14 09:02:30 2005] [error] Can’t locate Apache.pm in @INC (@INC
contains: /usr/lib/perl5/5.8.3/i386-linux-thread-multi /usr/lib/perl5/5.8.3
/usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.2/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.1/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2
/usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0
/usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.2/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.1/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.3 /usr/lib/perl5/vendor_perl/5.8.2
/usr/lib/perl5/vendor_perl/5.8.1 /usr/lib/perl5/vendor_perl/5.8.0
/usr/lib/perl5/vendor_perl . /etc/httpd/ /etc/httpd/lib/perl) at
/usr/lib/perl5/5.8.3/CGI.pm line 190.\nCompilation failed in require at
/usr/local/rt3/bin/webmux.pl line 56.\nBEGIN failed–compilation aborted at
/usr/local/rt3/bin/webmux.pl line 56.\nCompilation failed in require at
(eval 1) line 1.\n
[Thu Jul 14 09:02:30 2005] [error] Can’t load Perl file:
/usr/local/rt3/bin/webmux.pl for server rt.garnetweb.com:80, exiting…\n

I’m really lost as to which way to proceed on this one. I installed your
system about 2 years ago, and was pretty happy with it, and would like to
get it running again.

Here is my conf.d/rt.conf commented out lines just represent attempts to
try different things. Thanks.

ServerName rt.host.com:80 ServerAdmin "email@com.com" DocumentRoot /usr/local/rt3/share/html
   <IfModule mod_ssl.c>
           SSLEngine off
   </IfModule>
      # these four lines apply to Apache2+mod_perl2 only: {{{
   PerlSetVar MasonArgsMethod CGI
   PerlModule Apache2 Apache::compat
   RewriteEngine On
   RewriteRule ^(.*)/$ $1/index.html
   # }}}

   PerlModule Apache::DBI
   #PerlRequire /usr/local/rt3/bin/webmux.pl
   <Location />
           SetHandler perl-script
           PerlHandler ModPerl::Registry
           Options ExecCGI
           #PerlHandler RT::Mason
   </Location>
   <Directory /usr/local/rt3/share/html>
           Options -Includes +ExecCGI
   </Directory>

http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Drew Barnes
Applications Analyst
Raymond Walters College
University of Cincinnati

I’m having some issues getting rt installed on my box. I’m using apache
2.0.51 on fedora core1 with Mod Perl 2

With mod_perl2, you can’t rely on the standard ‘make fixdeps’ after
running configure. Re-run configure with the appropriate options, the
from the prompt run ‘perl sbin/rt-test-dependencies --with-mysql
–with-modperl2 --install’

That is what the docs say so that is what I did. There were no errors at
all from this. Here are the results:

[root@suburban rt3]# perl sbin/rt-test-dependencies --with-mysql
–with-modperl2 --install
NOTE: mod_perl 2.0 isn’t quite ready for prime_time just yet;
Best Practical Solutions strongly recommends that sites use
Apache 1.3 or FastCGI. If you MUST use mod_perl 2.0 (or 1.99),
please read the mailing list archives before asking for help.
perl:
5.8.3users:
rt group (rt)…found
bin owner (root)…found
libs owner (root)…found
libs group (bin)…found
web owner (apache)…found
web group (apache)…found
MASON dependencies:
CLI dependencies:
DEV dependencies:
MODPERL2 dependencies:
MYSQL dependencies:
MAILGATE dependencies:
CORE dependencies:

I would really appreciate it if someone could help me out, I have dug
through the docs, and haven’t received much help from this list

Please someone help me, I really would like to use this system but I need to
get it working first.

I’m having some issues getting rt installed on my box. I’m using apache
2.0.51 on fedora core1 with Mod Perl 2

With mod_perl2, you can’t rely on the standard ‘make fixdeps’ after
running configure. Re-run configure with the appropriate options, the
from the prompt run ‘perl sbin/rt-test-dependencies --with-mysql
–with-modperl2 --install’

I did this. And everything checks out.

Quoting Miles Scruggs rt@garnetweb.com:

I would really appreciate it if someone could help me out, I have dug
through the docs, and haven’t received much help from this list

Please someone help me, I really would like to use this system but I need to
get it working first.

…snip…

Here is my conf.d/rt.conf commented out lines just represent attempts to
try different things. Thanks.

ServerName rt.host.com:80 ServerAdmin "email@com.com" DocumentRoot /usr/local/rt3/share/html
   <IfModule mod_ssl.c>
           SSLEngine off
   </IfModule>

I don’t use this in my setup. ^^

      # these four lines apply to Apache2+mod_perl2 only: {{{
   PerlSetVar MasonArgsMethod CGI

I do not use this line at all in mine. ^^

   PerlModule Apache2 Apache::compat
   RewriteEngine On
   RewriteRule ^(.*)/$ $1/index.html
   # }}}

   PerlModule Apache::DBI
   #PerlRequire /usr/local/rt3/bin/webmux.pl

You definitely need this line. ^^
I also put the RewriteRule here.

   <Location />
           SetHandler perl-script

Keep this. ^^

           PerlHandler ModPerl::Registry
           Options ExecCGI

I don’t use the 2 lines above this. ^^

           #PerlHandler RT::Mason

But you definitely need this. ^^

   </Location>
   <Directory /usr/local/rt3/share/html>
           Options -Includes +ExecCGI
   </Directory>

I don’t use this part… ^^