Odd behavior

Hi all,

I’m trying to install rt on a gentoo machine apache2 for the webserver.
When I logon to rt it works fine, I changed my password, but everytime I
click on some link. (ie. Configuration, Tools, Preferences) it asks me
to re-authenticate.

It’s like it’s never saving my information. I know I have cookies
enabled, other websites work fine. Any ideas as to what could be causing
the problem.


What version of RT ?? There are few postings and suggested solutions but
the only one that worked for me was :
ALTER TABLE sessions CHANGE a_session a_session LONGBLOB;
I would suggest you look up the other solutions for this mailing list
my system is also gentoo and rt-3.6.1

sfaci@gila.bioengr.uic.edu wrote:


The alter table command below solved my repeated
login problem also:

ALTER TABLE sessions CHANGE a_session a_session

In addition, I couldn’t retrieve attachments after
upgrading from 3.4.? to 3.6.1. Another poster
provided the following similar solution:

ALTER TABLE Attachments CHANGE Content Content

In both cases the previous type was LONGTEXT. I
observe in /opt/rt3/etc/mysql.schema LONGTEXT is
defined as the type for both. I have also observed
several of the posters with these problems operate
Gentoo as I do. My first guess is this is not a
Gentoo specific problem but wonder why I have not
seen such reports on other platforms.

Is this a likely bug worth reporting?



Roy El-Hames wrote:

Thanks that fixed my problem. I was running rt-3.6.1.

The only other quirk I have is that when I start the webserver it takes a
good while to start up with the -D PERL flag and once the server is
started it takes about 30 seconds for it to respond.

Though I think that’s a side issue.

Thanks a lot for the responses, it’s up and running and kicking happily.


Well I’ve had rt-3.6.0 running happily on gentoo for a good few weeks
till I decided to do update world, its then when few things started to
break, I guess its one/possibly more of the recent ebuilds are broken or
not compatible with RT … I am guessing its either DBD or Apache-session.

David Oberlitner wrote: