Not able to get RT to redirect to HTTPS site

I modified thr SSL.Conf, Httpd.conf and the RT_SiteConfig.pm to point to 443 and http and it just bombs out anyone have any Ideas. using Red Hat 7, RT 4.4.1.

Set( $DatabaseHost, ‘localhost’ );
Set( $DatabaseName, ‘rt4’ );
Set( $DatabasePassword, ‘************’ );
Set( $DatabasePort, ‘’ );
Set( $DatabaseType, ‘mysql’ );
Set( $DatabaseUser, ‘rt_user’ );
Set( $rtname, ‘SECOPS’ );
Set( $WebDomain, ‘Server’);
Set( $WebPort, ‘443’ );
Set( $WebPath, ‘’);
Set( $SendmailPath, ‘/usr/sbin/sendmail’ );
Set( $CorrespondAddress , ‘Elevate-SecAlerts@elevate.com’);
Set( $CommentAddress ,‘Elevate-SecAlerts@elevate.com’);
Set( $MaxAttachmentSize , 10000000);
Set( $FriendlyFromLineFormat, “”%s" <%s>");
Set( @Plugins, ‘RT::IR’);
Set($LogToFile , ‘debug’);
Set($LogDir, ‘/opt/rt4/var/log’);
Set($LogToFileNamed , “rt.log”);

Set( $ExternalAuthPriority, [“My_LDAP”] );
Set( $ExternalInfoPriority, [“My_LDAP”] );

# Make users created from LDAP Privileged
Set( $UserAutocreateDefaultsOnLogin, { Privileged => 1 } );

# Users should still be autocreated by RT as internal users if they
# fail to exist in an external service; this is so requestors (who
# are not in LDAP) can still be created when they email in.
Set($AutoCreateNonExternalUsers, 1);

# Minimal LDAP configuration; see RT::Authen::ExternalAuth::LDAP for
# further details and examples

Set( $ExternalSettings, {
‘My_LDAP’ => {
‘type’ => ‘ldap’,
‘server’ => ‘server.domain.com’,
‘user’ => ‘s_crp_reqtracker’,
‘pass’ => ‘***************’,
‘base’ => ‘dc=domain,dc=com’,
‘filter’ => ‘(objectClass=inetOrgPerson)’,
# Users are allowed to log in via email address or account
# name
’attr_match_list’ => [
‘Name’,
‘EmailAddress’,
],
# Import the following properties of the user from LDAP upon
# login
’attr_map’ => {
‘Name’ => ‘sAMAccountName’,
‘EmailAddress’ => ‘mail’,
‘RealName’ => ‘cn’,
‘WorkPhone’ => ‘telephoneNumber’,
‘Address1’ => ‘streetAddress’,
‘City’ => ‘l’,
‘State’ => ‘st’,
‘Zip’ => ‘postalCode’,
‘Country’ => ‘co’,
},
},

Now HTTPD.Conf

When i go to the http://servername it will redirect to the https:\Servername but this come up

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at root@localhost to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

What do Apache logs tell?

BEGIN failed–compilation aborted at /opt/rt4/local/plugins/RT-IR/lib/RT/IR.pm line 134.
Compilation failed in require at /opt/rt4/sbin/…/lib/RT.pm line 751. (/opt/rt4/sbin/…/lib/RT.pm:390)
Can’t locate Parse/BooleanLogic.pm in @INC (@INC contains: /opt/rt4/sbin/…/local/lib /opt/rt4/local/plugins/RT-IR/lib /opt/rt4/local/plugins/RT-Extension-A$
BEGIN failed–compilation aborted at /opt/rt4/local/plugins/RT-IR/lib/RT/IR.pm line 134.
Compilation failed in require at /opt/rt4/sbin/…/lib/RT.pm line 751.
[Tue May 16 05:12:44.794825 2017] [mpm_prefork:notice] [pid 6419] AH00170: caught SIGWINCH, shutting down gracefully
[Tue May 16 05:12:45.902676 2017] [suexec:notice] [pid 6536] AH01232: suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Tue May 16 05:12:45.928291 2017] [auth_digest:notice] [pid 6536] AH01757: generating secret for digest authentication …
[Tue May 16 05:12:45.928846 2017] [lbmethod_heartbeat:notice] [pid 6536] AH02282: No slotmem from mod_heartmonitor
[Tue May 16 05:12:45.953566 2017] [mpm_prefork:notice] [pid 6536] AH00163: Apache/2.4.6 (Red Hat Enterprise Linux) OpenSSL/1.0.1e-fips mod_fcgid/2.3.9 PHP/5$
[Tue May 16 05:12:45.953597 2017] [core:notice] [pid 6536] AH00094: Command line: ‘/usr/sbin/httpd -D FOREGROUND’
[6559] [Tue May 16 12:14:26 2017] [critical]: Can’t locate Parse/BooleanLogic.pm in @INC (@INC contains: /opt/rt4/sbin/…/local/lib /opt/rt4/local/plugins/R$
BEGIN failed–compilation aborted at /opt/rt4/local/plugins/RT-IR/lib/RT/IR.pm line 134.
Compilation failed in require at /opt/rt4/sbin/…/lib/RT.pm line 751. (/opt/rt4/sbin/…/lib/RT.pm:390)
Can’t locate Parse/BooleanLogic.pm in @INC (@INC contains: /opt/rt4/sbin/…/local/lib /opt/rt4/local/plugins/RT-IR/lib /opt/rt4/local/plugins/RT-Extension-A$
BEGIN failed–compilation aborted at /opt/rt4/local/plugins/RT-IR/lib/RT/IR.pm line 134.
Compilation failed in require at /opt/rt4/sbin/…/lib/RT.pm line 751.
[6571] [Tue May 16 12:14:44 2017] [critical]: Can’t locate Parse/BooleanLogic.pm in @INC (@INC contains: /opt/rt4/sbin/…/local/lib /opt/rt4/local/plugins/R$
BEGIN failed–compilation aborted at /opt/rt4/local/plugins/RT-IR/lib/RT/IR.pm line 134.
Compilation failed in require at /opt/rt4/sbin/…/lib/RT.pm line 751. (/opt/rt4/sbin/…/lib/RT.pm:390)
Can’t locate Parse/BooleanLogic.pm in @INC (@INC contains: /opt/rt4/sbin/…/local/lib /opt/rt4/local/plugins/RT-IR/lib /opt/rt4/local/plugins/RT-Extension-A$
BEGIN failed–compilation aborted at /opt/rt4/local/plugins/RT-IR/lib/RT/IR.pm line 134.
Compilation failed in require at /opt/rt4/sbin/…/lib/RT.pm line 751.
[Tue May 16 05:14:56.605397 2017] [mpm_prefork:notice] [pid 6536] AH00170: caught SIGWINCH, shutting down gracefully
[Tue May 16 05:14:57.711989 2017] [suexec:notice] [pid 6597] AH01232: suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Tue May 16 05:14:57.736298 2017] [auth_digest:notice] [pid 6597] AH01757: generating secret for digest authentication …
[Tue May 16 05:14:57.736831 2017] [lbmethod_heartbeat:notice] [pid 6597] AH02282: No slotmem from mod_heartmonitor
[Tue May 16 05:14:57.759944 2017] [mpm_prefork:notice] [pid 6597] AH00163: Apache/2.4.6 (Red Hat Enterprise Linux) OpenSSL/1.0.1e-fips mod_fcgid/2.3.9 PHP/5$
[Tue May 16 05:14:57.759973 2017] [core:notice] [pid 6597] AH00094: Command line: ‘/usr/sbin/httpd -D FOREGROUND’
[6608] [Tue May 16 12:15:04 2017] [critical]: Can’t locate Parse/BooleanLogic.pm in @INC (@INC contains: /opt/rt4/sbin/…/local/lib /opt/rt4/local/plugins/R$
BEGIN failed–compilation aborted at /opt/rt4/local/plugins/RT-IR/lib/RT/IR.pm line 134.
Compilation failed in require at /opt/rt4/sbin/…/lib/RT.pm line 751. (/opt/rt4/sbin/…/lib/RT.pm:390)
Can’t locate Parse/BooleanLogic.pm in @INC (@INC contains: /opt/rt4/sbin/…/local/lib /opt/rt4/local/plugins/RT-IR/lib /opt/rt4/local/plugins/RT-Extension-A$
BEGIN failed–compilation aborted at /opt/rt4/local/plugins/RT-IR/lib/RT/IR.pm line 134.
Compilation failed in require at /opt/rt4/sbin/…/lib/RT.pm line 751.
[6612] [Tue May 16 12:15:25 2017] [critical]: Can’t locate Parse/BooleanLogic.pm in @INC (@INC contains: /opt/rt4/sbin/…/local/lib /opt/rt4/local/plugins/R$
BEGIN failed–compilation aborted at /opt/rt4/local/plugins/RT-IR/lib/RT/IR.pm line 134.
Compilation failed in require at /opt/rt4/sbin/…/lib/RT.pm line 751. (/opt/rt4/sbin/…/lib/RT.pm:390)
Can’t locate Parse/BooleanLogic.pm in @INC (@INC contains: /opt/rt4/sbin/…/local/lib /opt/rt4/local/plugins/RT-IR/lib /opt/rt4/local/plugins/RT-Extension-A$
BEGIN failed–compilation aborted at /opt/rt4/local/plugins/RT-IR/lib/RT/IR.pm line 134.

So here is my Setup. Yet every time i try to start the Server i get this
WARNING: RT couldn’t start up a web server on port 443.
This is often the case if the port is already in use or you’re running /opt/rt4/sbin/rt-server
as someone other than your system’s “root” user. You may also specify a
temporary port with: /opt/rt4/sbin/rt-server --port
When i do a service httpd configtest it comes back Syntax OK

RT_SiteConfig.pm

Set( $DatabaseHost, ‘localhost’ );
Set( $Organization, ‘domain.com’);
Set( $DatabaseName, ‘rt4’ );
Set( $DatabasePassword, ‘Masked Password’ );
Set( $DatabasePort, ‘’ );
Set( $DatabaseType, ‘mysql’ );
Set( $DatabaseUser, ‘rt_user’ );
Set( $rtname, ‘SECOPS’ );
Set( $WebDomain, ‘Server Name’);

Set( $WebDomain, ‘X.x.x.x’ );

Set( $WebPort, ‘443’ );
Set( $WebPath, ‘’);
Set( $CorrespondAddress , ‘email@elevate.com’);
Set( $CommentAddress ,‘email@elevate.com’);
Set( $MaxAttachmentSize , 10000000);
Set( $FriendlyFromLineFormat, “”%s" <%s>");
Set( @Plugins, ‘RT::IR’);

SSL.Conf

Per-Server Logging:

The home of a custom SSL log file. Use this when you want a

compact non-error SSL logfile on a virtual host basis.

CustomLog logs/ssl_request_log
“%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x “%r” %b”

Request Tracker

ServerName server name:443
AddDefaultCharset UTF-8
DocumentRoot /opt/rt4/share/html
Alias /NoAuth/images/ /opt/rt4/share/html/NoAuth/images/
ScriptAlias / /opt/rt4/sbin/rt-server.fcgi/

Require all granted

<Directory “/opt/rt4/sbin”>
SSLOptions +StdEnvVars

HTTPD.conf

ServerName gives the name and port that the server uses to identify itself.

This can often be determined automatically, but we recommend you specify

it explicitly to prevent problems during startup.

If your host doesn’t have a registered DNS name, enter its IP address here.

#ServerName www.example.com:80
<VirtualHost *:80>
ServerName server name.com:80
Redirect / https://Server.com/

Have you tried to start RT having plugins commented out?

I did. RT starts just fine unless it goes to https://

And you get the same error when plugins disabled?

yes same error everytime. Not redirecting to HTTPS and internal server error

was this resolved? my RT after login redirects to “https/”, don’t know how to fix it

That is most likely due to Apache config having a redirect rule