No content and no logging

Everything has gone relatively smoothly with the install of rt but now I’m
having problems. When I go to the root of my the webserver I just get a blank
page and the only html source is this:

also, there is no information written to the log file (/tmp/rt.log0). The file
is created but no information is getting written to it. I’m not getting any
errors in my apache log files so I’m at a loss. Thanks for any help you can
give.

Dan

Hi Dan,

Which version of Navigator (Mozilla or other…) and OS Server do you use ?

When you run “make testdeps” the all dependencies are ok ?

Sorry for my bad english :wink:

Dan wrote:

I actually think I’ve narrowed it down a bit since my post. I don’t think
mod_perl is working correctly. I put this:

use strict;
my $r = shift;
$r->send_http_header(‘text/html’);
$r->print(“It worked!!!\n”);

into a test file and ran it and I’m still getting that same blank page and the
same html I spoke of in my original post. I’m not sure why it wouldn’t be
working, this is what I’ve added:

LoadModule perl_module lib/httpd/mod_perl.so

<Files ~ “.pl$”>
PerlHandler Apache::Registry
PerlSendHeader On
SetHandler perl-script
Options +ExecCGI

DocumentRoot /opt/rt2/WebRT/html
ServerName helpdesk.cypherus.com
PerlModule Apache::DBI
PerlFreshRestart On
PerlRequire /opt/rt2/bin/webmux.pl

SetHandler perl-script
PerlHandler RT::Mason

Ok…

Why not use this syntaxe to define mod_perl environnement :

Alias /perl/ /var/www/perl/ SetHandler perl-script PerlHandler Apache::Registry Options +ExecCGI

I found this information on the Official Mod_Perl Site
(http://perl.apache.org/docs/1.0/guide/config.html#mod_perl_Configuration)
and i use this synatxe for my intranet server (Debian 3.0 kernel 2.4.19 + Apache 1.3.26).

Regards,

MikeOn Mon, 16 Sep 2002 12:51:03 -0700 “Dan” kasper37@netzero.com wrote:

I actually think I’ve narrowed it down a bit since my post. I don’t think
mod_perl is working correctly. I put this:

use strict;
my $r = shift;
$r->send_http_header(‘text/html’);
$r->print(“It worked!!!\n”);

into a test file and ran it and I’m still getting that same blank page and the
same html I spoke of in my original post. I’m not sure why it wouldn’t be
working, this is what I’ve added:

LoadModule perl_module lib/httpd/mod_perl.so

<Files ~ “.pl$”>
PerlHandler Apache::Registry
PerlSendHeader On
SetHandler perl-script
Options +ExecCGI

DocumentRoot /opt/rt2/WebRT/html
ServerName helpdesk.cypherus.com
PerlModule Apache::DBI
PerlFreshRestart On
PerlRequire /opt/rt2/bin/webmux.pl

SetHandler perl-script
PerlHandler RT::Mason

From what I can tell that should pretty much do it.

Dan

P.S. I’m using IE 5.50.4807.2300 and make testdeps says everything is fine.

----- Original Message -----
From: “Mikael MASSON” mikael.masson@risc.fr
To: rt-users@lists.fsck.com
Sent: Monday, September 16, 2002 12:28 PM
Subject: Re: [rt-users] No content and no logging

Hi Dan,

Which version of Navigator (Mozilla or other…) and OS Server do you use ?

When you run “make testdeps” the all dependencies are ok ?

Sorry for my bad english :wink:

Dan wrote:

Everything has gone relatively smoothly with the install of rt but now I’m
having problems. When I go to the root of my the webserver I just get a
blank

page and the only html source is this:

rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

,o888b,?88888 Mikael MASSON ,8888 888 ?888 RISC Technology, France 8888888P' 888 ~~~~~~~~~~~~~~~~~~ \\ Little Debian Dragon \\ 888P' 888 Recherche & D�veloppement88 O d888 http://www.debian.org http://www.risc.fr
`?._ _.o88888 GPG Public Key :
http://pgp.mit.edu:11371/pks/lookup?op=get&search=0x81701D02