New version seems lot slower with more resources

Older setup:

RT 3.4.5 with mysql 4.0.24 and Perl 5.8.6 on V20z with 2 1.8Ghz and 4G mem

mysql> select count() from Tickets;
| count(
) |
| 406311 |
1 row in set (0.25 sec)

Newer setup:

RT 3.8.2 with mysql 5.0.75 and Perl 5.8.8 on T1000 with 24 1Ghz cpu threads
and 16GB mem

mysql> select count() from Tickets;
| count(
) |
| 401576 |
1 row in set (2.02 sec)

As you can see it is really slow

Here is my my.cnf file

[client]
port = 3306
socket = /tmp/mysql.sock
[mysqld]
port = 3306
socket = /tmp/mysql.sock
skip-locking
key_buffer = 1G
max_allowed_packet = 50M
table_cache = 512
sort_buffer_size = 4M
read_buffer_size = 2M
read_rnd_buffer_size = 256K
net_buffer_length = 2K
thread_stack = 128K
server-id = 1
skip-federated
innodb_data_home_dir = /var/opt/csw/mysql5/
innodb_data_file_path = ibdata1:2000M;ibdata2:50M:autoextend
innodb_log_group_home_dir = /var/opt/csw/mysql5/
innodb_log_arch_dir = /var/opt/csw/mysql5/
innodb_buffer_pool_size = 1G
innodb_additional_mem_pool_size = 20M
innodb_log_file_size = 250M
innodb_log_buffer_size = 20M
innodb_flush_log_at_trx_commit = 2
[mysqldump]
quick
max_allowed_packet = 50M
[mysql]
no-auto-rehash
safe-updates
[isamchk]
key_buffer = 256M
sort_buffer_size = 256M
read_buffer = 2M
write_buffer = 2M
[myisamchk]
key_buffer = 256M
sort_buffer_size = 256M
read_buffer = 2M
write_buffer = 2M
[mysqlhotcopy]
interactive-timeout

Asif Iqbal
PGP Key: 0xE62693C5 KeyServer: pgp.mit.edu
A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?

I think you find more help on mysql performance lists. It can be
kernel (io scheduler), mysql (changes in options, degradations),
innodb (concurency issues), finally it can be cold cache.On Tue, Apr 28, 2009 at 7:01 PM, Asif Iqbal vadud3@gmail.com wrote:

Older setup:

RT 3.4.5 with mysql 4.0.24 and Perl 5.8.6 on V20z with 2 1.8Ghz and 4G mem

mysql> select count() from Tickets;
±---------+
| count(
) |
±---------+
| 406311 |
±---------+
1 row in set (0.25 sec)

Newer setup:

RT 3.8.2 with mysql 5.0.75 and Perl 5.8.8 on T1000 with 24 1Ghz cpu threads
and 16GB mem

mysql> select count() from Tickets;
±---------+
| count(
) |
±---------+
| 401576 |
±---------+
1 row in set (2.02 sec)

As you can see it is really slow

Here is my my.cnf file

[client]
port = 3306
socket = /tmp/mysql.sock
[mysqld]
port = 3306
socket = /tmp/mysql.sock
skip-locking
key_buffer = 1G
max_allowed_packet = 50M
table_cache = 512
sort_buffer_size = 4M
read_buffer_size = 2M
read_rnd_buffer_size = 256K
net_buffer_length = 2K
thread_stack = 128K
server-id = 1
skip-federated
innodb_data_home_dir = /var/opt/csw/mysql5/
innodb_data_file_path = ibdata1:2000M;ibdata2:50M:autoextend
innodb_log_group_home_dir = /var/opt/csw/mysql5/
innodb_log_arch_dir = /var/opt/csw/mysql5/
innodb_buffer_pool_size = 1G
innodb_additional_mem_pool_size = 20M
innodb_log_file_size = 250M
innodb_log_buffer_size = 20M
innodb_flush_log_at_trx_commit = 2
[mysqldump]
quick
max_allowed_packet = 50M
[mysql]
no-auto-rehash
safe-updates
[isamchk]
key_buffer = 256M
sort_buffer_size = 256M
read_buffer = 2M
write_buffer = 2M
[myisamchk]
key_buffer = 256M
sort_buffer_size = 256M
read_buffer = 2M
write_buffer = 2M
[mysqlhotcopy]
interactive-timeout


Asif Iqbal
PGP Key: 0xE62693C5 KeyServer: pgp.mit.edu
A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Best regards, Ruslan.