New RT 3.4.5 install - rt-mailgate install

Greetings!

I am trying to complete a new RT install configuration.

I am down to rt-mailgate. Here’s what I have read about the configuration:

SETUP
Much of the set up of the mail gateway depends on your MTA and mail
routing configuration. However, you will need
first of all to create an RT user for the mail gateway and assign it
a password; this helps to ensure that mail
coming into the web server did originate from the gateway.

   Next, you need to route mail to "rt-mailgate" for the queues youâre

monitoring. For instance, if youâre using
/etc/aliases and you have a “bugs” queue, you will want something
like this:

       bugs:         "â/opt/rt3/bin/rt-mailgate --queue bugs --action

correspond
–url HYPERLINK
"http://rt.mycorp.com/“http://rt.mycorp.com/”

       bugs-comment: "â/opt/rt3/bin/rt-mailgate --queue bugs --action

comment
–url HYPERLINK
"http://rt.mycorp.com/“http://rt.mycorp.com/”

   Note that you donât have to run your RT server on your mail server,

as the mail gateway will happily relay to a
different machine.

That does not say how to set up the user in RT. I created a user called
mailman. This is probably where I’m going astray, but I do not see any
special settings that designate this user as the user which can receive
mail.

I added the following line to /etc/aliases:

support: "/opt/rt3/bin/rt-mailgate --queue ‘00-Incoming Email’
–action correspond --url HYPERLINK
"http://support.emcsol.com/“http://support.emcsol.com/”

and ran newaliases.

When I add the --debug option to the command, I get this:

[root@tickets bin]# /opt/rt3/bin/rt-mailgate --queue ‘00-Incoming Email’
–action correspond --url HYPERLINK
"http://support.emcsol.com"http://support.emcsol.com --debug
test
Connecting to HYPERLINK
"http://support.emcsol.com/REST/1.0/NoAuth/mail-gateway"http://support.emcso
l.com/REST/1.0/NoAuth/mail-gateway at /opt/rt3/bin/rt-mailgate line 99, <>
line 1.

It makes me think that the permissions on my designated user are not set up
correctly.

Thoughts? Thanks!

Lorell Hathcock
HYPERLINK "mailto:lorell@hathcock.org"lorell@hathcock.org

No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.394 / Virus Database: 268.9.1/369 - Release Date: 6/19/2006

Lorell Hathcock wrote:

That does not say how to set up the user in RT. I created a user
called mailman. This is probably where I’m going astray, but I do not
see any special settings that designate this user as the user which
can receive mail.
There should be no need for a separate user to inject mail using
rt-mailgate.
I added the following line to /etc/aliases:

support: "/opt/rt3/bin/rt-mailgate --queue ‘00-Incoming Email’
–action correspond --url http://support.emcsol.com/
If this is a true copy&paste line it has an error, try replacing with
support: “|/opt/rt3/bin/rt-mailgate --queue”'00-Incoming Email”
–action correspond --url "http://support.emcsol.com/
http://support.emcsol.com/

I’m not 100% sure about replacing the ’ with " but this is how I use it
and it works.

and ran newaliases.
on a sidenote, please supply which MTA you’re using.

When I add the --debug option to the command, I get this:

[root@tickets bin]# /opt/rt3/bin/rt-mailgate --queue ‘00-Incoming
Email’ --action correspond --url http://support.emcsol.com --debug
test
Connecting to http://support.emcsol.com/REST/1.0/NoAuth/mail-gateway
at /opt/rt3/bin/rt-mailgate line 99, <> line 1.
I have never tried the --debug option so don’t know how it should respond.
It makes me think that the permissions on my designated user are not
set up correctly.
Depends a bit on what your MTA shows in it log files, does your mail
bounce or does it not appear in queue ?
Thoughts? Thanks!
Hope this helps you.

Vriendelijke groeten, ^ Bubbles IT
^ Oude Heerweg 175
Niels Huylebroeck ^ 9160 Lokeren, Belgie
Systeembeheerder, Programmeur ^ Tel: +32(0)9/355 13 31
niels@bubbles-it.be ^ Fax: +32(0)9/355 13 41

… Key : http://www.bubbles-it.be/pgp/niels.asc
… Fingerprint : 3885 CC0B C7A4 78CC 47DE 47AF 896A 6C40 80FA AF0F …
… Keyserver : http://pgp.mit.edu Key-ID : 0x80FAAF0F …

A diplomat is a person who can tell you to go to hell in such a way
that you actually look forward to the trip.

  • Caskie Stinnett, “Out of the Red”

support: “|/opt/rt3/bin/rt-mailgate --queue”'00-Incoming
Email" --action correspond --url "http://support.emcsol.com/"
http://support.emcsol.com/"
support: "|/opt/rt3/bin/rt-mailgate --queue “00-Incoming Email”
–action correspond --url "http://support.emcsol.com/"
http://support.emcsol.com/"
correction (left out a space and had a lost ')

Thanks for the help!

The line in /etc/aliases is:

support: "|/opt/rt3/bin/rt-mailgate --queue “00-Incoming Email”
–action correspond --url “HYPERLINK
"http://support.emcsol.com/\“http://support.emcsol.com/”

I am using the following line to send the mail locally:

#mail -v support -S “Test” < body.txt

Excerpt from /var/log/maillog:

Jun 22 16:04:55 tickets sendmail[16886]: k5ML4s2t016885:
to="|/opt/rt3/bin/rt-mailgate --queue HYPERLINK
"file://\\“00-Incoming”\“00-Incoming Email\” --action correspond --url
HYPERLINK
"file://\\“http://support.emcsol.com/\\"\"http://support.emcsol.com/\
", ctladdr=<HYPERLINK
"mailto:support@tickets.emcsol.com"support@tickets.emcsol.com> (8/0),
delay=00:00:01, xdelay=00:00:00, mailer=prog, pri=30577, dsn=5.0.0,
stat=Service unavailable
Jun 22 16:04:55 tickets sendmail[16886]: k5ML4s2t016885: k5ML4t2t016886:
DSN: Service unavailable
Jun 22 16:04:55 tickets sendmail[16886]: k5ML4t2t016886: to=<HYPERLINK
"mailto:root@tickets.emcsol.com"root@tickets.emcsol.com>, delay=00:00:00,
xdelay=00:00:00, mailer=local, pri=31601, dsn=2.0.0, stat=Sent

I see that sendmail has added additional slashes “” in the log file. Maybe
I should take them out in /etc/aliases and change over to single quotes?

I went ahead and did that. SO now here’s what is in /etc/aliases:

support: ‘|/opt/rt3/bin/rt-mailgate --queue “00-Incoming Email”
–action correspond --url “HYPERLINK
"http://support.emcsol.com/"’"http://support.emcsol.com/”’

And here’s what /var/log/maillog says:

Jun 22 16:35:15 tickets sendmail[16992]: k5MLZFD5016991:
to=’|/opt/rt3/bin/rt-mailgate --queue “00-Incoming Email” --action
correspond --url “HYPERLINK
"http://support.emcsol.com/"’"http://support.emcsol.com/”’,
ctladdr=<HYPERLINK
"mailto:support@tickets.emcsol.com"support@tickets.emcsol.com> (8/0),
delay=00:00:00, mailer=local, pri=120340, dsn=5.1.1, stat=User unknown
Jun 22 16:35:15 tickets sendmail[16992]: k5MLZFD5016991: k5MLZFD5016992:
DSN: User unknown
Jun 22 16:35:15 tickets sendmail[16992]: k5MLZFD5016992: to=<HYPERLINK
"mailto:root@tickets.emcsol.com"root@tickets.emcsol.com>, delay=00:00:00,
xdelay=00:00:00, mailer=local, pri=31595, dsn=2.0.0, stat=Sent

With double quotes, I get DSN: Service unavailable
With single quotes, I get DSN: User unknown

Here’s what I have in the Configuration->Tools->System Configuration section
of RT:

RT Variables

RT::AmbiguousDayInPast 1
RT::BasePath /opt/rt3
RT::BinPath /opt/rt3/bin
RT::CORE_CONFIG_FILE /opt/rt3/etc/RT_Config.pm
RT::CommentAddress support@emcsol.com
RT::CorrespondAddress support@emcsol.com
RT::DatabaseHost localhost
RT::DatabaseName rt3
RT::DatabasePassword Password not printed
RT::DatabaseRTHost localhost
RT::DatabaseType mysql
RT::DatabaseUser rt_user
RT::DateDayBeforeMonth 1
RT::DefaultSearchResultFormat ‘id/TITLE:#’, ‘Subject/TITLE:Subject’,
Status, QueueName, OwnerName, Priority, ‘NEWLINE’, ‘’,
Requestors’, ‘CreatedRelative’,
ToldRelative’, ‘LastUpdatedRelative’,
TimeLeft
RT::EmailOutputEncoding utf-8
RT::EtcPath /opt/rt3/etc
RT::FriendlyFromLineFormat “%s via RT” <%s>
RT::FriendlyToLineFormat “%s of emcsol.com Ticket #%s”:;
RT::LinkTransactionsRun1Scrip 1
RT::LocalEtcPath /opt/rt3/local/etc
RT::LocalLexiconPath /opt/rt3/local/po
RT::LocalPath /opt/rt3/local
RT::LogDir /opt/rt3/var/log
RT::LogToFileNamed rt.log
RT::LogToScreen error
RT::LogToSyslog debug
RT::LogoURL /NoAuth/images/bplogo.gif
RT::LoopsToRTOwner 1
RT::MailCommand sendmailpipe
RT::MasonComponentRoot /opt/rt3/share/html
RT::MasonDataDir /opt/rt3/var/mason_data
RT::MasonLocalComponentRoot /opt/rt3/local/html
RT::MasonSessionDir /opt/rt3/var/session_data
RT::MaxAttachmentSize 10000000
RT::MaxInlineBody 13456
RT::MessageBoxWidth 72
RT::MessageBoxWrap HARD
RT::MinimumPasswordLength 5
RT::MyRequestsLength 10
RT::MyTicketsLength 10
RT::Organization emcsol.com
RT::OwnerEmail catchall@emcsol.com
RT::ParseNewMessageForTicketCcs true
RT::RTAddressRegexp ^support@emcsol.com$
RT::RecordOutgoingEmail 1
RT::RedistributeAutoGeneratedMessages 1
RT::SITE_CONFIG_FILE /opt/rt3/etc/RT_SiteConfig.pm
RT::SendmailArguments -oi -t
RT::SendmailBounceArguments -f “<>”
RT::SendmailPath /usr/sbin/sendmail
RT::Timezone US/Central
RT::UseFriendlyFromLine 1
RT::VERSION 3.4.5
RT::VarPath /opt/rt3/var
RT::WebBaseURL http://support.emcsol.com
RT::WebFlushDbCacheEveryRequest 1
RT::WebImagesURL /NoAuth/images/
RT::WebURL http://support.emcsol.com/
RT::rtname emcsol.com

Perl configuration

Summary of my perl5 (revision 5 version 8 subversion 5) configuration:

Platform:

osname=linux, osvers=2.6.9-22.0.1.elsmp,

archname=i386-linux-thread-multi

uname='linux build-i386 2.6.9-22.0.1.elsmp #1 smp thu oct 27 13:14:25

cdt 2005 i686 i686 i386 gnulinux ’

config_args='-des -Doptimize=-O2 -g -pipe -m32 -march=i386

-mtune=pentium4 -Dversion=5.8.5 -Dmyhostname=localhost
-Dperladmin=root@localhost -Dcc=gcc -Dcf_by=Red Hat, Inc.
-Dinstallprefix=/usr -Dprefix=/usr -Darchname=i386-linux -Dvendorprefix=/usr
-Dsiteprefix=/usr -Duseshrplib -Dusethreads -Duseithreads -Duselargefiles
-Dd_dosuid -Dd_semctl_semun -Di_db -Ui_ndbm -Di_gdbm -Di_shadow -Di_syslog
-Dman3ext=3pm -Duseperlio -Dinstallusrbinperl -Ubincompat5005 -Uversiononly
-Dpager=/usr/bin/less -isr -Dinc_version_list=5.8.4 5.8.3 5.8.2 5.8.1 5.8.0’

hint=recommended, useposix=true, d_sigaction=define

usethreads=define use5005threads=undef useithreads=define

usemultiplicity=define

useperlio=define d_sfio=undef uselargefiles=define usesocks=undef

use64bitint=undef use64bitall=undef uselongdouble=undef

usemymalloc=n, bincompat5005=undef

Compiler:

cc='gcc', ccflags ='-D_REENTRANT -D_GNU_SOURCE -DDEBUGGING

-fno-strict-aliasing -pipe -I/usr/local/include -D_LARGEFILE_SOURCE
-D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm’,

optimize='-O2 -g -pipe -m32 -march=i386 -mtune=pentium4',

cppflags='-D_REENTRANT -D_GNU_SOURCE -DDEBUGGING -fno-strict-aliasing

-pipe -I/usr/local/include -I/usr/include/gdbm’

ccversion='', gccversion='3.4.4 20050721 (Red Hat 3.4.4-2)',

gccosandvers=’’

intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=1234

d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=12

ivtype='long', ivsize=4, nvtype='double', nvsize=8, Off_t='off_t',

lseeksize=8

alignbytes=4, prototype=define

Linker and Libraries:

ld='gcc', ldflags =' -L/usr/local/lib'

libpth=/usr/local/lib /lib /usr/lib

libs=-lnsl -lgdbm -ldb -ldl -lm -lcrypt -lutil -lpthread -lc

perllibs=-lnsl -ldl -lm -lcrypt -lutil -lpthread -lc

libc=/lib/libc-2.3.4.so, so=so, useshrplib=true, libperl=libperl.so

gnulibc_version='2.3.4'

Dynamic Linking:

dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Wl,-E

-Wl,-rpath,/usr/lib/perl5/5.8.5/i386-linux-thread-multi/CORE’

cccdlflags='-fPIC', lddlflags='-shared -L/usr/local/lib'

Lorell HathcockFrom: Niels Huylebroeck [mailto:niels@bubbles-it.be]
Sent: Thursday, June 22, 2006 9:35 AM
To: Lorell Hathcock
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] New RT 3.4.5 install - rt-mailgate install

Lorell Hathcock wrote:

That does not say how to set up the user in RT. I created a user called
mailman. This is probably where I’m going astray, but I do not see any
special settings that designate this user as the user which can receive
mail.

There should be no need for a separate user to inject mail using
rt-mailgate.

I added the following line to /etc/aliases:

support: "/opt/rt3/bin/rt-mailgate --queue ‘00-Incoming Email’
–action correspond --url HYPERLINK
"http://support.emcsol.com/“http://support.emcsol.com/”

If this is a true copy&paste line it has an error, try replacing with
support: “|/opt/rt3/bin/rt-mailgate --queue”'00-Incoming Email"
–action correspond --url “HYPERLINK
"http://support.emcsol.com/“http://support.emcsol.com/”

I’m not 100% sure about replacing the ’ with " but this is how I use it and
it works.

and ran newaliases.

on a sidenote, please supply which MTA you’re using.

When I add the --debug option to the command, I get this:

[root@tickets bin]# /opt/rt3/bin/rt-mailgate --queue ‘00-Incoming Email’
–action correspond --url HYPERLINK
"http://support.emcsol.com"http://support.emcsol.com --debug
test
Connecting to HYPERLINK
"http://support.emcsol.com/REST/1.0/NoAuth/mail-gateway"http://support.emcso
l.com/REST/1.0/NoAuth/mail-gateway at /opt/rt3/bin/rt-mailgate line 99, <>
line 1.

I have never tried the --debug option so don’t know how it should respond.

It makes me think that the permissions on my designated user are not set up
correctly.

Depends a bit on what your MTA shows in it log files, does your mail bounce
or does it not appear in queue ?

Thoughts? Thanks!

Hope this helps you.

Vriendelijke groeten, ^ Bubbles IT

                           ^ Oude Heerweg 175

Niels Huylebroeck ^ 9160 Lokeren, Belgie

Systeembeheerder, Programmeur ^ Tel: +32(0)9/355 13 31

HYPERLINK "mailto:niels@bubbles-it.be"niels@bubbles-it.be ^ Fax:
+32(0)9/355 13 41

… Key : HYPERLINK
"http://www.bubbles-it.be/pgp/niels.asc"http://www.bubbles-it.be/pgp/niels.a
sc …

… Fingerprint : 3885 CC0B C7A4 78CC 47DE 47AF 896A 6C40 80FA AF0F …

… Keyserver : HYPERLINK "http://pgp.mit.edu"http://pgp.mit.edu
Key-ID : 0x80FAAF0F …

A diplomat is a person who can tell you to go to hell in such a way

that you actually look forward to the trip.

  • Caskie Stinnett, “Out of the Red”

No virus found in this incoming message.
Checked by AVG Free Edition.
Version: 7.1.394 / Virus Database: 268.9.1/369 - Release Date: 6/19/2006

No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.394 / Virus Database: 268.9.2/372 - Release Date: 6/21/2006

No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.394 / Virus Database: 268.9.2/372 - Release Date: 6/21/2006

One more thing.

The email address I will use here is HYPERLINK
"mailto:support@emcsol.com"support@emcsol.com. The MX record is not yet set
up for this. My email server is on a different machine than RT. I will
forward email from my mail server to my RT server later. For now I am just
trying to get email into the HYPERLINK
"mailto:support@localhost"support@localhost account to go into RT.

Lorell Hathcock
HYPERLINK "mailto:lorell@hathcock.org"lorell@hathcock.org
1-713-992-2343 (cell)From: Lorell Hathcock [mailto:lorell@hathcock.org]
Sent: Thursday, June 22, 2006 5:27 PM
To: 'rt-users@lists.bestpractical.com’
Subject: RE: [rt-users] New RT 3.4.5 install - rt-mailgate install

Thanks for the help!

The line in /etc/aliases is:

support: "|/opt/rt3/bin/rt-mailgate --queue “00-Incoming Email”
–action correspond --url “HYPERLINK
"http://support.emcsol.com/\“http://support.emcsol.com/”

I am using the following line to send the mail locally:

#mail -v support -S “Test” < body.txt

Excerpt from /var/log/maillog:

Jun 22 16:04:55 tickets sendmail[16886]: k5ML4s2t016885:
to="|/opt/rt3/bin/rt-mailgate --queue HYPERLINK
"file://\\“00-Incoming”\“00-Incoming Email\” --action correspond --url
HYPERLINK
"file://\\“http://support.emcsol.com/\\"\"http://support.emcsol.com/\
", ctladdr=<HYPERLINK
"mailto:support@tickets.emcsol.com"support@tickets.emcsol.com> (8/0),
delay=00:00:01, xdelay=00:00:00, mailer=prog, pri=30577, dsn=5.0.0,
stat=Service unavailable
Jun 22 16:04:55 tickets sendmail[16886]: k5ML4s2t016885: k5ML4t2t016886:
DSN: Service unavailable
Jun 22 16:04:55 tickets sendmail[16886]: k5ML4t2t016886: to=<HYPERLINK
"mailto:root@tickets.emcsol.com"root@tickets.emcsol.com>, delay=00:00:00,
xdelay=00:00:00, mailer=local, pri=31601, dsn=2.0.0, stat=Sent

I see that sendmail has added additional slashes “” in the log file. Maybe
I should take them out in /etc/aliases and change over to single quotes?

I went ahead and did that. SO now here’s what is in /etc/aliases:

support: ‘|/opt/rt3/bin/rt-mailgate --queue “00-Incoming Email”
–action correspond --url “HYPERLINK
"http://support.emcsol.com/"’"http://support.emcsol.com/”’

And here’s what /var/log/maillog says:

Jun 22 16:35:15 tickets sendmail[16992]: k5MLZFD5016991:
to=’|/opt/rt3/bin/rt-mailgate --queue “00-Incoming Email” --action
correspond --url “HYPERLINK
"http://support.emcsol.com/"’"http://support.emcsol.com/”’,
ctladdr=<HYPERLINK
"mailto:support@tickets.emcsol.com"support@tickets.emcsol.com> (8/0),
delay=00:00:00, mailer=local, pri=120340, dsn=5.1.1, stat=User unknown
Jun 22 16:35:15 tickets sendmail[16992]: k5MLZFD5016991: k5MLZFD5016992:
DSN: User unknown
Jun 22 16:35:15 tickets sendmail[16992]: k5MLZFD5016992: to=<HYPERLINK
"mailto:root@tickets.emcsol.com"root@tickets.emcsol.com>, delay=00:00:00,
xdelay=00:00:00, mailer=local, pri=31595, dsn=2.0.0, stat=Sent

With double quotes, I get DSN: Service unavailable
With single quotes, I get DSN: User unknown

Here’s what I have in the Configuration->Tools->System Configuration section
of RT:

RT Variables

RT::AmbiguousDayInPast 1
RT::BasePath /opt/rt3
RT::BinPath /opt/rt3/bin
RT::CORE_CONFIG_FILE /opt/rt3/etc/RT_Config.pm
RT::CommentAddress support@emcsol.com
RT::CorrespondAddress support@emcsol.com
RT::DatabaseHost localhost
RT::DatabaseName rt3
RT::DatabasePassword Password not printed
RT::DatabaseRTHost localhost
RT::DatabaseType mysql
RT::DatabaseUser rt_user
RT::DateDayBeforeMonth 1
RT::DefaultSearchResultFormat ‘id/TITLE:#’, ‘Subject/TITLE:Subject’,
Status, QueueName, OwnerName, Priority, ‘NEWLINE’, ‘’,
Requestors’, ‘CreatedRelative’,
ToldRelative’, ‘LastUpdatedRelative’,
TimeLeft
RT::EmailOutputEncoding utf-8
RT::EtcPath /opt/rt3/etc
RT::FriendlyFromLineFormat “%s via RT” <%s>
RT::FriendlyToLineFormat “%s of emcsol.com Ticket #%s”:;
RT::LinkTransactionsRun1Scrip 1
RT::LocalEtcPath /opt/rt3/local/etc
RT::LocalLexiconPath /opt/rt3/local/po
RT::LocalPath /opt/rt3/local
RT::LogDir /opt/rt3/var/log
RT::LogToFileNamed rt.log
RT::LogToScreen error
RT::LogToSyslog debug
RT::LogoURL /NoAuth/images/bplogo.gif
RT::LoopsToRTOwner 1
RT::MailCommand sendmailpipe
RT::MasonComponentRoot /opt/rt3/share/html
RT::MasonDataDir /opt/rt3/var/mason_data
RT::MasonLocalComponentRoot /opt/rt3/local/html
RT::MasonSessionDir /opt/rt3/var/session_data
RT::MaxAttachmentSize 10000000
RT::MaxInlineBody 13456
RT::MessageBoxWidth 72
RT::MessageBoxWrap HARD
RT::MinimumPasswordLength 5
RT::MyRequestsLength 10
RT::MyTicketsLength 10
RT::Organization emcsol.com
RT::OwnerEmail catchall@emcsol.com
RT::ParseNewMessageForTicketCcs true
RT::RTAddressRegexp ^support@emcsol.com$
RT::RecordOutgoingEmail 1
RT::RedistributeAutoGeneratedMessages 1
RT::SITE_CONFIG_FILE /opt/rt3/etc/RT_SiteConfig.pm
RT::SendmailArguments -oi -t
RT::SendmailBounceArguments -f “<>”
RT::SendmailPath /usr/sbin/sendmail
RT::Timezone US/Central
RT::UseFriendlyFromLine 1
RT::VERSION 3.4.5
RT::VarPath /opt/rt3/var
RT::WebBaseURL http://support.emcsol.com
RT::WebFlushDbCacheEveryRequest 1
RT::WebImagesURL /NoAuth/images/
RT::WebURL http://support.emcsol.com/
RT::rtname emcsol.com

Perl configuration

Summary of my perl5 (revision 5 version 8 subversion 5) configuration:

Platform:

osname=linux, osvers=2.6.9-22.0.1.elsmp,

archname=i386-linux-thread-multi

uname='linux build-i386 2.6.9-22.0.1.elsmp #1 smp thu oct 27 13:14:25

cdt 2005 i686 i686 i386 gnulinux ’

config_args='-des -Doptimize=-O2 -g -pipe -m32 -march=i386

-mtune=pentium4 -Dversion=5.8.5 -Dmyhostname=localhost
-Dperladmin=root@localhost -Dcc=gcc -Dcf_by=Red Hat, Inc.
-Dinstallprefix=/usr -Dprefix=/usr -Darchname=i386-linux -Dvendorprefix=/usr
-Dsiteprefix=/usr -Duseshrplib -Dusethreads -Duseithreads -Duselargefiles
-Dd_dosuid -Dd_semctl_semun -Di_db -Ui_ndbm -Di_gdbm -Di_shadow -Di_syslog
-Dman3ext=3pm -Duseperlio -Dinstallusrbinperl -Ubincompat5005 -Uversiononly
-Dpager=/usr/bin/less -isr -Dinc_version_list=5.8.4 5.8.3 5.8.2 5.8.1 5.8.0’

hint=recommended, useposix=true, d_sigaction=define

usethreads=define use5005threads=undef useithreads=define

usemultiplicity=define

useperlio=define d_sfio=undef uselargefiles=define usesocks=undef

use64bitint=undef use64bitall=undef uselongdouble=undef

usemymalloc=n, bincompat5005=undef

Compiler:

cc='gcc', ccflags ='-D_REENTRANT -D_GNU_SOURCE -DDEBUGGING

-fno-strict-aliasing -pipe -I/usr/local/include -D_LARGEFILE_SOURCE
-D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm’,

optimize='-O2 -g -pipe -m32 -march=i386 -mtune=pentium4',

cppflags='-D_REENTRANT -D_GNU_SOURCE -DDEBUGGING -fno-strict-aliasing

-pipe -I/usr/local/include -I/usr/include/gdbm’

ccversion='', gccversion='3.4.4 20050721 (Red Hat 3.4.4-2)',

gccosandvers=’’

intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=1234

d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=12

ivtype='long', ivsize=4, nvtype='double', nvsize=8, Off_t='off_t',

lseeksize=8

alignbytes=4, prototype=define

Linker and Libraries:

ld='gcc', ldflags =' -L/usr/local/lib'

libpth=/usr/local/lib /lib /usr/lib

libs=-lnsl -lgdbm -ldb -ldl -lm -lcrypt -lutil -lpthread -lc

perllibs=-lnsl -ldl -lm -lcrypt -lutil -lpthread -lc

libc=/lib/libc-2.3.4.so, so=so, useshrplib=true, libperl=libperl.so

gnulibc_version='2.3.4'

Dynamic Linking:

dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Wl,-E

-Wl,-rpath,/usr/lib/perl5/5.8.5/i386-linux-thread-multi/CORE’

cccdlflags='-fPIC', lddlflags='-shared -L/usr/local/lib'

Lorell Hathcock

From: Niels Huylebroeck [mailto:niels@bubbles-it.be]
Sent: Thursday, June 22, 2006 9:35 AM
To: Lorell Hathcock
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] New RT 3.4.5 install - rt-mailgate install

Lorell Hathcock wrote:

That does not say how to set up the user in RT. I created a user called
mailman. This is probably where I’m going astray, but I do not see any
special settings that designate this user as the user which can receive
mail.

There should be no need for a separate user to inject mail using
rt-mailgate.

I added the following line to /etc/aliases:

support: "/opt/rt3/bin/rt-mailgate --queue ‘00-Incoming Email’
–action correspond --url HYPERLINK
"http://support.emcsol.com/“http://support.emcsol.com/”

If this is a true copy&paste line it has an error, try replacing with
support: “|/opt/rt3/bin/rt-mailgate --queue”'00-Incoming Email"
–action correspond --url “HYPERLINK
"http://support.emcsol.com/“http://support.emcsol.com/”

I’m not 100% sure about replacing the ’ with " but this is how I use it and
it works.

and ran newaliases.

on a sidenote, please supply which MTA you’re using.

When I add the --debug option to the command, I get this:

[root@tickets bin]# /opt/rt3/bin/rt-mailgate --queue ‘00-Incoming Email’
–action correspond --url HYPERLINK
"http://support.emcsol.com"http://support.emcsol.com --debug
test
Connecting to HYPERLINK
"http://support.emcsol.com/REST/1.0/NoAuth/mail-gateway"http://support.emcso
l.com/REST/1.0/NoAuth/mail-gateway at /opt/rt3/bin/rt-mailgate line 99, <>
line 1.

I have never tried the --debug option so don’t know how it should respond.

It makes me think that the permissions on my designated user are not set up
correctly.

Depends a bit on what your MTA shows in it log files, does your mail bounce
or does it not appear in queue ?

Thoughts? Thanks!

Hope this helps you.

Vriendelijke groeten, ^ Bubbles IT

                           ^ Oude Heerweg 175

Niels Huylebroeck ^ 9160 Lokeren, Belgie

Systeembeheerder, Programmeur ^ Tel: +32(0)9/355 13 31

HYPERLINK "mailto:niels@bubbles-it.be"niels@bubbles-it.be ^ Fax:
+32(0)9/355 13 41

… Key : HYPERLINK
"http://www.bubbles-it.be/pgp/niels.asc"http://www.bubbles-it.be/pgp/niels.a
sc …

… Fingerprint : 3885 CC0B C7A4 78CC 47DE 47AF 896A 6C40 80FA AF0F …

… Keyserver : HYPERLINK "http://pgp.mit.edu"http://pgp.mit.edu
Key-ID : 0x80FAAF0F …

A diplomat is a person who can tell you to go to hell in such a way

that you actually look forward to the trip.

  • Caskie Stinnett, “Out of the Red”

No virus found in this incoming message.
Checked by AVG Free Edition.
Version: 7.1.394 / Virus Database: 268.9.1/369 - Release Date: 6/19/2006

No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.394 / Virus Database: 268.9.2/372 - Release Date: 6/21/2006

No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.394 / Virus Database: 268.9.2/372 - Release Date: 6/21/2006

No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.394 / Virus Database: 268.9.2/372 - Release Date: 6/21/2006