New install 3.6.6 - logo image issue


#1

Hello everybody,

I installed the new version RT 3.6.6 on an ubuntu server 8.04. The
installation went fine. I am able to login to the RT. The only issue I
have is the logo in the left upper corner. I don’t know how I can make
that work. If I look at the image properties it shows me the
following:

Location: http://noauth/images//bplogo.gif

Where do I have to change the settings to get the link correct? If I
point my browser to http://mydomain/NoAuth/images/bplogo.gif the logo
comes up.

Thanks for all your help

Robert


#2

There is a Header file in

…/rt3/html/Elements/Logo

That defines the location of your logo.

But don’t edit that file. Copy that file to your ‘local’ version, edit it
there, and the presence of this change will overwrite the default html.

(Note,I know my stuff is not in the usual place-- you might need to replace
/usr/local and /usr/share below with your specific html locations…)

  1. Make sure the logo is in the right place

mv my_logo.png /usr/local/rt3/html/NoAuth/images/

  1. Copy the file

cp -vR /usr/share/rt3/html/Elements/Logo /usr/local/rt3/html/Elements/Logo

  1. Edit the local version to point to your logo. My relevant line looks
    like:

<img src="<%$RT::WebImagesURL%>/my_logo.png"
alt="<%loc(“Acme Corporate Logo”)%>" />

  1. Bounce apache

service httpd restart

The information contained in this email is strictly confidential and subject
to the Confidentiality Notice at www.mcfina.com/emailpolicy-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Robert Keidel
Sent: Thursday, May 15, 2008 4:28 PM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] new install 3.6.6 - logo image issue

Hello everybody,

I installed the new version RT 3.6.6 on an ubuntu server 8.04. The
installation went fine. I am able to login to the RT. The only issue I
have is the logo in the left upper corner. I don’t know how I can make
that work. If I look at the image properties it shows me the
following:

Location: http://noauth/images//bplogo.gif

Where do I have to change the settings to get the link correct? If I
point my browser to http://mydomain/NoAuth/images/bplogo.gif the logo
comes up.

Thanks for all your help

Robert
http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


#3

Thanks Sam,

for the help, but I was not looking to change my logo. I tried to
figure out why the RT uses “/noauth/images/”. Its supposed to be
"/NoAuth/images/"
I also discovered, if I add an alias in my virtual host (Alias
/NoAuth/images/ /opt/rt3/share/html/NoAuth/images/) I get the
following error message in the startup from apache2.
The Alias directive in /etc/apache2/sites-enabled/rthelpdesk at line
12 will probably never match because it overlaps an earlier
ScriptAlias.
But I do not have any other ScriptAlias in my system. Its fresh
install system. I hope someone is able to help me.

Thanks

RobertOn Thu, May 15, 2008 at 1:52 PM, Sam A. Hicks shicks@mcfina.com wrote:

There is a Header file in

…/rt3/html/Elements/Logo

That defines the location of your logo.

But don’t edit that file. Copy that file to your ‘local’ version, edit it
there, and the presence of this change will overwrite the default html.

(Note,I know my stuff is not in the usual place-- you might need to replace
/usr/local and /usr/share below with your specific html locations…)

  1. Make sure the logo is in the right place

mv my_logo.png /usr/local/rt3/html/NoAuth/images/

  1. Copy the file

cp -vR /usr/share/rt3/html/Elements/Logo /usr/local/rt3/html/Elements/Logo

  1. Edit the local version to point to your logo. My relevant line looks
    like:

<img src="<%$RT::WebImagesURL%>/my_logo.png"
alt="<%loc(“Acme Corporate Logo”)%>" />

  1. Bounce apache

service httpd restart


The information contained in this email is strictly confidential and subject
to the Confidentiality Notice at www.mcfina.com/emailpolicy

-----Original Message-----
From: rt-users-bounces@lists.bestpractical.com
[mailto:rt-users-bounces@lists.bestpractical.com] On Behalf Of Robert Keidel
Sent: Thursday, May 15, 2008 4:28 PM
To: rt-users@lists.bestpractical.com
Subject: [rt-users] new install 3.6.6 - logo image issue

Hello everybody,

I installed the new version RT 3.6.6 on an ubuntu server 8.04. The
installation went fine. I am able to login to the RT. The only issue I
have is the logo in the left upper corner. I don’t know how I can make
that work. If I look at the image properties it shows me the
following:

Location: http://noauth/images//bplogo.gif

Where do I have to change the settings to get the link correct? If I
point my browser to http://mydomain/NoAuth/images/bplogo.gif the logo
comes up.

Thanks for all your help

Robert


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


#4

Hello,

I fixed the apache issue. But I still try to figure out my problems
with Logo. I try to make something clear for myself. So please let me
know if I am wrong. The whole RT site is under the following directory
tree. And I assume here the default iinstallation.
/opt/rt3/share/html/ So if I would like to make any changes on one of
the files in that directory, I supposed to copy that file to
/opt/rt3/local/html/? And I tried that with the Footer file and it
worked just fine. But if I try to do the same thing with the "Logo"
file it does not work. It even doesn’t work if I make the changes
directly in the file under /opt/rt3/share/html/. I don’t get that
right now. If you need more information please let me know. I started
to bang my head against the wall. So please forgive me if I am not
specific enough.

Thanks for your help

Robert


#5

At 05:12 PM 5/16/2008, Robert Keidel wrote:

Hello,

I fixed the apache issue. But I still try to figure out my problems
with Logo. I try to make something clear for myself. So please let me
know if I am wrong. The whole RT site is under the following directory
tree. And I assume here the default iinstallation.
/opt/rt3/share/html/ So if I would like to make any changes on one of
the files in that directory, I supposed to copy that file to
/opt/rt3/local/html/? And I tried that with the Footer file and it
worked just fine. But if I try to do the same thing with the "Logo"
file it does not work. It even doesn’t work if I make the changes
directly in the file under /opt/rt3/share/html/. I don’t get that
right now. If you need more information please let me know. I started
to bang my head against the wall. So please forgive me if I am not
specific enough.

Thanks for your help

Robert

Robert,

What do you have in RT_Config.pm and RT_SiteConfig.pm for “$WebImagesURL” ?

Steve


#6

Hello,

thanks Sam, I tried the stuff you suggested, but it did not fix my
problem. I am at the point to start over from scratch. I am very
certain that this issue is created from a wrong installation process.
My question is now, where do I have to look at, so I do not create
that error again. I could install the packaged version 3.6.5 what
comes with Ubuntu, but I’d like to use the newest version. Maybe if
you all could give me some suggestion where to look just so I do not
get the same error again. Any help would be very appreciated. Or maybe
you have some other suggestions.

Thanks for all your help,

Robert


#7

I solved my my problem. I am not sure if that is the right approach,
but at least it works now. When I run the ./configure command, I
always use “–with-rt-group=rt”, and I added this group to the system.
This time I used “root” instead of “rt” and it works.

Thanks

RobertOn Tue, May 20, 2008 at 1:00 PM, Robert Keidel rkeidel@gmail.com wrote:

Hello,

thanks Sam, I tried the stuff you suggested, but it did not fix my
problem. I am at the point to start over from scratch. I am very
certain that this issue is created from a wrong installation process.
My question is now, where do I have to look at, so I do not create
that error again. I could install the packaged version 3.6.5 what
comes with Ubuntu, but I’d like to use the newest version. Maybe if
you all could give me some suggestion where to look just so I do not
get the same error again. Any help would be very appreciated. Or maybe
you have some other suggestions.

Thanks for all your help,

Robert