Need sendmail help

I keep seeing…

Jul 27 02:29:25 camelot sendmail[6156]: f6QGTPx06156: from=nobody,
size=1095, class=-60, nrcpts=1, msgid=rt-371-1478.12.6572325048802@TDCE,
relay=nobody@localhost

Jul 27 02:29:25 camelot sendmail[6156]: f6QGTPx06156: f6QGTP006156: DSN:
‘AdminCc of TDCE Ticket #371’:;… List:; syntax illegal for recipient
addresses

Jul 27 02:29:25 camelot sendmail[6156]: f6QGTP006156: to=terry,
delay=00:00:00, xdelay=00:00:00, mailer=local, pri=30100, dsn=2.0.0,
stat=Sent

How does RT generate this DSN?

[linux, v2.0.4 of RT.]

Terence C. Giufre-Sweetser

| TereDonn Telecommunications Ltd | Phone +61-[0]7-32369366 |
| 1/128 Bowen St, SPRING HILL | FAX +61-[0]7-32369930 |
| PO BOX 1054, SPRING HILL 4004 | Mobile +61-[0]414-663053 |
| Queensland Australia | http://www.tdce.com.au |

Hello All,

I’m trying to get RT2 up for an evaluation at our company.
I’ve got it running on Red Hat 7.1, with postgresql 7.1.2 and RH supplied
apache and mod_perl

Everything seems to be in order, and the apache user should be able to write
to the /opt/rt2/WebRT/sessiondata directory.

Anyone seen this? What am I missing?

[Thu Jul 26 12:52:27 2001] [error] RT Couldn’t write to session directory
’/opt/rt2/WebRT/sessiondata’. Check that this directory’s permissions are
correct. at /opt/rt2/bin/webmux.pl line 143.

Here it is:

/opt is root:root 755
/opt/rt2 is apache:rt 755
/opt/rt2/WebRT is apache:rt 755
/opt/rt2/WebRT/sessiondata is apache:rt 755

Note that I’ve chmod -R 777 /opt and chown -R apache:rt /opt and kicked
the httpd server…still no luck…
Obviously, I’d like to tighten security, but I just need it running to
see how it looks at the moment.

Thanks!From: matthew zeier [mailto:matthew.zeier@thirdcoast.net]
Sent: Thursday, July 26, 2001 12:06 PM
To: Nathan Olla
Subject: Re: [rt-users] Need Help: RT can’t write to sessiondir

Probably dumb to ask but what do the directory permissions look like for
/opt, /opt/rt2, /opt/rt2/WebRT and /opt/rt2/WebRT/sessiondata ?

  • mz

From: “Nathan Olla” nathan.olla@newisys.com
To: rt-users@fsck.com
Sent: Thursday, July 26, 2001 10:05 AM
Subject: [rt-users] Need Help: RT can’t write to sessiondir

Hello All,

I’m trying to get RT2 up for an evaluation at our company.
I’ve got it running on Red Hat 7.1, with postgresql 7.1.2 and RH
supplied
apache and mod_perl

Everything seems to be in order, and the apache user should be able to
write
to the /opt/rt2/WebRT/sessiondata directory.

Anyone seen this? What am I missing?

[Thu Jul 26 12:52:27 2001] [error] RT Couldn’t write to session
directory
’/opt/rt2/WebRT/sessiondata’. Check that this directory’s permissions
are
correct. at /opt/rt2/bin/webmux.pl line 143.


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

smime.p7s (3.07 KB)

Jul 27 02:29:25 camelot sendmail[6156]: f6QGTPx06156: f6QGTP006156: DSN:
‘AdminCc of TDCE Ticket #371’:;… List:; syntax illegal for recipient
addresses

And sendmail returns the email unsent:

Return-Path:
Received: (from daemon@localhost)
by camelot.tdce.com.au (8.11.1/8.11.1) id f6QHgQI07210;
Fri, 27 Jul 2001 03:42:26 +1000
Message-Id: rt-374-1522.13.6899299591728@TDCE
RT-Ticket: TDCE #374
X-Mailer: Perl5 Mail::Internet v1.33
RT-Originator: [WITHHELD]
Content-Disposition: inline
Content-Type: text/plain
In-Reply-To: rt-374@TDCE
Managed-BY: Request Tracker 2.0.4 (http://www.fsck.com/projects/rt)
Precedence: bulk
MIME-Version: 1.0
Content-Transfer-Encoding: binary
Sender: daemon daemon@tdce.com.au

Terence C. Giufre-Sweetser

| TereDonn Telecommunications Ltd | Phone +61-[0]7-32369366 |
| 1/128 Bowen St, SPRING HILL | FAX +61-[0]7-32369930 |
| PO BOX 1054, SPRING HILL 4004 | Mobile +61-[0]414-663053 |
| Queensland Australia | http://www.tdce.com.au |

Terence wrote:

Jul 27 02:29:25 camelot sendmail[6156]: f6QGTPx06156: f6QGTP006156: DSN:
‘AdminCc of TDCE Ticket #371’:;… List:; syntax illegal for recipient
addresses

config.pm:

RT can optionally set a “Friendly” ‘To:’ header when sending messages to

Ccs or AdminCcs (rather than having a blank ‘To:’ header.

This feature DOES NOT WORK WITH SENDMAIL[tm] BRAND SENDMAIL

If you are using sendmail, rather than postfix, qmail, exim or some other MTA,

you must disable this option.

$UseFriendlyToLine = 1;

RT can optionally set a “Friendly” ‘To:’ header when sending messages to

Ccs or AdminCcs (rather than having a blank ‘To:’ header.

This feature DOES NOT WORK WITH SENDMAIL[tm] BRAND SENDMAIL

If you are using sendmail, rather than postfix, qmail, exim or some other MTA,

you must disable this option.

$UseFriendlyToLine = 1;

I have:

$UseFriendlyToLine = undef;

Terence C. Giufre-Sweetser

| TereDonn Telecommunications Ltd | Phone +61-[0]7-32369366 |
| 1/128 Bowen St, SPRING HILL | FAX +61-[0]7-32369930 |
| PO BOX 1054, SPRING HILL 4004 | Mobile +61-[0]414-663053 |
| Queensland Australia | http://www.tdce.com.au |