Mysql performance problem


#1

hi,

I fixed the issue with lighttpd and got it up and running :slight_smile:

Now for testing proposals I use lighttpd and apache… with both
webservers I have the problem that e.g. opening a ticket is very slow
(with both webservers) and the CPU usage increases to 100% …

Does anyone has an idea how to fix this? Its a brand new server and i
dumped the mysql data in it…

Thanks for any help!

best regards,
Raphael


#2

RT debug log. mysql slow log.

Very slow? How slow? Hangs forever or 1 minute? How big is your DB?On Fri, Jul 11, 2008 at 12:47 PM, Raphael Loziczky rl@greentube.com wrote:

hi,

I fixed the issue with lighttpd and got it up and running :slight_smile:

Now for testing proposals I use lighttpd and apache… with both
webservers I have the problem that e.g. opening a ticket is very slow
(with both webservers) and the CPU usage increases to 100% …

Does anyone has an idea how to fix this? Its a brand new server and i
dumped the mysql data in it…

Thanks for any help!

best regards,
Raphael


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Best regards, Ruslan.


#3

How can I enable RT debug log? mysql error log shows no errors…

very slow means that it hangs for about 1 minute - we have our old
system running with the same db which is much faster! (on old hardware)

the mysql dump is about 20 gigs… when I made the dump from the old
system I had to use “force recovery” mode with mysql to get a working
dump. maybe thats the problem?

Ruslan Zakirov schrieb:

RT debug log. mysql slow log.

Very slow? How slow? Hangs forever or 1 minute? How big is your DB?On Fri, Jul 11, 2008 at 12:47 PM, Raphael Loziczky <rl@greentube.com> wrote:

hi,

I fixed the issue with lighttpd and got it up and running :slight_smile:

Now for testing proposals I use lighttpd and apache… with both
webservers I have the problem that e.g. opening a ticket is very slow
(with both webservers) and the CPU usage increases to 100% …

Does anyone has an idea how to fix this? Its a brand new server and i
dumped the mysql data in it…

Thanks for any help!

best regards,
Raphael
http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com


-- 
Raphael Loziczky
System Administrator
raphael.loziczky@greentube.com
Greentube Internet Entertainment Solutions AG
Mariahilfer StraĂźe 47/1/102
A-1060 Wien
FN 197003k, HG Wien

Tel: +43 1 494 50 56 - 30
Fax: +43 1 494 50 56 - 14
http://www.greentube.com/

Internet Email Confidentiality Footer
Privileged/confidential information may be contained in this message. If you are not the addressee indicated in this message (or responsible for delivery of the message to this person), you may not copy or deliver this message to anyone. In such a case, you should destroy this message and kindly notify the sender by replying. Please make it known immediately  f you or your employer does not consent to the medium of e-mail for messages of this kind. Opinions, conclusions and other information in this message that do not relate to the official business of my firm shall be understood as neither given nor endorsed by it.

#4

thx for the tip, Arran but it’s currently running with mysql 5.0.22 so
the broken query optimizer can’t be the problem…

some more ideas?

thanks,
Raphael

Arran Cudbard-Bell schrieb:

Raphael Loziczky wrote:

How can I enable RT debug log? mysql error log shows no errors…

very slow means that it hangs for about 1 minute - we have our old
system running with the same db which is much faster! (on old hardware)
the mysql dump is about 20 gigs… when I made the dump from the old
system I had to use “force recovery” mode with mysql to get a working
dump. maybe thats the problem?
If your new mysql instance running mysql 5.1 ?

If so the query optimizer is slightly broken, this can cause issues
with queries. Try with a version 5.0.

Thanks,
Arran

Ruslan Zakirov schrieb:

RT debug log. mysql slow log.

Very slow? How slow? Hangs forever or 1 minute? How big is your DB?

hi,

I fixed the issue with lighttpd and got it up and running :slight_smile:

Now for testing proposals I use lighttpd and apache… with both
webservers I have the problem that e.g. opening a ticket is very slow
(with both webservers) and the CPU usage increases to 100% …

Does anyone has an idea how to fix this? Its a brand new server and i
dumped the mysql data in it…

Thanks for any help!

best regards,
Raphael


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

–
Raphael Loziczky
System Administrator
raphael.loziczky@greentube.com

Greentube Internet Entertainment Solutions AG
Mariahilfer Stra�e 47/1/102
A-1060 Wien
FN 197003k, HG Wien

Tel: +43 1 494 50 56 - 30
Fax: +43 1 494 50 56 - 14
http://www.greentube.com/


Internet Email Confidentiality Footer

Privileged/confidential information may be contained in this message.
If you are not the addressee indicated in this message (or
responsible for delivery of the message to this person), you may not
copy or deliver this message to anyone. In such a case, you should
destroy this message and kindly notify the sender by replying. Please
make it known immediately f you or your employer does not consent to
the medium of e-mail for messages of this kind. Opinions, conclusions
and other information in this message that do not relate to the
official business of my firm shall be understood as neither given nor
endorsed by it.


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Raphael Loziczky
System Administrator
raphael.loziczky@greentube.com
Greentube Internet Entertainment Solutions AG
Mariahilfer Stra�e 47/1/102
A-1060 Wien
FN 197003k, HG Wien

Tel: +43 1 494 50 56 - 30
Fax: +43 1 494 50 56 - 14

Internet Email Confidentiality Footer
Privileged/confidential information may be contained in this message. If you are not the addressee indicated in this message (or responsible for delivery of the message to this person), you may not copy or deliver this message to anyone. In such a case, you should destroy this message and kindly notify the sender by replying. Please make it known immediately f you or your employer does not consent to the medium of e-mail for messages of this kind. Opinions, conclusions and other information in this message that do not relate to the official business of my firm shall be understood as neither given nor endorsed by it.


#5

thx for the tip, Arran but it’s currently running with mysql 5.0.22 so
the broken query optimizer can’t be the problem…

Actually, 5.0.22 is known to have some AWFUL query optimizer bugs. My
recollection is that they were fixed in 5.0,45 or so


#6

Jesse Vincent schrieb:

thx for the tip, Arran but it’s currently running with mysql 5.0.22 so
the broken query optimizer can’t be the problem…

Actually, 5.0.22 is known to have some AWFUL query optimizer bugs. My
recollection is that they were fixed in 5.0,45 or so

ok updated to 5.0.45 but still the same problem :frowning:


#7

Turn this on in your my.cnf file so you can see if it’s the MySQL queries:
#log_slow_queries = /var/log/mysql/mysql-slow.log

Thank you,
Micah Gersten
onShore Networks
Internal Developer

Raphael Loziczky wrote: