i am using an RT 5.03 installation on a Ubuntu Linux 22.04.3 LTS box with MariaDB Ver 10.6.12-MariaDB-0ubuntu0.22.04.1).

Starting this morning i get the following warning via rt cron daemon:

Subject of mail: Cron root@rt /opt/rt5/sbin/rt-fulltext-indexer --quiet AND
Cron root@rt /opt/rt5/sbin/rt-email-dashboards

WARNING: MYSQL_OPT_RECONNECT is deprecated and will be removed in a future version.

It is just a warning but i guess that some changes have to be made. Any suggestions?

Thx in advance and have fun,


1 Like

I have the same setup as you, had to turn off notification in cron cause it sends every other minute.
Yes, also need to know what changes needs to be done?

I upgraded to 5.0.4 and the problem persists. I have the same setup as the previous posters.

An easy way to replicate from the command line is:
$ sudo /opt/rt5/sbin/rt-email-dashboards

(or whatever your path is to RT’s sbin/ )

1 Like

I had some software updates that I ran now and after that I ran /opt/rt5/sbin/rt-fulltext-indexer with no warning about deprecated MySQL.

Was it easy to upgrade to RT 5.0.4, did you follow any guide? Did you also upgrade the Ubuntu server?

The others in this thread are using MariaDB, not MySQL. But the error is a MySQL error, since MariaDB is interoperable.

You can run a command like “dpkg --list | grep mariadb” to see if that’s what you have.

For the upgrade: I went from 5.0.3 to 5.0.4 which was painless. Just follow the instructions in the README file.

After some system updates i got rid of the warning message. So the problem is solved.

But for my understanding: As i posted i use a MariaDB installation but i got a MySQL warning. So i guess that some client software /rt Perl stuff) uses a lib with this depricated feature. Because of the compatibility betwenn MySQl and MariaDB they are both affected or is it just a warning from the library and as MariaDB user i can ignore it?

Th@nx a lot to all posters,


Some additional background on what happened here and the current update that removed the message:

The errors went away when I restarted my system. I had restarted my web server and various components after some system upgrades, but not the whole system. I’m not sure what specific package was causing the error pre-reboot, and then not causing error post-reboot, but the solution was to reboot.