MyRT Global Page error

Hi Guys,

I just upgraded to the new RT 3.8 from my old 3.4. Almost everything looks
fine as of now with only one exception. When I click on “RT at a Glance” for
global configration to set the template for all users, I see this meesage in
my browser.

“Can’t call method “Content” on an undefined value at
/share/html/Admin/Global/MyRT.html line 97.”

I am not able to understand what the problem is and would highly appreciate
any help from you guys.

Thank you,

Abdus Samad

Turn on debug on rt log and post the error-----Original Message-----
From: “Abdus Samad” mr.samad@gmail.com

Date: Sun, 13 Jul 2008 21:46:04
To: rt-users@lists.bestpractical.com
Subject: [rt-users] MyRT Global Page error

http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

I would reinstall bothFrom: “Abdus Samad” mr.samad@gmail.com

Date: Sun, 13 Jul 2008 23:25:10
To: chaim.rieger@gmail.com
Cc: rt-users-bounces@lists.bestpractical.com; rt-users@lists.bestpractical.com
Subject: Re: [rt-users] MyRT Global Page error

I receive the following errors in debug logs.

[Sun Jul 13 18:21:49 2008] [debug]: You’ve enabled GraphViz, but we couldn’t
load the module: Can’t locate GraphViz.pm in @INC (@INC contains:
/opt/rt3/bin/…/local/lib /opt/rt3/bin/…/lib /etc/perl
/usr/local/lib/perl/5.8.4 /usr/local/share/perl/5.8.4 /usr/lib/perl5
/usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8
/usr/local/lib/site_perl . /etc/apache/ /etc/apache/lib/perl) at
/opt/rt3/bin/…/lib/RT/Config.pm line 249.
(/opt/rt3/bin/…/lib/RT/Config.pm:250)
[Sun Jul 13 18:21:49 2008] [debug]: RT’s GnuPG libraries couldn’t
successfully read your configured GnuPG home directory
(/opt/rt3/var/data/gpg). PGP support has been disabled
(/opt/rt3/bin/…/lib/RT/Config.pm:275)
[Sun Jul 13 18:21:55 2008] [debug]: RT’s GnuPG libraries couldn’t
successfully read your configured GnuPG home directory
(/opt/rt3/var/data/gpg). PGP support has been disabled
(/opt/rt3/bin/…/lib/RT/Config.pm:275)

The second one seems to be the problem, any suggestions how to enable the
support.? or is there some other problem opening MyRT.html

Thank you,
Abdus Samad

What’s in /opt/rt3/share/html/Admin/Global/MyRT.html line 97.From: “Abdus Samad” mr.samad@gmail.com

Date: Sun, 13 Jul 2008 23:58:21
To: chaim.rieger@gmail.com
Cc: rt-users-bounces@lists.bestpractical.com; rt-users@lists.bestpractical.com
Subject: Re: [rt-users] MyRT Global Page error

Thanks for your response, The Graphviz error is gone after reinstalling but
the gnupg error is still there even after installing the library.
The package have been installed by using the following command (apt-get
install GnuPG-Interface*). but the error logs still show
[Sun Jul 13 18:52:21 2008] [debug]: RT’s GnuPG libraries couldn’t
successfully read your configured GnuPG home directory
(/opt/rt3/var/data/gpg). PGP support has been disabled
(/opt/rt3/bin/…/lib/RT/Config.pm:275)
and I am not able to access the MyRT.html page which is giving the same
error.

Can’t call method “Content” on an undefined value at
/opt/rt3/share/html/Admin/Global/MyRT.html line 97.

Thank you,
Abdus Samad

I receive the following errors in debug logs.

[Sun Jul 13 18:21:49 2008] [debug]: You’ve enabled GraphViz, but we couldn’t
load the module: Can’t locate GraphViz.pm in @INC (@INC contains:
/opt/rt3/bin/…/local/lib /opt/rt3/bin/…/lib /etc/perl
/usr/local/lib/perl/5.8.4 /usr/local/share/perl/5.8.4 /usr/lib/perl5
/usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8
/usr/local/lib/site_perl . /etc/apache/ /etc/apache/lib/perl) at
/opt/rt3/bin/…/lib/RT/Config.pm line 249.
(/opt/rt3/bin/…/lib/RT/Config.pm:250)
[Sun Jul 13 18:21:49 2008] [debug]: RT’s GnuPG libraries couldn’t
successfully read your configured GnuPG home directory
(/opt/rt3/var/data/gpg). PGP support has been disabled
(/opt/rt3/bin/…/lib/RT/Config.pm:275)
[Sun Jul 13 18:21:55 2008] [debug]: RT’s GnuPG libraries couldn’t
successfully read your configured GnuPG home directory
(/opt/rt3/var/data/gpg). PGP support has been disabled
(/opt/rt3/bin/…/lib/RT/Config.pm:275)

The second one seems to be the problem, any suggestions how to enable the
support.? or is there some other problem opening MyRT.html

Thank you,
Abdus SamadOn Sun, Jul 13, 2008 at 9:56 PM, chaim.rieger@gmail.com wrote:

Turn on debug on rt log and post the error
Sent via BlackBerry from T-Mobile

-----Original Message-----
From: “Abdus Samad” mr.samad@gmail.com

Date: Sun, 13 Jul 2008 21:46:04
To: rt-users@lists.bestpractical.com
Subject: [rt-users] MyRT Global Page error


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

I have checked google and found that many people had this problem in the
past but there is no solution to this posted on the internet.

Thank you,
Abdus SamadOn Mon, Jul 14, 2008 at 12:04 AM, Abdus Samad mr.samad@gmail.com wrote:

 90     items => \@items,
 91     current_portlets => $default_portlets->Content,
 92     OnSave => sub {
 93         my ( $conf, $pane ) = @_;
 94         $default_portlets->SetContent( $conf );
 95         push @actions, loc( 'Global portlet [_1] saved.', $pane );
 96     }
 97 );
 98
 99 $m->comp( '/Widgets/SelectionBox:process', %ARGS, self => $_, nojs

=> 1 )
100 for @panes;

On Mon, Jul 14, 2008 at 12:00 AM, chaim.rieger@gmail.com wrote:

What’s in /opt/rt3/share/html/Admin/Global/MyRT.html line 97.

Sent via BlackBerry from T-Mobile


From: “Abdus Samad” mr.samad@gmail.com
Date: Sun, 13 Jul 2008 23:58:21 +0500

To: chaim.rieger@gmail.com
CC: rt-users-bounces@lists.bestpractical.com; <
rt-users@lists.bestpractical.com>
Subject: Re: [rt-users] MyRT Global Page error
Thanks for your response, The Graphviz error is gone after reinstalling
but the gnupg error is still there even after installing the library.
The package have been installed by using the following command (apt-get
install GnuPG-Interface*). but the error logs still show
[Sun Jul 13 18:52:21 2008] [debug]: RT’s GnuPG libraries couldn’t
successfully read your configured GnuPG home directory
(/opt/rt3/var/data/gpg). PGP support has been disabled
(/opt/rt3/bin/…/lib/RT/Config.pm:275)
and I am not able to access the MyRT.html page which is giving the same
error.

Can’t call method “Content” on an undefined value at
/opt/rt3/share/html/Admin/Global/MyRT.html line 97.

Thank you,
Abdus Samad

On Sun, Jul 13, 2008 at 11:25 PM, chaim.rieger@gmail.com wrote:

I would reinstall both

Sent via BlackBerry from T-Mobile


From: “Abdus Samad” mr.samad@gmail.com
Date: Sun, 13 Jul 2008 23:25:10 +0500
To: chaim.rieger@gmail.com
CC: rt-users-bounces@lists.bestpractical.com; <
rt-users@lists.bestpractical.com>
Subject: Re: [rt-users] MyRT Global Page error
I receive the following errors in debug logs.

[Sun Jul 13 18:21:49 2008] [debug]: You’ve enabled GraphViz, but we
couldn’t load the module: Can’t locate GraphViz.pm in @INC (@INC contains:
/opt/rt3/bin/…/local/lib /opt/rt3/bin/…/lib /etc/perl
/usr/local/lib/perl/5.8.4 /usr/local/share/perl/5.8.4 /usr/lib/perl5
/usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8
/usr/local/lib/site_perl . /etc/apache/ /etc/apache/lib/perl) at
/opt/rt3/bin/…/lib/RT/Config.pm line 249.
(/opt/rt3/bin/…/lib/RT/Config.pm:250)
[Sun Jul 13 18:21:49 2008] [debug]: RT’s GnuPG libraries couldn’t
successfully read your configured GnuPG home directory
(/opt/rt3/var/data/gpg). PGP support has been disabled
(/opt/rt3/bin/…/lib/RT/Config.pm:275)
[Sun Jul 13 18:21:55 2008] [debug]: RT’s GnuPG libraries couldn’t
successfully read your configured GnuPG home directory
(/opt/rt3/var/data/gpg). PGP support has been disabled
(/opt/rt3/bin/…/lib/RT/Config.pm:275)

The second one seems to be the problem, any suggestions how to enable the
support.? or is there some other problem opening MyRT.html

Thank you,
Abdus Samad

On Sun, Jul 13, 2008 at 9:56 PM, chaim.rieger@gmail.com wrote:

Turn on debug on rt log and post the error
Sent via BlackBerry from T-Mobile

-----Original Message-----
From: “Abdus Samad” mr.samad@gmail.com

Date: Sun, 13 Jul 2008 21:46:04
To: rt-users@lists.bestpractical.com
Subject: [rt-users] MyRT Global Page error


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Thanks for your response, The Graphviz error is gone after reinstalling but
the gnupg error is still there even after installing the library.
The package have been installed by using the following command (apt-get
install GnuPG-Interface*). but the error logs still show
[Sun Jul 13 18:52:21 2008] [debug]: RT’s GnuPG libraries couldn’t
successfully read your configured GnuPG home directory
(/opt/rt3/var/data/gpg). PGP support has been disabled
(/opt/rt3/bin/…/lib/RT/Config.pm:275)
and I am not able to access the MyRT.html page which is giving the same
error.

Can’t call method “Content” on an undefined value at
/opt/rt3/share/html/Admin/Global/MyRT.html line 97.

Thank you,
Abdus SamadOn Sun, Jul 13, 2008 at 11:25 PM, chaim.rieger@gmail.com wrote:

I would reinstall both

Sent via BlackBerry from T-Mobile


From: “Abdus Samad” mr.samad@gmail.com
Date: Sun, 13 Jul 2008 23:25:10 +0500
To: chaim.rieger@gmail.com
CC: rt-users-bounces@lists.bestpractical.com; <
rt-users@lists.bestpractical.com>
Subject: Re: [rt-users] MyRT Global Page error
I receive the following errors in debug logs.

[Sun Jul 13 18:21:49 2008] [debug]: You’ve enabled GraphViz, but we
couldn’t load the module: Can’t locate GraphViz.pm in @INC (@INC contains:
/opt/rt3/bin/…/local/lib /opt/rt3/bin/…/lib /etc/perl
/usr/local/lib/perl/5.8.4 /usr/local/share/perl/5.8.4 /usr/lib/perl5
/usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8
/usr/local/lib/site_perl . /etc/apache/ /etc/apache/lib/perl) at
/opt/rt3/bin/…/lib/RT/Config.pm line 249.
(/opt/rt3/bin/…/lib/RT/Config.pm:250)
[Sun Jul 13 18:21:49 2008] [debug]: RT’s GnuPG libraries couldn’t
successfully read your configured GnuPG home directory
(/opt/rt3/var/data/gpg). PGP support has been disabled
(/opt/rt3/bin/…/lib/RT/Config.pm:275)
[Sun Jul 13 18:21:55 2008] [debug]: RT’s GnuPG libraries couldn’t
successfully read your configured GnuPG home directory
(/opt/rt3/var/data/gpg). PGP support has been disabled
(/opt/rt3/bin/…/lib/RT/Config.pm:275)

The second one seems to be the problem, any suggestions how to enable the
support.? or is there some other problem opening MyRT.html

Thank you,
Abdus Samad

On Sun, Jul 13, 2008 at 9:56 PM, chaim.rieger@gmail.com wrote:

Turn on debug on rt log and post the error
Sent via BlackBerry from T-Mobile

-----Original Message-----
From: “Abdus Samad” mr.samad@gmail.com

Date: Sun, 13 Jul 2008 21:46:04
To: rt-users@lists.bestpractical.com
Subject: [rt-users] MyRT Global Page error


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Thanks for your response, The Graphviz error is gone after reinstalling but
the gnupg error is still there even after installing the library.
The package have been installed by using the following command (apt-get
install GnuPG-Interface*). but the error logs still show
[Sun Jul 13 18:52:21 2008] [debug]: RT’s GnuPG libraries couldn’t
successfully read your configured GnuPG home directory
(/opt/rt3/var/data/gpg). PGP support has been disabled
(/opt/rt3/bin/…/lib/RT/Config.pm:275)
and I am not able to access the MyRT.html page which is giving the same
error.

Can’t call method “Content” on an undefined value at
/opt/rt3/share/html/Admin/Global/MyRT.html line 97.

When you ran RT’s upgrade, did it prompt you to do a database upgrade?
Did you do that upgrade? Do you still have the logs?

-j

Yes it did prompt me for upgrade and I did that, all the update up to 3.8
were done by the script it gave at the end of update (I did not do that
manyaly by goinng in each direcory and altering the tables) The scipt
included did not returned any errors so, I guess it did worked fine.
I think it might be a problem with the database, so, I checked if I have
InnoDB in MySQL enabled and found that it was not. I enabled that and also
altered all table to Innodb Engine. Now the next step I guess was to follow
the Upgrade.mysql help file present inside the package. I found that /
schema.mysql-4.0-4.1.pl must be run. Now I have a new problem when I run
this script. It says.

DBD::mysql::db column_info failed: column_info doesn’t support column
selection at etc/upgrade/schema.mysql-4.0-4.1.pl line 227.
DBD::mysql::db column_info failed: column_info doesn’t support column
selection at etc/upgrade/schema.mysql-4.0-4.1.pl line 227.

Can any one point me in the direction of resolution of this issue. Since
now, all my tables have InnoDB engine.
The version of mysql I am running is mysql Ver 14.7 Distrib 4.1.11, for
pc-linux-gnu (i386).

Thank you,
Abdus SamadOn Mon, Jul 14, 2008 at 1:54 AM, Jesse Vincent jesse@bestpractical.com wrote:

On Sun, Jul 13, 2008 at 11:58:21PM +0500, Abdus Samad wrote:

Thanks for your response, The Graphviz error is gone after reinstalling
but
the gnupg error is still there even after installing the library.
The package have been installed by using the following command (apt-get
install GnuPG-Interface*). but the error logs still show
[Sun Jul 13 18:52:21 2008] [debug]: RT’s GnuPG libraries couldn’t
successfully read your configured GnuPG home directory
(/opt/rt3/var/data/gpg). PGP support has been disabled
(/opt/rt3/bin/…/lib/RT/Config.pm:275)
and I am not able to access the MyRT.html page which is giving the same
error.

Can’t call method “Content” on an undefined value at
/opt/rt3/share/html/Admin/Global/MyRT.html line 97.

When you ran RT’s upgrade, did it prompt you to do a database upgrade?
Did you do that upgrade? Do you still have the logs?

-j

90 items => @items,
91 current_portlets => $default_portlets->Content,
92 OnSave => sub {
93 my ( $conf, $pane ) = @_;
94 $default_portlets->SetContent( $conf );
95 push @actions, loc( 'Global portlet [1] saved.’, $pane );
96 }
97 );
98
99 $m->comp( ‘/Widgets/SelectionBox:process’, %ARGS, self => $
, nojs
=> 1 )
100 for @panes;On Mon, Jul 14, 2008 at 12:00 AM, chaim.rieger@gmail.com wrote:

What’s in /opt/rt3/share/html/Admin/Global/MyRT.html line 97.

Sent via BlackBerry from T-Mobile


From: “Abdus Samad” mr.samad@gmail.com
Date: Sun, 13 Jul 2008 23:58:21 +0500

To: chaim.rieger@gmail.com
CC: rt-users-bounces@lists.bestpractical.com; <
rt-users@lists.bestpractical.com>
Subject: Re: [rt-users] MyRT Global Page error
Thanks for your response, The Graphviz error is gone after reinstalling but
the gnupg error is still there even after installing the library.
The package have been installed by using the following command (apt-get
install GnuPG-Interface*). but the error logs still show
[Sun Jul 13 18:52:21 2008] [debug]: RT’s GnuPG libraries couldn’t
successfully read your configured GnuPG home directory
(/opt/rt3/var/data/gpg). PGP support has been disabled
(/opt/rt3/bin/…/lib/RT/Config.pm:275)
and I am not able to access the MyRT.html page which is giving the same
error.

Can’t call method “Content” on an undefined value at
/opt/rt3/share/html/Admin/Global/MyRT.html line 97.

Thank you,
Abdus Samad

On Sun, Jul 13, 2008 at 11:25 PM, chaim.rieger@gmail.com wrote:

I would reinstall both

Sent via BlackBerry from T-Mobile


From: “Abdus Samad” mr.samad@gmail.com
Date: Sun, 13 Jul 2008 23:25:10 +0500
To: chaim.rieger@gmail.com
CC: rt-users-bounces@lists.bestpractical.com; <
rt-users@lists.bestpractical.com>
Subject: Re: [rt-users] MyRT Global Page error
I receive the following errors in debug logs.

[Sun Jul 13 18:21:49 2008] [debug]: You’ve enabled GraphViz, but we
couldn’t load the module: Can’t locate GraphViz.pm in @INC (@INC contains:
/opt/rt3/bin/…/local/lib /opt/rt3/bin/…/lib /etc/perl
/usr/local/lib/perl/5.8.4 /usr/local/share/perl/5.8.4 /usr/lib/perl5
/usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8
/usr/local/lib/site_perl . /etc/apache/ /etc/apache/lib/perl) at
/opt/rt3/bin/…/lib/RT/Config.pm line 249.
(/opt/rt3/bin/…/lib/RT/Config.pm:250)
[Sun Jul 13 18:21:49 2008] [debug]: RT’s GnuPG libraries couldn’t
successfully read your configured GnuPG home directory
(/opt/rt3/var/data/gpg). PGP support has been disabled
(/opt/rt3/bin/…/lib/RT/Config.pm:275)
[Sun Jul 13 18:21:55 2008] [debug]: RT’s GnuPG libraries couldn’t
successfully read your configured GnuPG home directory
(/opt/rt3/var/data/gpg). PGP support has been disabled
(/opt/rt3/bin/…/lib/RT/Config.pm:275)

The second one seems to be the problem, any suggestions how to enable the
support.? or is there some other problem opening MyRT.html

Thank you,
Abdus Samad

On Sun, Jul 13, 2008 at 9:56 PM, chaim.rieger@gmail.com wrote:

Turn on debug on rt log and post the error
Sent via BlackBerry from T-Mobile

-----Original Message-----
From: “Abdus Samad” mr.samad@gmail.com

Date: Sun, 13 Jul 2008 21:46:04
To: rt-users@lists.bestpractical.com
Subject: [rt-users] MyRT Global Page error


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Yes it did prompt me for upgrade and I did that, all the update up
to 3.8 were done by the script it gave at the end of update (I did
not do that manyaly by goinng in each direcory and altering the
tables) The scipt included did not returned any errors so, I guess
it did worked fine.
I think it might be a problem with the database, so, I checked if I
have InnoDB in MySQL enabled and found that it was not. I enabled
that and also altered all table to Innodb Engine. Now the next step
I guess was to follow the Upgrade.mysql help file present inside the
package. I found that /schema.mysql-4.0-4.1.pl must be run. Now I
have a new problem when I run this script. It says.

DBD::mysql::db column_info failed: column_info doesn’t support
column selection at etc/upgrade/schema.mysql-4.0-4.1.pl line 227.
DBD::mysql::db column_info failed: column_info doesn’t support
column selection at etc/upgrade/schema.mysql-4.0-4.1.pl line 227.

Can any one point me in the direction of resolution of this issue.
Since now, all my tables have InnoDB engine.
The version of mysql I am running is mysql Ver 14.7 Distrib 4.1.11,
for pc-linux-gnu (i386).

I suspect you saw the answer when I mentioned it to other users, but
try upgrading your DBD::mysql to the latest stable version.

-Jesse