Multiple instances of rt2 under one apache server

Hi there.

I've recently set up RT2. I've been through the docs, and the faq,

which so far is a bit sparse, but the mailing lists make up for that.

I work for the IT group for a bank. We have different groups within the bank
that deals with “requests”. Lets say for example: IT systems, IT development,
Facilities, and Operations. Each group will have their own administrative
users, and each will have their own group of queues for assigning new tasks.

To accomodate this, I’ve layed out the configuration as follows

  • unpack the RT software to /TOP/src

  • from /TOP/src, install the software for the SITE:

    make install RT_PATH=/TOP/SITE DB_DATABASE=rt2_SITE

(where SITE is systems, development, facilities, operations, etc)

What I now need to do is to be able to get apache’s configuration to support
each of these sites. I tried two methods:

  • set up a virtualhost for request.domain.com. DocumentRoot for the vhost is
    /TOP. Set up containers for each SITE under /TOP. Within the
    location containers, I’ve added the perl handlers and external
    authentication.

[ SNIP ]

DocumentRoot /TOP
ServerName request.ccmc.commerzbank.com

Order deny,allow
Deny from all
Allow from X.X.,Y.Y.,Z.Z.*



DocumentRoot /TOP
ServerName request.domain.com

Order deny,allow
Deny from all
Allow from 190.20.,10.196.,10.197.*

<Location /demo>
PerlModule Apache::DBI
PerlFreshRestart On
SetHandler perl-script
PerlHandler RT::Mason
PerlRequire /TOP/demo/bin/webmux.pl
AuthName "Request System Authentication"
AuthType Basic
PerlSetVar myPDC PDC
PerlSetVar myBDC BDC
PerlSetVar myDOMAIN DOMAIN
PerlAuthenHandler Apache::AuthenSmb
require valid-user

<Location /systems>
PerlModule Apache::DBI
PerlFreshRestart On
SetHandler perl-script
PerlHandler RT::Mason
PerlRequire /TOP/systems/bin/webmux.pl
AuthName "Request System Authentication"
AuthType Basic
PerlSetVar myPDC PDC
PerlSetVar myBDC BDC
PerlSetVar myDOMAIN DOMAIN
PerlAuthenHandler Apache::AuthenSmb
require valid-user

[SNIP]

[SNIP]

Using this configuration (plus mods to each config.pm to handle the MasonRoot
and WebExternalAuth along with the other site specific configs), I’m able to
point to the url http://request.domain.com/demo/WebRT/html/index.html to get
to the demo request system. Unfortunately, I cannot get to system, facilities
or development. When I start apache I get the following output:

Subroutine SetContentType redefined at /TOP/facilities/bin/webmux.pl line 88.
Subroutine CGIObject redefined at /TOP/facilities/bin/webmux.pl line 93.
Subroutine handler redefined at /TOP/facilities/bin/webmux.pl line 122.
Subroutine SetContentType redefined at /TOP/operations/bin/webmux.pl line 88.
Subroutine CGIObject redefined at /TOP/operations/bin/webmux.pl line 93.
Subroutine handler redefined at /TOP/operations/bin/webmux.pl line 122.
Subroutine SetContentType redefined at /TOP/systems/bin/webmux.pl line 88.
Subroutine CGIObject redefined at /TOP/systems/bin/webmux.pl line 93.
Subroutine handler redefined at /TOP/systems/bin/webmux.pl line 122.

Also, when I try to get to any of the other sites, I get this error in the
apache error log:

[Wed Oct 10 16:06:42 2001] [warn] [Mason] Cannot resolve file to component: /TOP/operations/WebRT/html/index.html (is file outside component root?)

My assumption, based on the fact that each “require webmux.pl” generates a
"redefined" error, is that the first (demo) rt2 instance is the only instance
that is used. This would also explain why the html for the other site is
considered “outside the component root”.

I’ve also tried using separate virtualhosts for each instance, but no dice. I
get the same errors about webmux.pl. Thus I suspect its soemthing that perl is
doing thats keeping this from happening.

Note that the /TOP contains some html that allows people to select which
instance they want. I dont have this as the document root because I need to
allow non-users (guest users) to select the url that will allow them to
request a new task, and not all requesters are users. Thus the authentication
is done on the which is under the document root.

Is there an issue preventing me from running multiple RT instances under the
same apache configuration? Am I just doing something very wrong?

Any ideas would be greatly appreciated.

Adam

p.s. this is rt2.0.8, perl 5.6.0, apache 1.3.20, mod_perl 1.26, and all the
perl modules listed in “make testdeps” for rt2.0.8

Hmm. Did you look at trying NameVirtualHost directive? It uses separate config ‘buckets’ so it might act very differently…On Wed, 10 Oct 2001 18:27:49 -0400, Adam R Prato arp-rt2@metachar.net wrote:

Hi there.

I’ve recently set up RT2. I’ve been through the docs, and the faq,
which so far is a bit sparse, but the mailing lists make up for that.

I work for the IT group for a bank. We have different groups within the bank
that deals with “requests”. Lets say for example: IT systems, IT development,
Facilities, and Operations. Each group will have their own administrative
users, and each will have their own group of queues for assigning new tasks.

To accomodate this, I’ve layed out the configuration as follows

  • unpack the RT software to /TOP/src

  • from /TOP/src, install the software for the SITE:

    make install RT_PATH=/TOP/SITE DB_DATABASE=rt2_SITE

(where SITE is systems, development, facilities, operations, etc)

What I now need to do is to be able to get apache’s configuration to support
each of these sites. I tried two methods:

  • set up a virtualhost for request.domain.com. DocumentRoot for the vhost is
    /TOP. Set up containers for each SITE under /TOP. Within the
    location containers, I’ve added the perl handlers and external
    authentication.

[ SNIP ]

DocumentRoot /TOP
ServerName request.ccmc.commerzbank.com

Order deny,allow
Deny from all
Allow from X.X.,Y.Y.,Z.Z.*



DocumentRoot /TOP
ServerName request.domain.com

Order deny,allow
Deny from all
Allow from 190.20.,10.196.,10.197.*

<Location /demo>
PerlModule Apache::DBI
PerlFreshRestart On
SetHandler perl-script
PerlHandler RT::Mason
PerlRequire /TOP/demo/bin/webmux.pl
AuthName "Request System Authentication"
AuthType Basic
PerlSetVar myPDC PDC
PerlSetVar myBDC BDC
PerlSetVar myDOMAIN DOMAIN
PerlAuthenHandler Apache::AuthenSmb
require valid-user

<Location /systems>
PerlModule Apache::DBI
PerlFreshRestart On
SetHandler perl-script
PerlHandler RT::Mason
PerlRequire /TOP/systems/bin/webmux.pl
AuthName "Request System Authentication"
AuthType Basic
PerlSetVar myPDC PDC
PerlSetVar myBDC BDC
PerlSetVar myDOMAIN DOMAIN
PerlAuthenHandler Apache::AuthenSmb
require valid-user

[SNIP]

[SNIP]

Using this configuration (plus mods to each config.pm to handle the MasonRoot
and WebExternalAuth along with the other site specific configs), I’m able to
point to the url http://request.domain.com/demo/WebRT/html/index.html to get
to the demo request system. Unfortunately, I cannot get to system, facilities
or development. When I start apache I get the following output:

Subroutine SetContentType redefined at /TOP/facilities/bin/webmux.pl line 88.
Subroutine CGIObject redefined at /TOP/facilities/bin/webmux.pl line 93.
Subroutine handler redefined at /TOP/facilities/bin/webmux.pl line 122.
Subroutine SetContentType redefined at /TOP/operations/bin/webmux.pl line 88.
Subroutine CGIObject redefined at /TOP/operations/bin/webmux.pl line 93.
Subroutine handler redefined at /TOP/operations/bin/webmux.pl line 122.
Subroutine SetContentType redefined at /TOP/systems/bin/webmux.pl line 88.
Subroutine CGIObject redefined at /TOP/systems/bin/webmux.pl line 93.
Subroutine handler redefined at /TOP/systems/bin/webmux.pl line 122.

Also, when I try to get to any of the other sites, I get this error in the
apache error log:

[Wed Oct 10 16:06:42 2001] [warn] [Mason] Cannot resolve file to component: /TOP/operations/WebRT/html/index.html (is file outside component root?)

My assumption, based on the fact that each “require webmux.pl” generates a
"redefined" error, is that the first (demo) rt2 instance is the only instance
that is used. This would also explain why the html for the other site is
considered “outside the component root”.

I’ve also tried using separate virtualhosts for each instance, but no dice. I
get the same errors about webmux.pl. Thus I suspect its soemthing that perl is
doing thats keeping this from happening.

Note that the /TOP contains some html that allows people to select which
instance they want. I dont have this as the document root because I need to
allow non-users (guest users) to select the url that will allow them to
request a new task, and not all requesters are users. Thus the authentication
is done on the which is under the document root.

Is there an issue preventing me from running multiple RT instances under the
same apache configuration? Am I just doing something very wrong?

Any ideas would be greatly appreciated.

Adam

p.s. this is rt2.0.8, perl 5.6.0, apache 1.3.20, mod_perl 1.26, and all the
perl modules listed in “make testdeps” for rt2.0.8


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

mod_perl isn’t compartmentalized within vhosts. what you want to do
is to set up each seperate RT instance on its own apache httpd running
on a high port bound to localhost. Then use mod_proxypass to pass
connections off to the right subserver. Or use the fastcgi handler.

-jOn Wed, Oct 10, 2001 at 06:27:49PM -0400, Adam R Prato wrote:

Hi there.

I’ve recently set up RT2. I’ve been through the docs, and the faq,
which so far is a bit sparse, but the mailing lists make up for that.

I work for the IT group for a bank. We have different groups within the bank
that deals with “requests”. Lets say for example: IT systems, IT development,
Facilities, and Operations. Each group will have their own administrative
users, and each will have their own group of queues for assigning new tasks.

To accomodate this, I’ve layed out the configuration as follows

  • unpack the RT software to /TOP/src

  • from /TOP/src, install the software for the SITE:

    make install RT_PATH=/TOP/SITE DB_DATABASE=rt2_SITE

(where SITE is systems, development, facilities, operations, etc)

What I now need to do is to be able to get apache’s configuration to support
each of these sites. I tried two methods:

  • set up a virtualhost for request.domain.com. DocumentRoot for the vhost is
    /TOP. Set up containers for each SITE under /TOP. Within the
    location containers, I’ve added the perl handlers and external
    authentication.

[ SNIP ]

DocumentRoot /TOP
ServerName request.ccmc.commerzbank.com

Order deny,allow
Deny from all
Allow from X.X.,Y.Y.,Z.Z.*



DocumentRoot /TOP
ServerName request.domain.com

Order deny,allow
Deny from all
Allow from 190.20.,10.196.,10.197.*

<Location /demo>
PerlModule Apache::DBI
PerlFreshRestart On
SetHandler perl-script
PerlHandler RT::Mason
PerlRequire /TOP/demo/bin/webmux.pl
AuthName "Request System Authentication"
AuthType Basic
PerlSetVar myPDC PDC
PerlSetVar myBDC BDC
PerlSetVar myDOMAIN DOMAIN
PerlAuthenHandler Apache::AuthenSmb
require valid-user

<Location /systems>
PerlModule Apache::DBI
PerlFreshRestart On
SetHandler perl-script
PerlHandler RT::Mason
PerlRequire /TOP/systems/bin/webmux.pl
AuthName "Request System Authentication"
AuthType Basic
PerlSetVar myPDC PDC
PerlSetVar myBDC BDC
PerlSetVar myDOMAIN DOMAIN
PerlAuthenHandler Apache::AuthenSmb
require valid-user

[SNIP]

[SNIP]

Using this configuration (plus mods to each config.pm to handle the MasonRoot
and WebExternalAuth along with the other site specific configs), I’m able to
point to the url http://request.domain.com/demo/WebRT/html/index.html to get
to the demo request system. Unfortunately, I cannot get to system, facilities
or development. When I start apache I get the following output:

Subroutine SetContentType redefined at /TOP/facilities/bin/webmux.pl line 88.
Subroutine CGIObject redefined at /TOP/facilities/bin/webmux.pl line 93.
Subroutine handler redefined at /TOP/facilities/bin/webmux.pl line 122.
Subroutine SetContentType redefined at /TOP/operations/bin/webmux.pl line 88.
Subroutine CGIObject redefined at /TOP/operations/bin/webmux.pl line 93.
Subroutine handler redefined at /TOP/operations/bin/webmux.pl line 122.
Subroutine SetContentType redefined at /TOP/systems/bin/webmux.pl line 88.
Subroutine CGIObject redefined at /TOP/systems/bin/webmux.pl line 93.
Subroutine handler redefined at /TOP/systems/bin/webmux.pl line 122.

Also, when I try to get to any of the other sites, I get this error in the
apache error log:

[Wed Oct 10 16:06:42 2001] [warn] [Mason] Cannot resolve file to component: /TOP/operations/WebRT/html/index.html (is file outside component root?)

My assumption, based on the fact that each “require webmux.pl” generates a
"redefined" error, is that the first (demo) rt2 instance is the only instance
that is used. This would also explain why the html for the other site is
considered “outside the component root”.

I’ve also tried using separate virtualhosts for each instance, but no dice. I
get the same errors about webmux.pl. Thus I suspect its soemthing that perl is
doing thats keeping this from happening.

Note that the /TOP contains some html that allows people to select which
instance they want. I dont have this as the document root because I need to
allow non-users (guest users) to select the url that will allow them to
request a new task, and not all requesters are users. Thus the authentication
is done on the which is under the document root.

Is there an issue preventing me from running multiple RT instances under the
same apache configuration? Am I just doing something very wrong?

Any ideas would be greatly appreciated.

Adam

p.s. this is rt2.0.8, perl 5.6.0, apache 1.3.20, mod_perl 1.26, and all the
perl modules listed in “make testdeps” for rt2.0.8


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

http://www.bestpractical.com/products/rt – Trouble Ticketing. Free.

Jesse,

Is the module you refer to actually mod_proxy rather than mod_proxypass in
which you need to enable the the “ProxyPass” Directive?

I did quick hunt on google and there are very few references to
mod_proxypass (your site being the most popular).

If so then this bit of doco
http://fsck.com/projects/rt/docs/2.0/manual.html#using_a_seperate_webserver_
with_
probably needs a minor correction also.

Cheers
AdamFrom: “Jesse Vincent” jesse@bestpractical.com
To: “Adam R Prato” arp-rt2@metachar.net
Cc: rt-users@lists.fsck.com
Sent: Thursday, October 11, 2001 10:23 AM
Subject: Re: [rt-users] [fwd] Multiple instances of rt2 under one apache
server.

mod_perl isn’t compartmentalized within vhosts. what you want to do
is to set up each seperate RT instance on its own apache httpd running
on a high port bound to localhost. Then use mod_proxypass to pass
connections off to the right subserver. Or use the fastcgi handler.

-j

Hi there.

I’ve recently set up RT2. I’ve been through the docs, and the faq,
which so far is a bit sparse, but the mailing lists make up for that.

I work for the IT group for a bank. We have different groups within the
bank

that deals with “requests”. Lets say for example: IT systems, IT
development,

Facilities, and Operations. Each group will have their own
administrative

users, and each will have their own group of queues for assigning new
tasks.

To accomodate this, I’ve layed out the configuration as follows

  • unpack the RT software to /TOP/src

  • from /TOP/src, install the software for the SITE:

    make install RT_PATH=/TOP/SITE DB_DATABASE=rt2_SITE

(where SITE is systems, development, facilities, operations, etc)

What I now need to do is to be able to get apache’s configuration to
support

each of these sites. I tried two methods:

/TOP. Set up containers for each SITE under /TOP. Within
the

location containers, I’ve added the perl handlers and external
authentication.

[ SNIP ]

DocumentRoot /TOP
ServerName request.ccmc.commerzbank.com

Order deny,allow
Deny from all
Allow from X.X.,Y.Y.,Z.Z.*



DocumentRoot /TOP
ServerName request.domain.com

Order deny,allow
Deny from all
Allow from 190.20.,10.196.,10.197.*

<Location /demo>
PerlModule Apache::DBI
PerlFreshRestart On
SetHandler perl-script
PerlHandler RT::Mason
PerlRequire /TOP/demo/bin/webmux.pl
AuthName "Request System Authentication"
AuthType Basic
PerlSetVar myPDC PDC
PerlSetVar myBDC BDC
PerlSetVar myDOMAIN DOMAIN
PerlAuthenHandler Apache::AuthenSmb
require valid-user

<Location /systems>
PerlModule Apache::DBI
PerlFreshRestart On
SetHandler perl-script
PerlHandler RT::Mason
PerlRequire /TOP/systems/bin/webmux.pl
AuthName "Request System Authentication"
AuthType Basic
PerlSetVar myPDC PDC
PerlSetVar myBDC BDC
PerlSetVar myDOMAIN DOMAIN
PerlAuthenHandler Apache::AuthenSmb
require valid-user

[SNIP]

[SNIP]

Using this configuration (plus mods to each config.pm to handle the
MasonRoot

and WebExternalAuth along with the other site specific configs), I’m
able to

point to the url http://request.domain.com/demo/WebRT/html/index.html to
get

to the demo request system. Unfortunately, I cannot get to system,
facilities

or development. When I start apache I get the following output:

Subroutine SetContentType redefined at /TOP/facilities/bin/webmux.pl
line 88.

Subroutine CGIObject redefined at /TOP/facilities/bin/webmux.pl line 93.
Subroutine handler redefined at /TOP/facilities/bin/webmux.pl line 122.
Subroutine SetContentType redefined at /TOP/operations/bin/webmux.pl
line 88.

Subroutine CGIObject redefined at /TOP/operations/bin/webmux.pl line 93.
Subroutine handler redefined at /TOP/operations/bin/webmux.pl line 122.
Subroutine SetContentType redefined at /TOP/systems/bin/webmux.pl line

Subroutine CGIObject redefined at /TOP/systems/bin/webmux.pl line 93.
Subroutine handler redefined at /TOP/systems/bin/webmux.pl line 122.

Also, when I try to get to any of the other sites, I get this error in
the

apache error log:

[Wed Oct 10 16:06:42 2001] [warn] [Mason] Cannot resolve file to
component: /TOP/operations/WebRT/html/index.html (is file outside component
root?)

My assumption, based on the fact that each “require webmux.pl” generates
a

“redefined” error, is that the first (demo) rt2 instance is the only
instance

that is used. This would also explain why the html for the other site is
considered “outside the component root”.

I’ve also tried using separate virtualhosts for each instance, but no
dice. I

get the same errors about webmux.pl. Thus I suspect its soemthing that
perl is

doing thats keeping this from happening.

Note that the /TOP contains some html that allows people to select which
instance they want. I dont have this as the document root because I need
to

allow non-users (guest users) to select the url that will allow them to
request a new task, and not all requesters are users. Thus the
authentication

is done on the which is under the document root.

Is there an issue preventing me from running multiple RT instances under
the

same apache configuration? Am I just doing something very wrong?

Any ideas would be greatly appreciated.

Adam

p.s. this is rt2.0.8, perl 5.6.0, apache 1.3.20, mod_perl 1.26, and all
the

perl modules listed in “make testdeps” for rt2.0.8


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users


http://www.bestpractical.com/products/rt – Trouble Ticketing. Free.


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

sheepish grin
Er. right. Thanks. I’ll fix up the docs.

-jOn Thu, Oct 11, 2001 at 10:54:27AM +1000, Adam Clarke wrote:

Jesse,

Is the module you refer to actually mod_proxy rather than mod_proxypass in
which you need to enable the the “ProxyPass” Directive?

I did quick hunt on google and there are very few references to
mod_proxypass (your site being the most popular).

If so then this bit of doco
http://fsck.com/projects/rt/docs/2.0/manual.html#using_a_seperate_webserver_
with_
probably needs a minor correction also.

Cheers
Adam
----- Original Message -----
From: “Jesse Vincent” jesse@bestpractical.com
To: “Adam R Prato” arp-rt2@metachar.net
Cc: rt-users@lists.fsck.com
Sent: Thursday, October 11, 2001 10:23 AM
Subject: Re: [rt-users] [fwd] Multiple instances of rt2 under one apache
server.

mod_perl isn’t compartmentalized within vhosts. what you want to do
is to set up each seperate RT instance on its own apache httpd running
on a high port bound to localhost. Then use mod_proxypass to pass
connections off to the right subserver. Or use the fastcgi handler.

-j

On Wed, Oct 10, 2001 at 06:27:49PM -0400, Adam R Prato wrote:

Hi there.

I’ve recently set up RT2. I’ve been through the docs, and the faq,
which so far is a bit sparse, but the mailing lists make up for that.

I work for the IT group for a bank. We have different groups within the
bank

that deals with “requests”. Lets say for example: IT systems, IT
development,

Facilities, and Operations. Each group will have their own
administrative

users, and each will have their own group of queues for assigning new
tasks.

To accomodate this, I’ve layed out the configuration as follows

  • unpack the RT software to /TOP/src

  • from /TOP/src, install the software for the SITE:

    make install RT_PATH=/TOP/SITE DB_DATABASE=rt2_SITE

(where SITE is systems, development, facilities, operations, etc)

What I now need to do is to be able to get apache’s configuration to
support

each of these sites. I tried two methods:

/TOP. Set up containers for each SITE under /TOP. Within
the

location containers, I’ve added the perl handlers and external
authentication.

[ SNIP ]

DocumentRoot /TOP
ServerName request.ccmc.commerzbank.com

Order deny,allow
Deny from all
Allow from X.X.,Y.Y.,Z.Z.*



DocumentRoot /TOP
ServerName request.domain.com

Order deny,allow
Deny from all
Allow from 190.20.,10.196.,10.197.*

<Location /demo>
PerlModule Apache::DBI
PerlFreshRestart On
SetHandler perl-script
PerlHandler RT::Mason
PerlRequire /TOP/demo/bin/webmux.pl
AuthName "Request System Authentication"
AuthType Basic
PerlSetVar myPDC PDC
PerlSetVar myBDC BDC
PerlSetVar myDOMAIN DOMAIN
PerlAuthenHandler Apache::AuthenSmb
require valid-user

<Location /systems>
PerlModule Apache::DBI
PerlFreshRestart On
SetHandler perl-script
PerlHandler RT::Mason
PerlRequire /TOP/systems/bin/webmux.pl
AuthName "Request System Authentication"
AuthType Basic
PerlSetVar myPDC PDC
PerlSetVar myBDC BDC
PerlSetVar myDOMAIN DOMAIN
PerlAuthenHandler Apache::AuthenSmb
require valid-user

[SNIP]

[SNIP]

Using this configuration (plus mods to each config.pm to handle the
MasonRoot

and WebExternalAuth along with the other site specific configs), I’m
able to

point to the url http://request.domain.com/demo/WebRT/html/index.html to
get

to the demo request system. Unfortunately, I cannot get to system,
facilities

or development. When I start apache I get the following output:

Subroutine SetContentType redefined at /TOP/facilities/bin/webmux.pl
line 88.

Subroutine CGIObject redefined at /TOP/facilities/bin/webmux.pl line 93.
Subroutine handler redefined at /TOP/facilities/bin/webmux.pl line 122.
Subroutine SetContentType redefined at /TOP/operations/bin/webmux.pl
line 88.

Subroutine CGIObject redefined at /TOP/operations/bin/webmux.pl line 93.
Subroutine handler redefined at /TOP/operations/bin/webmux.pl line 122.
Subroutine SetContentType redefined at /TOP/systems/bin/webmux.pl line

Subroutine CGIObject redefined at /TOP/systems/bin/webmux.pl line 93.
Subroutine handler redefined at /TOP/systems/bin/webmux.pl line 122.

Also, when I try to get to any of the other sites, I get this error in
the

apache error log:

[Wed Oct 10 16:06:42 2001] [warn] [Mason] Cannot resolve file to
component: /TOP/operations/WebRT/html/index.html (is file outside component
root?)

My assumption, based on the fact that each “require webmux.pl” generates
a

“redefined” error, is that the first (demo) rt2 instance is the only
instance

that is used. This would also explain why the html for the other site is
considered “outside the component root”.

I’ve also tried using separate virtualhosts for each instance, but no
dice. I

get the same errors about webmux.pl. Thus I suspect its soemthing that
perl is

doing thats keeping this from happening.

Note that the /TOP contains some html that allows people to select which
instance they want. I dont have this as the document root because I need
to

allow non-users (guest users) to select the url that will allow them to
request a new task, and not all requesters are users. Thus the
authentication

is done on the which is under the document root.

Is there an issue preventing me from running multiple RT instances under
the

same apache configuration? Am I just doing something very wrong?

Any ideas would be greatly appreciated.

Adam

p.s. this is rt2.0.8, perl 5.6.0, apache 1.3.20, mod_perl 1.26, and all
the

perl modules listed in “make testdeps” for rt2.0.8


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users


http://www.bestpractical.com/products/rt – Trouble Ticketing. Free.


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

http://www.bestpractical.com/products/rt – Trouble Ticketing. Free.

mod_perl isn’t compartmentalized within vhosts. what you want to do
is to set up each seperate RT instance on its own apache httpd running
on a high port bound to localhost. Then use mod_proxypass to pass
connections off to the right subserver. Or use the fastcgi handler.

-j

Or, if it were me, running in a private address space (RFC1918 et. al)
simply bind each apache instance to a different local address. Sounds a
lot simpler to me…

Greg White

  • Greg White wrote on 10 Oct 2001:> On Wed, Oct 10, 2001 at 08:23:51PM -0400, Jesse Vincent wrote:

mod_perl isn’t compartmentalized within vhosts. what you want to do
is to set up each seperate RT instance on its own apache httpd running
on a high port bound to localhost. Then use mod_proxypass to pass
connections off to the right subserver. Or use the fastcgi handler.

-j

Or, if it were me, running in a private address space (RFC1918 et. al)
simply bind each apache instance to a different local address. Sounds a
lot simpler to me…

Thanks to everyone for their advice. I’m running apache on different high ports
rather than use an additional IP address. Wether I use an IP address or a
high port, I still have to maintain N number of configurations for N number of
RT instances.

The configuration now looks like:

ProxyPass /demo       http://request.domain.com:8011/demo
ProxyPass /systems    http://request.domain.com:8012/systems
ProxyPass /facilities http://request.domain.com:8013/facilities
ProxyPass /operations http://request.domain.com:8014/operations

(Yes, I’m still obfuscating our domain even though I was tired in the previous
email and leaked both the domain and the IP space used. How lame of me).

each of these apache configurations have a very typical instance of rt
configured:

DocumentRoot /proj/request ServerName request.domain.com PerlModule Apache::DBI PerlFreshRestart On SetHandler perl-script Order deny,allow Deny from all Allow from X.X.*,Y.Y.*,Z.Z.* PerlHandler RT::Mason PerlRequire /proj/request/INSTANCE/bin/webmux.pl AuthName "Request System Authentication" AuthType Basic PerlSetVar myPDC PDC PerlSetVar myBDC BDC PerlSetVar myDOMAIN DOMAIN PerlAuthenHandler Apache::AuthenSmb require valid-user

I’ve modified my apache startup to look for /var/apache.* (I may investigate
something more elegant), and start up an apache process for each apache dir if
the httpd.config exists in /var/HTTPDIR/conf/httpd.conf

Onward to future rt battles…

Adam

each of these apache configurations have a very typical instance of rt
configured:

DocumentRoot /proj/request ServerName request.domain.com PerlModule Apache::DBI PerlFreshRestart On SetHandler perl-script Order deny,allow Deny from all Allow from X.X.*,Y.Y.*,Z.Z.* PerlHandler RT::Mason PerlRequire /proj/request/INSTANCE/bin/webmux.pl AuthName "Request System Authentication" AuthType Basic PerlSetVar myPDC PDC PerlSetVar myBDC BDC PerlSetVar myDOMAIN DOMAIN PerlAuthenHandler Apache::AuthenSmb require valid-user

Question.

Do you think it would be possible to move rt.jpg out of / and into /NoAuth?
The reason I ask is because for some reason, the rt.jpg causes me to have
to type in the login/password twice in this configuration. First for the main
index.html, and then a second time for rt.jpg. If it moves to /NoAuth, I can
put a separate container that doesnt require any authentication,
which will fix this.

Or perhaps, the better answer is to cache the credentials better?

Comments?

Adam

  • Greg White wrote on 10 Oct 2001:> On Wed, Oct 10, 2001 at 08:23:51PM -0400, Jesse Vincent wrote:

mod_perl isn’t compartmentalized within vhosts. what you want to do
is to set up each seperate RT instance on its own apache httpd running
on a high port bound to localhost. Then use mod_proxypass to pass
connections off to the right subserver. Or use the fastcgi handler.

-j

Or, if it were me, running in a private address space (RFC1918 et. al)
simply bind each apache instance to a different local address. Sounds a
lot simpler to me…

Thanks to everyone for their advice. I’m running apache on different high ports
rather than use an additional IP address. Wether I use an IP address or a
high port, I still have to maintain N number of configurations for N number of
RT instances.

The configuration now looks like:

ProxyPass /demo       http://request.domain.com:8011/demo
ProxyPass /systems    http://request.domain.com:8012/systems
ProxyPass /facilities http://request.domain.com:8013/facilities
ProxyPass /operations http://request.domain.com:8014/operations

(Yes, I’m still obfuscating our domain even though I was tired in the previous
email and leaked both the domain and the IP space used. How lame of me).

each of these apache configurations have a very typical instance of rt
configured:

DocumentRoot /proj/request ServerName request.domain.com PerlModule Apache::DBI PerlFreshRestart On SetHandler perl-script Order deny,allow Deny from all Allow from X.X.*,Y.Y.*,Z.Z.* PerlHandler RT::Mason PerlRequire /proj/request/INSTANCE/bin/webmux.pl AuthName "Request System Authentication" AuthType Basic PerlSetVar myPDC PDC PerlSetVar myBDC BDC PerlSetVar myDOMAIN DOMAIN PerlAuthenHandler Apache::AuthenSmb require valid-user

I’ve modified my apache startup to look for /var/apache.* (I may investigate
something more elegant), and start up an apache process for each apache dir if
the httpd.config exists in /var/HTTPDIR/conf/httpd.conf

Onward to future rt battles…

Adam

I’ve seen that with a broken Apache::Cookie or CGI::Cookie or Apache::Session.On Thu, Oct 11, 2001 at 01:40:31AM -0400, Adam R Prato wrote:

each of these apache configurations have a very typical instance of rt
configured:

DocumentRoot /proj/request ServerName request.domain.com PerlModule Apache::DBI PerlFreshRestart On SetHandler perl-script Order deny,allow Deny from all Allow from X.X.*,Y.Y.*,Z.Z.* PerlHandler RT::Mason PerlRequire /proj/request/INSTANCE/bin/webmux.pl AuthName "Request System Authentication" AuthType Basic PerlSetVar myPDC PDC PerlSetVar myBDC BDC PerlSetVar myDOMAIN DOMAIN PerlAuthenHandler Apache::AuthenSmb require valid-user

Question.

Do you think it would be possible to move rt.jpg out of / and into /NoAuth?
The reason I ask is because for some reason, the rt.jpg causes me to have
to type in the login/password twice in this configuration. First for the main
index.html, and then a second time for rt.jpg. If it moves to /NoAuth, I can
put a separate container that doesnt require any authentication,
which will fix this.

Or perhaps, the better answer is to cache the credentials better?

Comments?

Adam


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

http://www.bestpractical.com/products/rt – Trouble Ticketing. Free.