Moving database from production 4.2 to development server 4.4

Hello All,

Today i am trying to put our latest version of RT into service but i am running into issues.

So far i’ve got my mysqldump witht he sql.gz file using this command

mysqldump -u username -p rt4 --default-character-set=binary | /bin/gzip > /mysql/mysql-infotrackdb-date +\%m\%d\%y.sql.gz

I want to use this database from version 4.2 to my our test server running 4.4 and import it into a new database named rt5 on the test server.

I tried once before but ended up breaking the whole thing and now am reverting to a previous snapshot.

Would love any guidance on getting this up and running.

What went wrong? Did you run the database upgrade steps before trying to access the web UI?

well i tried imported my database and then i think my it guy changed the dns binding and that may have been what pooched it.

What i’d really like how to do this properly because im a bit lost.

The README has instructions under item 6b:

and you can see notes on the changes from 4.2 -> 4.4:
https://docs.bestpractical.com/rt/4.4.4/UPGRADING-4.4.html

Thank you, I now understand you have to run the configure script from the install files to perform the commands to upgrade the database.

I suppose i should read the README more thoroughly and trust what it says to do.

I also ran UPDATE rt4.Users SET ExternalAuthId = NULL; in mysql as the newer version doesn’t use that column and was throwing errors.