More install issues

I am still working on installing RT here. I put the oracle setup on
the back burner for the moment, our DBA here thinks that perhaps the
perl that is parsing schema.Oracle expects newlines between create
statements and thats why it errors on every sequence creation
attempting to create it twice. I intend to test the theory later today.

Right now my problems stem from Apache2 and mod_perl2. I was under
the impression using mod_perl2 is supported in the 3.5.x Testing
line, though I find any definitive statement to that effect hard to
come by. CentOS provides mod_perl 1.99_16 which I did find was
unsupported so I removed the package and built my own mod_perl 2.0.2
and verified its working by loading Apache::Status. here is my list
of issues with loading our rt page.

starting Apache yields this error:
Starting httpd: No root path(s) specified at /opt/rt3/bin/webmux.pl
line 98
I have tried setting Set($WebPath , “”); to arbitrary values and it
seems completely ignored in my RT_SiteConfig.pm

going to the baseurl rt.geneseo.edu downloads index.html

going to rt.geneseo.edu/index.html loads a blank page. the source for
the file implies I should at the least get an error message about rt
being an incomplete install.

the debug log reveals this error:
[Wed Jan 25 15:57:27 2006] [crit]: The ‘comp’ parameter (undef) to
HTML::Mason::Request::CGI->new()
was an ‘undef’, which is not one of the allowed types: scalar object

Stack:
[/usr/lib/perl5/site_perl/5.8.5/HTML/Mason/CGIHandler.pm:127]
[/usr/lib/perl5/site_perl/5.8.5/HTML/Mason/CGIHandler.pm:63]
[/opt/rt3/bin/webmux.pl:122]
[-e:0] (/opt/rt3/bin/webmux.pl:124)
(END)

My virtual host config is:

<VirtualHost 137.238.1.86>
ServerName rt.geneseo.edu
DocumentRoot /opt/rt3/share/html
ErrorLog logs/rt_error_log
CustomLog logs/rt_access_log combined
AddDefaultCharset UTF-8

 PerlModule Apache2::compat
 PerlModule Apache::DBI
 PerlRequire /opt/rt3/bin/webmux.pl

 <Location />

RewriteEngine On

RedirectMatch permanent (.*)/$ $1/index.html

  SetHandler perl-script
  PerlHandler RT::Mason
 </Location>

Does anyone have any idea what is going on here? am I missing some
parameters needed for working with mod_perl2?

thanks for any help.

Shawn Plummer
Systems Manager
CIT SUNY Geneseo
"The mind can make substance, and people planets of its own with
beings brighter than have been, and give a breath to forms which can
outlive all flesh." -Lord Byron

smime.p7s (2.42 KB)

Shawn Plummer wrote:

Right now my problems stem from Apache2 and mod_perl2. … Does anyone
have any idea what is going on here? am I missing some parameters
needed for working with mod_perl2?

We use an empty WebPath. I had to set ‘UseCanonicalName’ to ‘on’.

Could you include a little more server config information concerning
the 1.86 host?

Do you have a ‘NameVirtualHost’ and port defined for your vhost?

What are your default vhosts?

Where does your Apache ‘Listen’?

Greg