Modifying Data Label in RT 3.8.1

Greetings Everyone!

My second question of the day (and hopefully my final).

Basics:
I’m running RT 3.8.1 on Linux Ubuntu 8.04 Hardy, Apache 2.2.8, Perl 5.8.8,
and MySQL 5.0.51a-3ubuntu5.1. We want to be able to track the total time
spent on a ticket and the time spent that we should bill to a client. As
such, we developed our own internal process where we put the total time
spent on a ticket in the Time Worked column and the time we plan to bill the
client for (which is usually less than the total time) in the Time Estimated
column.

*The Problem:
*Is it possible to change the Time Estimated data label to read Billable
Time
in the interface? That would greatly help reduce confusion.

Thanks in advance!
-Chris

Is it possible to change the Time Estimated data label to read Billable Time
in the interface? That would greatly help reduce confusion.

Customize a local copy of your language’s po file? e.g;

mkdir -p /opt/rt3/local/lib/RT/I18N/
cp /opt/rt3/lib/RT/I18N/en.po /opt/rt3/local/lib/RT/I18N/en.po
emacs /opt/rt3/local/lib/RT/I18N/en.po

Cambridge Energy Alliance: Save money. Save the planet.

Sorry - I’m a total n00b here. Can you explain what that’s doing exactly? I
can’t quite follow what’s happening. Looks like, you make a new dir, copy
some specific library file (language po file?) and then “emacs” the lib file
(don’t know what that does).

Then, would you go edit the copied file and look for Time Estimated?

Thanks in advance, sorry for the newbie questions…
-ChrisOn Fri, Feb 13, 2009 at 12:56 PM, Jerrad Pierce < jpierce@cambridgeenergyalliance.org> wrote:

Is it possible to change the Time Estimated data label to read Billable
Time
in the interface? That would greatly help reduce confusion.

Customize a local copy of your language’s po file? e.g;

mkdir -p /opt/rt3/local/lib/RT/I18N/
cp /opt/rt3/lib/RT/I18N/en.po /opt/rt3/local/lib/RT/I18N/en.po
emacs /opt/rt3/local/lib/RT/I18N/en.po


Cambridge Energy Alliance: Save money. Save the planet.


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Sorry - I’m a total n00b here. Can you explain what that’s doing exactly? I
can’t quite follow what’s happening. Looks like, you make a new dir,
uh, yeah

copy some specific library file (language po file?)
uh-huh

and then “emacs” the lib file (don’t know what that does).
It’s a text editor. Use whatever you want to make the changes.
Emacs happens to have some understanding of po files,
that should prevent you from bungling things.

Specifically you want to add:

msgid "Time Estimated"
msgstr “Time Billed”

to your local localization file.
Cambridge Energy Alliance: Save money. Save the planet.

Hrm. I added:
#: NOT FOUND IN SOURCE
msgid "Time Estimated"
msgstr “Billable Time”

to the bottom of /opt/rt3/local/lib/RT/I18N/en.po and restarted apache2. No
luck. Was I supposed to update the other file? Did I do something wrong?

Thanks so much for your help…
-ChrisOn Fri, Feb 13, 2009 at 1:19 PM, Jerrad Pierce < jpierce@cambridgeenergyalliance.org> wrote:

Specifically you want to add:

msgid "Time Estimated"
msgstr “Time Billed”

to your local localization file.

Cambridge Energy Alliance: Save money. Save the planet.

to the bottom of /opt/rt3/local/lib/RT/I18N/en.po and restarted apache2. No
You don’t need to restart, HUP/graceful/reload is good enough.

luck. Was I supposed to update the other file? Did I do something wrong?

Hmm, it seems RT doesn’t support local localizations, without creating
a RT/I18N_Local.pm file. I think you might be able to get away with just:

cp /opt/rt3/local/lib/RT/I18N.pm /opt/rt3/local/lib/RT/I18N_Local.pm

It seems like overkill, but I18N.pm uses the FILE token to locate po files.
Cambridge Energy Alliance: Save money. Save the planet.

It REALLY didn’t like that. I wasn’t able to start apache with that file. I
had to delete the file to get it to start again. (BTW, HUP isn’t a known
thing on my ubuntu box…)

-ChrisOn Fri, Feb 13, 2009 at 1:48 PM, Jerrad Pierce < jpierce@cambridgeenergyalliance.org> wrote:

to the bottom of /opt/rt3/local/lib/RT/I18N/en.po and restarted apache2.
No
You don’t need to restart, HUP/graceful/reload is good enough.

luck. Was I supposed to update the other file? Did I do something wrong?

Hmm, it seems RT doesn’t support local localizations, without creating
a RT/I18N_Local.pm file. I think you might be able to get away with just:

cp /opt/rt3/local/lib/RT/I18N.pm /opt/rt3/local/lib/RT/I18N_Local.pm

It seems like overkill, but I18N.pm uses the FILE token to locate po
files.

Cambridge Energy Alliance: Save money. Save the planet.

It REALLY didn’t like that. I wasn’t able to start apache with that file. I
had to delete the file to get it to start again.
Any information from error logs to report? Did you not copy I18N/i_default.pm
to local too?

I did, and works fine for me.

(BTW, HUP isn’t a known thing on my ubuntu box…)
Even Ubuntu understands SIGHUP
Cambridge Energy Alliance: Save money. Save the planet.

Thanks for all the help! I feel like you’ve really gone above and beyond
helping me sort this out!

Unfortunately, it’s still not working (and I’m 95% sure it’s all me).

Here’s what I’ve done:

Created a file called rt3/lib/RT/I18N/en_qaa.po. That file contains the
following:
#: added 2/16/2009 by CN to modify a data label. According to
#: instructions at http://wiki.bestpractical.com/view/CustomizeLabel

msgid "Time Estimated"
msgstr “Billable Time”

I then tried SIGHUP and HUP at the command line and just got -bash: HUP:
command not found
(which I think is just a function of me misunderstanding
what you’re telling me to do to gracefully restart the server). So, I went
with the old standby of sudo /etc/init.d/apache2 restart and then removed
all the cookies in my browser associated with the Web site. When I started a
new session, logged back into the Web site, I still see Time
Estimated
when I go to edit a ticket.

Thanks so much for sticking with me on this problem!
-ChrisOn Fri, Feb 13, 2009 at 2:47 PM, Jerrad Pierce < jpierce@cambridgeenergyalliance.org> wrote:

On Fri, Feb 13, 2009 at 14:32, Jerrad Pierce jpierce@cambridgeenergyalliance.org wrote:

On Fri, Feb 13, 2009 at 14:12, Chris Nelson cnelson@delivra.com wrote:

It REALLY didn’t like that. I wasn’t able to start apache with that
file. I

had to delete the file to get it to start again.
Any information from error logs to report? Did you not copy I18N/
i_default.pm
to local too?

I did, and works fine for me.
Actually, to clarify, see:
http://wiki.bestpractical.com/view/CustomizeLabel

This may not be the sanctioned way/what Best Practical had in mind,
but it seems close, and it works. Others are welcome to make corrections.


Cambridge Energy Alliance: Save money. Save the planet.

Ok. I added the lines:
msgid "Time Estimated"
msgstr “Billable Time”

to the bottom of rt3/lib/RT/I18N/en.po, restarted apache, and it worked
like a champ! Is there a way to get RT to use the en_qaa.po file so that
upgrades won’t destroy those changes?

Thanks so very much for the help!
-ChrisOn Mon, Feb 16, 2009 at 2:10 PM, Chris Nelson cnelson@delivra.com wrote:

Thanks for all the help! I feel like you’ve really gone above and beyond
helping me sort this out!

Unfortunately, it’s still not working (and I’m 95% sure it’s all me).

Here’s what I’ve done:

Created a file called rt3/lib/RT/I18N/en_qaa.po. That file contains the
following:
#: added 2/16/2009 by CN to modify a data label. According to
#: instructions at http://wiki.bestpractical.com/view/CustomizeLabel

msgid "Time Estimated"
msgstr “Billable Time”

I then tried SIGHUP and HUP at the command line and just got -bash: HUP:
command not found
(which I think is just a function of me
misunderstanding what you’re telling me to do to gracefully restart the
server). So, I went with the old standby of sudo /etc/init.d/apache2
restart
and then removed all the cookies in my browser associated with
the Web site. When I started a new session, logged back into the Web site, I
still see Time Estimated when I go to edit a ticket.

Thanks so much for sticking with me on this problem!
-Chris

On Fri, Feb 13, 2009 at 2:47 PM, Jerrad Pierce < jpierce@cambridgeenergyalliance.org> wrote:

On Fri, Feb 13, 2009 at 14:32, Jerrad Pierce jpierce@cambridgeenergyalliance.org wrote:

On Fri, Feb 13, 2009 at 14:12, Chris Nelson cnelson@delivra.com wrote:

It REALLY didn’t like that. I wasn’t able to start apache with that
file. I

had to delete the file to get it to start again.
Any information from error logs to report? Did you not copy I18N/
i_default.pm
to local too?

I did, and works fine for me.
Actually, to clarify, see:
http://wiki.bestpractical.com/view/CustomizeLabel

This may not be the sanctioned way/what Best Practical had in mind,
but it seems close, and it works. Others are welcome to make corrections.


Cambridge Energy Alliance: Save money. Save the planet.

to the bottom of rt3/lib/RT/I18N/en.po, restarted apache, and it worked like
a champ! Is there a way to get RT to use the en_qaa.po file so that upgrades
won’t destroy those changes?
Yes, you have to set your language to that dialect in user preferences.
You should also be able to set the system default language to that dialect.

Cambridge Energy Alliance: Save money. Save the planet.

Same issue here. How do you set the system default language? I could
not find anything in the User interface.

Another thread suggested to add the following in the rt3/etc/RT_SiteConfig.pm
Set($AutoCreate, {Privileged => 1, Lang => ‘fr’});

But that did not work.

Thanks,
ThierryOn Mon, Feb 16, 2009 at 2:44 PM, Jerrad Pierce jpierce@cambridgeenergyalliance.org wrote:

On Mon, Feb 16, 2009 at 15:04, Chris Nelson cnelson@delivra.com wrote:

to the bottom of rt3/lib/RT/I18N/en.po, restarted apache, and it worked like
a champ! Is there a way to get RT to use the en_qaa.po file so that upgrades
won’t destroy those changes?
Yes, you have to set your language to that dialect in user preferences.
You should also be able to set the system default language to that dialect.


Cambridge Energy Alliance: Save money. Save the planet.


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com