Modify the deafult home page?

Is there a way to modify the default home page for provilidged user to
show more ticket search results? Specifically, I’d like to see a list
of “stalled” tickets that I own so I can remember to give the requestors
of these tickets a poke every once in a while.

Thanks in advance,
Daryl

Is there is a way to change the default results that
are displayed when a queue is selected? I’d like to
see the most recent tickets at the top, descending
order, sorted by ticket number. Under the
current/default model, I click on “Id” twice to get it
to sort by ticket number, descending.

Thanks!

Do you Yahoo!?
SBC Yahoo! DSL - Now only $29.95 per month!
http://sbc.yahoo.com

Daryl,

Try http://www.fsck.com/pub/rt/contrib/2.0/

stalled
stalled.READMEOn Tue, 2003-07-01 at 11:38, Daryl G. Jurbala wrote:

Is there a way to modify the default home page for provilidged user to
show more ticket search results? Specifically, I’d like to see a list
of “stalled” tickets that I own so I can remember to give the requestors
of these tickets a poke every once in a while.

Thanks in advance,
Daryl


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

Ok, after much hassle we’ve finally managed to make RT (3.0.3)
accept tickets via eMails with international characters.
I can compose a message with any charactes like öäü and it
creates and displays the ticket nicely. Big hooray!

However modifying the ticket from within the web interface
now messes up the ISO characters.

For example if I simply comment on a ticket, the ticket text
(with the umlauts) is nicely copied to the web mask but when I
submit it, the umlauts are garbeled.

For example I create the following ticket via eMail:>>>
From: Gerald Rüscher ruescher@math-mail.uni-paderborn.de
Date: Wed, 2 Jul 2003 16:08:04 +0200
Subject: International Ticket
To: pem2@math-mail.uni-paderborn.de
CC:
1 umlaut: xöx
aaaa
2 umlauts: xööx
aaaa
3 umlauts: xöööx
aaaa
<<<

Commenting this ticket without modifiying the web mask yields:

[ruescher@math-mail.uni-paderborn.de - Mi 02. Jul 2003, 16:08:24]:

1 umlaut: xöx
aaaa
2 umlauts: xööx
aaaa
3 umlauts: xöööx
aaa
<<<<

The unlauts have been somehow converted and in each line following
a line containing an umlaut, leading characters are dropped.

What’s going on here? Commenting on a ticket doesn’t involve any
eMails so why does RT mess up it’s own data? I give up :slight_smile:

Jerry

Gerald Rüscher
Lt. Rechnerbetrieb Mathematik
ruescher@math.upb.de

Universität Paderborn
Fakultät V - Mathematik/Informatik/Elektrotechnik
Warburger Str. 100
D-33098 Paderborn
Tel : 05251/60-2600
Fax : 05251/60-3729

One way would be to modify the QuickSearch element to change the sort
order. Something that looks like

TicketsSortBy=Id&TicketsSortOrder=DESC

could be inserted into the link

Hey, while we’re on the subject if there’s a RT way to do this let me
know.On Tue, 2003-07-01 at 11:50, Joseph Spenner wrote:

Is there is a way to change the default results that
are displayed when a queue is selected? I’d like to
see the most recent tickets at the top, descending
order, sorted by ticket number. Under the
current/default model, I click on “Id” twice to get it
to sort by ticket number, descending.

Thanks!


Do you Yahoo!?
SBC Yahoo! DSL - Now only $29.95 per month!
http://sbc.yahoo.com


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

The unlauts have been somehow converted and in each line following
a line containing an umlaut, leading characters are dropped.

What’s going on here? Commenting on a ticket doesn’t involve any
eMails so why does RT mess up it’s own data? I give up :slight_smile:

On Win32 with mysql 4.0.x (but not on Unix) we have been observing
that the SearchBuilder/mysql layer drops the utf8 flag after a while
of normal execution.

The work around here is to apply the following patch to
RT/Attachment_Overlay.pm and add this line to RT_SiteConfig.pm:

Set( $AlwaysUseBase64, 1 );

which turns on Base64 encoding for all MIME contents.

Thanks,
/Autrijus/

— //depot/RT/rt/lib/RT/Attachment_Overlay.pm 2003/07/01 18:18:04
+++ //depot/RT/rt/lib/RT/Attachment_Overlay.pm 2003/07/02 09:32:30
@@ -168,8 +168,8 @@
#if the current attachment contains nulls and the
#database doesn’t support embedded nulls

  •    if (    ( !$RT::Handle->BinarySafeBLOBs )
    
  •         && ( $Body =~ /\x00/ ) ) {
    
  •    if ( $RT::AlwaysUseBase64 or
    
  •    ( !$RT::Handle->BinarySafeBLOBs ) && ( $Body =~ /\x00/ ) ) {
    
           # set a flag telling us to mimencode the attachment
           $ContentEncoding = 'base64';

Ok, after much hassle we’ve finally managed to make RT (3.0.3)
accept tickets via eMails with international characters.
I can compose a message with any charactes like ��� and it
creates and displays the ticket nicely. Big hooray!

What did you have to do to make RT 3.0.3 accept mail with international
characters? Are you using mod_perl, speedy_cgi or fast_cgi?

Jesse


Gerald R�scher
Lt. Rechnerbetrieb Mathematik
ruescher@math.upb.de

Universit�t Paderborn
Fakult�t V - Mathematik/Informatik/Elektrotechnik
Warburger Str. 100
D-33098 Paderborn
Tel : 05251/60-2600
Fax : 05251/60-3729


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm

http://www.bestpractical.com/rt – Trouble Ticketing. Free.

Ok, after much hassle we’ve finally managed to make RT (3.0.3)
accept tickets via eMails with international characters.
I can compose a message with any charactes like öäü and it
creates and displays the ticket nicely. Big hooray!

What did you have to do to make RT 3.0.3 accept mail with
international characters? Are you using mod_perl, speedy_cgi
or fast_cgi?

Thanks for your response.

We’re using the fastcgi version.

To make RT accept int. characters we installed the latest version
of Locale:Maketext:Lexikon (0.26). Another problem was that there were
outdated files var/mason_data/obj which were only-re-created after
deleting the entire “obj” directory (this had nothing to do with RT
but happened because the system time on the web server was not set
correctly)

Anway creating tickets via eMail now works nicely.

The problem is creating or modifying tickets via the web interface.
Once more: if create a ticket using the web interface which
contains the text

xxxxöööxxxx
1234567890
<<<<

Then the new ticket is displayed as

xxxxöööxxxx
4567890
<<<<

So the three umlauts have been converted to something (is this UTF-8?)
and the first three characters in the next line are missing. Strange!
It happens independently from the browser (Opera, Mozilla, IE)

The sad thing is, that RT is such a nice system which perfectly fits
our needs (in fact other departements at our university are just
waiting for our installation to run smoothly before they switch to RT too)
If we only could get it to work with languages spoken in strange
countries like Germany :wink:

Jerry

Hello,

–Am Donnerstag, 3. Juli 2003 9:45 Uhr +0200 schrieb Gerald Rüscher
ruescher@math.uni-paderborn.de:

The sad thing is, that RT is such a nice system which perfectly fits
our needs (in fact other departements at our university are just
waiting for our installation to run smoothly before they switch to RT too)
If we only could get it to work with languages spoken in strange
countries like Germany :wink:

I can say that it definetly works with int. characters from email and web,
because we are productive with rt 3.0.3 here.

That means: there is something wrong with your configuration (do you use
perl 5.8 or 5.6?).

Since I have now some experiences with this issue, you can send me your
configs, and I will see, if I can help you.

Dirk.

Dirk Pape (mailto:pape-rt@inf.fu-berlin.de) schrieb:

The sad thing is, that RT is such a nice system which perfectly fits
our needs (in fact other departements at our university are just
waiting for our installation to run smoothly before they switch to
RT too) If we only could get it to work with languages spoken in
strange countries like Germany :wink:

Hehe, we have the same problems over here.

I can say that it definetly works with int. characters from email and
web, because we are productive with rt 3.0.3 here.

That means: there is something wrong with your configuration (do you
use perl 5.8 or 5.6?).

I am able to send mails to rt and they are stored nicely with all the
Umlaute. But when I reply or comment on a message they all get messed
up like Geralds messages.

We are running a debian 3.0 box with perl 5.6.1. Is it neccecary switching
to 5.8!?

Any help appreciated.

Greetings

Christian

Hehe, we have the same problems over here.

I can say that it definetly works with int. characters from email and
web, because we are productive with rt 3.0.3 here.

That means: there is something wrong with your configuration (do you
use perl 5.8 or 5.6?).

I am able to send mails to rt and they are stored nicely with all the
Umlaute. But when I reply or comment on a message they all get messed
up like Geralds messages.

We are running a debian 3.0 box with perl 5.6.1.
Is it neccecary switching to 5.8!?

Seems to be. The README strongly suggest version 5.8 to fix
problems with UTF encoding. Unfortunately perl 5.8 is not
available on RH 7.3 (which we use here) and I don’t want to
upgrade the entire OS in order to use RT :frowning:

Regards,
Jerry

Unfortunately perl 5.8 is not
available on RH 7.3 (which we use here) and I don’t want to
upgrade the entire OS in order to use RT :frowning:

Jerry,

I’m about to set up our new RT 3 server, and will try to do it under Redhat 7.3. My plan was to try the Perl 5.8 RPM from ActiveState. Does that sound good to you?

I have other work right now, so you might get to this before I do. If you try it, be sure to let the list know if it works!

prl

Quoting Phil R Lawrence prlawrence@Lehigh.EDU:> On Tue, 8 Jul 2003 13:24:26 +0200 Gerald R�scher ruescher@math-mail.uni-paderborn.de wrote:

Unfortunately perl 5.8 is not
available on RH 7.3 (which we use here) and I don’t want to
upgrade the entire OS in order to use RT :frowning:

Jerry,

I’m about to set up our new RT 3 server, and will try to do it under Redhat
7.3. My plan was to try the Perl 5.8 RPM from ActiveState. Does that sound
good to you?

I’m using RT 3.0.3 on a RedHat 7.3.
I compiled and installed Perl 5.8 from source (still have 5.6.1 “just in case”).
Everything works fine.

If you need some help…

Remy Chibois

I’m trying to use the Windows MySQL ODBC 3.51 driver
to connect to the mysql database behind my RT 2.0.15
(linux). From the windows box I hope to eventually
use Crystal Reports to query and generate reports.
Upon installing the ODBC driver on the Windows box and
testing, I get an error in Windows:

[MySQL][ODBC 3.51 Driver] Access denied for user:
rt_user@myrtbox’ (Using Password: YES)

In the ODBC driver configuration, I used the following
info:

db name: rt2
db user: rt_user
db pass:

Is there some special way mysql needs to be started,
or some command line flag somewhere preventing my
connection from working?
Currently, it appears that mysql only permits
connections from the IP of the host itself. For a
quick test, I built a local ssh redirect on the box
with the mysql to satisfy mysql (it thinks the
connection came from localhost) and pointed my odbc
driver to this new port. So, tcp 3306 is covered.
But udp 3306 is not. Perhaps this is my problem?

If anyone else is using Crystal Reports to query RT,
I’d be interested in how you did this, or what I’m
doing wrong.

Thanks!

Do you Yahoo!?
SBC Yahoo! DSL - Now only $29.95 per month!
http://sbc.yahoo.com

Right off the bat, so, sorry if I missed your meaning,
it sounds like you just need to ensure you got permissions correct:

mysql>grant all privileges on rt2.* to rt_user@myrtbox identified by
’your-password’;

mysql>flush privileges;On Mon, 2003-07-14 at 11:04, Joseph Spenner wrote:

I’m trying to use the Windows MySQL ODBC 3.51 driver
to connect to the mysql database behind my RT 2.0.15
(linux). From the windows box I hope to eventually
use Crystal Reports to query and generate reports.
Upon installing the ODBC driver on the Windows box and
testing, I get an error in Windows:

[MySQL][ODBC 3.51 Driver] Access denied for user:
rt_user@myrtbox’ (Using Password: YES)

In the ODBC driver configuration, I used the following
info:

db name: rt2
db user: rt_user
db pass:

Is there some special way mysql needs to be started,
or some command line flag somewhere preventing my
connection from working?
Currently, it appears that mysql only permits
connections from the IP of the host itself. For a
quick test, I built a local ssh redirect on the box
with the mysql to satisfy mysql (it thinks the
connection came from localhost) and pointed my odbc
driver to this new port. So, tcp 3306 is covered.
But udp 3306 is not. Perhaps this is my problem?

If anyone else is using Crystal Reports to query RT,
I’d be interested in how you did this, or what I’m
doing wrong.

Thanks!


Do you Yahoo!?
SBC Yahoo! DSL - Now only $29.95 per month!
http://sbc.yahoo.com


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at http://fsck.com/rtfm
Rob Joost
Unix Administrator

KnowledgeNet
14624 N. Scottsdale Road, #300
Scottsdale, AZ 85254
Phone: (480) 315-4841
Cell: (602) 920-6113
Email: rob.joost@knowledgenet.com
Web: http://www.knowledgenet.com/

Why KnowledgeNet? Listen and learn from top customers – Cisco, US
Postal Service, and EMC, to name a few!
http://www.knowledgenet.com/onlineevents/

In RT 2.0.15, is there a way to perform a ticket
search such that I can quickly get the number of
tickets that matched the search? (rather than pages
and pages of tickets, not knowing how many results
there were )?

ie: Search for all tickets requested by
justin.case@nowhere.com, and get a number back?

Do you Yahoo!?
SBC Yahoo! DSL - Now only $29.95 per month!
http://sbc.yahoo.com

Robert:
Thanks for the tip! I got it to work with the
following:

mysql -uroot -p

mysql> grant all privileges on rt2.* to rt_user@’%'
identified by ‘rt_mypass’ with grant option;
Query OK, 0 rows affected (0.00 sec)

mysql> grant all privileges on rt2.* to
rt_user@‘localhost’ identified by ‘rt_mypass’ with
grant option;
Query OK, 0 rows affected (0.00 sec)

mysql> flush privileges;
Query OK, 0 rows affected (0.00 sec)

mysql>— Robert Joost rob.joost@knowledgenet.com wrote:

Right off the bat, so, sorry if I missed your
meaning,
it sounds like you just need to ensure you got
permissions correct:

mysql>grant all privileges on rt2.* to
rt_user@myrtbox identified by
’your-password’;

mysql>flush privileges;

On Mon, 2003-07-14 at 11:04, Joseph Spenner wrote:

I’m trying to use the Windows MySQL ODBC 3.51
driver
to connect to the mysql database behind my RT
2.0.15
(linux). From the windows box I hope to
eventually
use Crystal Reports to query and generate reports.
Upon installing the ODBC driver on the Windows box
and
testing, I get an error in Windows:

[MySQL][ODBC 3.51 Driver] Access denied for user:
rt_user@myrtbox’ (Using Password: YES)

In the ODBC driver configuration, I used the
following
info:

db name: rt2
db user: rt_user
db pass:

Is there some special way mysql needs to be
started,
or some command line flag somewhere preventing my
connection from working?
Currently, it appears that mysql only permits
connections from the IP of the host itself. For a
quick test, I built a local ssh redirect on the
box
with the mysql to satisfy mysql (it thinks the
connection came from localhost) and pointed my
odbc
driver to this new port. So, tcp 3306 is covered.

But udp 3306 is not. Perhaps this is my problem?

If anyone else is using Crystal Reports to query
RT,
I’d be interested in how you did this, or what I’m
doing wrong.

Thanks!


Do you Yahoo!?
SBC Yahoo! DSL - Now only $29.95 per month!
http://sbc.yahoo.com


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Have you read the FAQ? The RT FAQ Manager lives at
http://fsck.com/rtfm

Rob Joost
Unix Administrator

KnowledgeNet
14624 N. Scottsdale Road, #300
Scottsdale, AZ 85254
Phone: (480) 315-4841
Cell: (602) 920-6113
Email: rob.joost@knowledgenet.com
Web: http://www.knowledgenet.com/

Why KnowledgeNet? Listen and learn from top
customers – Cisco, US
Postal Service, and EMC, to name a few!
http://www.knowledgenet.com/onlineevents/

Do you Yahoo!?
SBC Yahoo! DSL - Now only $29.95 per month!
http://sbc.yahoo.com