Mod_ssl and RT2? Possibly off-topic

Is anyone else using this setup and/or had problems with it?

We have been using RT2 with Mod_ssl/Apache for about a week now and we
constantly get unable to find page error messages while using RT. If you
hit back and then submit or refresh the page it usually resolves the error
but is very annoying. As a test we switched RT2 back to a non-ssl
setup on the same server and now we no longer receive any error messages.

Log files show SSL connections being ‘lost’ or ‘not connected’.

System is Solaris 8 on Sparc platform Sun Netra T1.
Apache is 1.3.19 with mod_ssl, mod_perl (static module built into apache),
mod_php4. Everything built from scratch on that server.

System has plenty of RAM and disk and is not loaded at all.

We do not have problems with any other pages on mod_ssl just with RT2 on
mod_ssl.

I was just about to post this. I’m not using mod_ssl. This is on SuSE
7.1 with postgres backend. Not very well built yet, first try, lots of
problems installing. So I thought this might go away when I reinstall.

I’m getting various errors while in the web interface as a user:

As any user logging out I get a “document contained no data” error
from Netscape.

and in httpd/error_log:
[Tue Jul 31 06:32:47 2001] [notice] child pid 4957 exit signal
Segmentation fault (11)

Usually after about 3 tries it lets me log out, but I often have to
repoint my browser back to the Index.html to get back to the login
screen.

Another error I get is when moving a ticket to another queue. RT says
transacion failed, permission denied, but the ticket is non-the-less in
the new queue. user has permission to create ticket in new queue.

Ashley Gould
Technical Support
ASL, Inc.
techsupport@aslab.com
Support (510)857-0057
Fax (510)857-0010On Tue, Jul 31, 2001 at 01:14:09PM -0500, Sanity wrote:

Is anyone else using this setup and/or had problems with it?

We have been using RT2 with Mod_ssl/Apache for about a week now and we
constantly get unable to find page error messages while using RT. If you
hit back and then submit or refresh the page it usually resolves the error
but is very annoying. As a test we switched RT2 back to a non-ssl
setup on the same server and now we no longer receive any error messages.

Log files show SSL connections being ‘lost’ or ‘not connected’.

System is Solaris 8 on Sparc platform Sun Netra T1.
Apache is 1.3.19 with mod_ssl, mod_perl (static module built into apache),
mod_php4. Everything built from scratch on that server.

System has plenty of RAM and disk and is not loaded at all.

We do not have problems with any other pages on mod_ssl just with RT2 on
mod_ssl.


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Sanity wrote:

Is anyone else using this setup and/or had problems with it?

We have been using RT2 with Mod_ssl/Apache for about a week now and we
constantly get unable to find page error messages while using RT. If you
hit back and then submit or refresh the page it usually resolves the error
but is very annoying. As a test we switched RT2 back to a non-ssl
setup on the same server and now we no longer receive any error messages.

No problems at all for us - Solaris 8/Sparc, Apache 1.3.20, and
mod_ssl-2.8.4-1.3.20 - We’ve also got mod_perl-1.25 (and perl 5.6.1)
installed into apache.

RT does get VERY slow, and seems to bring down apache to a crawl when
viewing queues with lots of (more than 100) tickets. Anyone else had
THAT problem ?

T�o de Hesselle,
Unix Systems Administrator

University of Technology, Sydney

RT does get VERY slow, and seems to bring down apache to a crawl when
viewing queues with lots of (more than 100) tickets. Anyone else had
THAT problem ?

Limiting the number of results per page should deal with that for you.
There are some performance tweaks to DBIx::SearchBuilder that could be made,
so RT could easily cache data from ancillary columns, like watchers and areas
that would speed all this up a lot. If anyone is interested sponsoring that work, they should ping me off-list.

    -j


Téo de Hesselle,
Unix Systems Administrator

University of Technology, Sydney


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

jesse reed vincent – root@eruditorum.orgjesse@fsck.com
70EBAC90: 2A07 FC22 7DB4 42C1 9D71 0108 41A3 3FB3 70EB AC90

This is scary. I’m imagining tracerouting you and seeing links like “Route
84” and “Route 9, Exit 14”. Obviously, this is illness induced.
–Cana McCoy

Jesse wrote:

RT does get VERY slow, and seems to bring down apache to a crawl when
viewing queues with lots of (more than 100) tickets. Anyone else had
THAT problem ?

Limiting the number of results per page should deal with that for you.

Errr Okay. But the default is ‘unlimited’, which will try to display 500
tickets, but will instead bring the whole apache server down to a crawl. I
suppose I should wander the twisty maze of code that is RT until I find
where it sets this…

T�o de Hesselle, | Kites rise higest against
Unix Systems Administrator | the wind – not with it.
|
University of Technology, Sydney | – Winston Churchill

Jesse wrote:

RT does get VERY slow, and seems to bring down apache to a crawl when
viewing queues with lots of (more than 100) tickets. Anyone else had
THAT problem ?

Limiting the number of results per page should deal with that for you.

Errr Okay. But the default is ‘unlimited’, which will try to display 500
tickets, but will instead bring the whole apache server down to a crawl. I
suppose I should wander the twisty maze of code that is RT until I find
where it sets this…

The default probably bears changing. It worked fine throughout testing, but now
that folks are throwing bigger ticket loads at rt…

You want to look at Listing/PickRestriction and /Elements/SelectResultsPerPage


Téo de Hesselle, | Kites rise higest against
Unix Systems Administrator | the wind – not with it.
|
University of Technology, Sydney | – Winston Churchill


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

jesse reed vincent – root@eruditorum.orgjesse@fsck.com
70EBAC90: 2A07 FC22 7DB4 42C1 9D71 0108 41A3 3FB3 70EB AC90

Computer games don’t affect kids; I mean if Pac-Man affected us as
kids, we’d all be running around in darkened rooms, munching magic
pills and listening to repetitive electronic music.
%
IP networks were intended to survive nuclear attack, but 12 year old
kids with PCs were not part of the threat model. – mycroft

Ok. the default as of 2.0.5 will be 50 results per page. Sometime around 2.2,
users will be able to configure things like this personally, but this should
give folks a nice apparent speed boost. :wink:

    -jOn Thu, Aug 02, 2001 at 11:28:23AM +1000, Teo de Hesselle wrote:

Jesse wrote:

On Wed, Aug 01, 2001 at 03:20:05PM +1000, Teo de Hesselle wrote:

RT does get VERY slow, and seems to bring down apache to a crawl when
viewing queues with lots of (more than 100) tickets. Anyone else had
THAT problem ?

Limiting the number of results per page should deal with that for you.

Errr Okay. But the default is ‘unlimited’, which will try to display 500
tickets, but will instead bring the whole apache server down to a crawl. I
suppose I should wander the twisty maze of code that is RT until I find
where it sets this…


Téo de Hesselle, | Kites rise higest against
Unix Systems Administrator | the wind – not with it.
|
University of Technology, Sydney | – Winston Churchill


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

jesse reed vincent – root@eruditorum.orgjesse@fsck.com
70EBAC90: 2A07 FC22 7DB4 42C1 9D71 0108 41A3 3FB3 70EB AC90

…realized that the entire structure of the net could be changed to be made
more efficient, elegant, and spontaneously make more money for everyone
involved. It’s a marvelously simple diagram, but this form doesn’t have a way
for me to draw it. It’ll wait. -Adam Hirsch

I continue to struggle with a mod_ssl-enabled RT2 (2.0.9) occasionally
having connection troubles with internet explorer browsers (netscape here
works fine). I’ve finally set my mod_ssl error level to debug, but I
wonder if anyone has made progress on this problem?

It wasn’t so bad in earlier versions of RT2, but now that everything
appears to be no-cache, forms that fail submission because of connection
issues now have to be re-filled for another attempt. On a secondary note,
would it be possible to pick and choose what content has the no-cache
header(s) and what do not?

Thanks,
Christian

Christian Gilmore
Team Lead
Web Infrastructure & Tools
IBM Software Group

I continue to struggle with a mod_ssl-enabled RT2 (2.0.9) occasionally
having connection troubles with internet explorer browsers (netscape here
works fine). I’ve finally set my mod_ssl error level to debug, but I
wonder if anyone has made progress on this problem?

Do you have your apache configured to force IE to http/1.0, per the default
apache config files? IE’s HTTP/1.1 implementation gets really wacky
with regard to things like keep-alives. In other situations (unrelated to RT)
I’ve had no end to trouble dealing with servinng secure content to users
running IE :confused:

It wasn’t so bad in earlier versions of RT2, but now that everything
appears to be no-cache, forms that fail submission because of connection
issues now have to be re-filled for another attempt. On a secondary note,
would it be possible to pick and choose what content has the no-cache
header(s) and what do not?

That would actually be rather difficult to pull off. What content do you
want to cache?

Thanks,
Christian


Christian Gilmore
Team Lead
Web Infrastructure & Tools
IBM Software Group

-----Original Message-----
From: rt-users-admin@lists.fsck.com
[mailto:rt-users-admin@lists.fsck.com]On Behalf Of Sanity
Sent: Tuesday, July 31, 2001 1:14 PM
To: rt-users@lists.fsck.com
Subject: [rt-users] Mod_ssl and RT2? Possibly off-topic…

Is anyone else using this setup and/or had problems with it?

We have been using RT2 with Mod_ssl/Apache for about a week now and we
constantly get unable to find page error messages while using
RT. If you
hit back and then submit or refresh the page it usually
resolves the error
but is very annoying. As a test we switched RT2 back to a non-ssl
setup on the same server and now we no longer receive any
error messages.

Log files show SSL connections being ‘lost’ or ‘not connected’.

System is Solaris 8 on Sparc platform Sun Netra T1.
Apache is 1.3.19 with mod_ssl, mod_perl (static module built
into apache),
mod_php4. Everything built from scratch on that server.

System has plenty of RAM and disk and is not loaded at all.

We do not have problems with any other pages on mod_ssl just
with RT2 on
mod_ssl.


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

http://www.bestpractical.com/products/rt – Trouble Ticketing. Free.

Had the same problem here. Upgrading to Explorer 6 seemed to fix all the
strange problems.

JeremyFrom: rt-users-admin@lists.fsck.com
[mailto:rt-users-admin@lists.fsck.com]On Behalf Of Jesse Vincent
Sent: Thursday, December 06, 2001 1:24 PM
To: Christian Gilmore
Cc: rt-users@lists.fsck.com; 'Sanity’
Subject: Re: [rt-users] Mod_ssl and RT2? Possibly off-topic…

I continue to struggle with a mod_ssl-enabled RT2 (2.0.9) occasionally
having connection troubles with internet explorer browsers (netscape here
works fine). I’ve finally set my mod_ssl error level to debug, but I
wonder if anyone has made progress on this problem?

Do you have your apache configured to force IE to http/1.0, per the default
apache config files? IE’s HTTP/1.1 implementation gets really wacky
with regard to things like keep-alives. In other situations (unrelated to
RT)
I’ve had no end to trouble dealing with servinng secure content to users
running IE :confused:

It wasn’t so bad in earlier versions of RT2, but now that everything
appears to be no-cache, forms that fail submission because of connection
issues now have to be re-filled for another attempt. On a secondary note,
would it be possible to pick and choose what content has the no-cache
header(s) and what do not?

That would actually be rather difficult to pull off. What content do you
want to cache?

Thanks,
Christian


Christian Gilmore
Team Lead
Web Infrastructure & Tools
IBM Software Group

-----Original Message-----
From: rt-users-admin@lists.fsck.com
[mailto:rt-users-admin@lists.fsck.com]On Behalf Of Sanity
Sent: Tuesday, July 31, 2001 1:14 PM
To: rt-users@lists.fsck.com
Subject: [rt-users] Mod_ssl and RT2? Possibly off-topic…

Is anyone else using this setup and/or had problems with it?

We have been using RT2 with Mod_ssl/Apache for about a week now and we
constantly get unable to find page error messages while using
RT. If you
hit back and then submit or refresh the page it usually
resolves the error
but is very annoying. As a test we switched RT2 back to a non-ssl
setup on the same server and now we no longer receive any
error messages.

Log files show SSL connections being ‘lost’ or ‘not connected’.

System is Solaris 8 on Sparc platform Sun Netra T1.
Apache is 1.3.19 with mod_ssl, mod_perl (static module built
into apache),
mod_php4. Everything built from scratch on that server.

System has plenty of RAM and disk and is not loaded at all.

We do not have problems with any other pages on mod_ssl just
with RT2 on
mod_ssl.


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

http://www.bestpractical.com/products/rt – Trouble Ticketing. Free.

rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

“JV” == Jesse Vincent jesse@bestpractical.com writes:

JV> Do you have your apache configured to force IE to http/1.0, per the default
JV> apache config files? IE’s HTTP/1.1 implementation gets really wacky
JV> with regard to things like keep-alives. In other situations (unrelated to RT)
JV> I’ve had no end to trouble dealing with servinng secure content to users
JV> running IE :confused:

Force IE to use SSLv2, or upgrade your IE to 5.5 or newer. We had
issues with one customer and that solved it.

Vivek Khera, Ph.D. Khera Communications, Inc.
Internet: khera@kciLink.com Rockville, MD +1-240-453-8497
AIM: vivekkhera Y!: vivek_khera http://www.khera.org/~vivek/