Mime version lacking in sent emails headers


I am a part-time system administrator in our small company, I am installing
RT v2.0.15 on RedHat 7.2. I don’t really know Perl, I wrote a couple of
small programs with Perl, in old Basic/Fortran style, just to try it. I am
almost the only Unix man in the company, everybody else works on MS-Windows
:frowning: So I have to fit to their wishes, with buttons, GUIs everywhere … Not
to speak against RT ! I only mean that they really are windowish :frowning:

So our support staff is going to discover RT; currently they use to send
emails using different flavours of MS-Outlook*. They are used to send
attachments by email to our customers. So I tried to send an attachment from
the RT GUI, it did not work, I discovered the bundle NotifyWithAttachment,
installed it, and tried again to send an attachment to myself, receiving it
with MS-Outlook :frowning: I got the full Mime encoded text, not the attachment
icon. So I browsed the full header, and discovered that all other emails
contain the Mime version in the header, while RT email don’t. Thus I added
the following line

$self->SetHeader(‘MIME-Version’, “1.0”);



It worked, I received every attachment that I sent !

I verified and found the RFC 2045 which states :

" Messages composed in accordance with this document MUST include such
a header field, with the following verbatim text:

 MIME-Version: 1.0"

Did I do a correct modification in SendEmail.pm ?

Best regards

.-. Robert GRASSO - CEDRAT S.A.
/v\ 10, Chemin de Pre Carre - ZIRST - 38246 MEYLAN Cedex - FRANCE
// \ Tel: +33 (0)4 76 90 50 45 Fax: +33 (0)4 76 90 16 09
/( )\ mailto:Robert.Grasso@cedrat.com
UNIX was not designed to stop you from doing stupid things, because
that would also stop you from doing clever things. – Doug Gwyn
Support service : mailto:support@cedrat.com
Commercial service : mailto:cedrat@cedrat.com
Web site : http://www.cedrat.com