MIME-tools compatibility

Hi all,

Just noticed the blocking compatibility issue:

CPAN installs by default MIME-tools version 6.106
(E/ER/ERYQ/MIME-tools-6ALPHA-6.106.tar.gz), and mail-gateway
reports the error:

Can’t locate object method “output_prefix” via package &q
uot;MIME::Parser" at /opt/rt3/lib/RT/EmailParser.pm line 746.

With MIME-tools-5.411 installed by hand, everything’s fine.

It would be nice if rt-test-dependencies would detect this issue.

Tested also MIME-tools-6.200_01, with same (bad) result.

Stan

For your information, here’s the reply from the module author.
Stan— Eryq eryq@zeegee.com wrote:

Date: Tue, 10 Jun 2003 10:44:35 -0400
From: Eryq eryq@zeegee.com
To: Stanislav Sinyagin ssinyagin@yahoo.com
Subject: Re: MIME-tools compatibility

Stanislav Sinyagin wrote:

Hi all,

Just noticed the blocking compatibility issue:

CPAN installs by default MIME-tools version 6.106
(E/ER/ERYQ/MIME-tools-6ALPHA-6.106.tar.gz), and mail-gateway
reports the error:

Can’t locate object method “output_prefix” via package &q
uot;MIME::Parser" at /opt/rt3/lib/RT/EmailParser.pm line 746.

With MIME-tools-5.411 installed by hand, everything’s fine.

It would be nice if rt-test-dependencies would detect this issue.

Tested also MIME-tools-6.200_01, with same (bad) result.

Yes, there has been an API change from 5.x to 6.x, and
I didn’t use the correct _ CPAN number, so 5.411 will be
the default for CPAN installs again in the next 48 hours
when PAUSEd deletes 6ALPHA-6.106.

Actually, I think the API change happened in the
4.x to 5.x jump, and output_prefix was deprecated
a long while ago, but I’m not sure offhand.


Eryq, http://www.zeegee.com/eryq

Hello,

–Am Dienstag, 10. Juni 2003 5:56 Uhr -0700 schrieb Stanislav Sinyagin
ssinyagin@yahoo.com:

Just noticed the blocking compatibility issue:

CPAN installs by default MIME-tools version 6.106
(E/ER/ERYQ/MIME-tools-6ALPHA-6.106.tar.gz), and mail-gateway
reports the error:

Can’t locate object method “output_prefix” via package &q
uot;MIME::Parser" at /opt/rt3/lib/RT/EmailParser.pm line 746.

With MIME-tools-5.411 installed by hand, everything’s fine.

It would be nice if rt-test-dependencies would detect this issue.

yes I see this also (just stumbled over this)

Dirk.

Eryq and I have corresponded. the 6ALPHA code has been scheduled for
deletion from CPAN in favor of 6.200_01, which will make the CPAN
indexer only suggest 5.411 for production deployment. (Any module with a
version # containing an underscore character is treated as ‘for
developers only’). Things should be back to normal very soon.

As MIME::Tools 6 stabilizes, we’ll look at porting to it.

-jOn Tue, Jun 10, 2003 at 05:56:14AM -0700, Stanislav Sinyagin wrote:

Hi all,

Just noticed the blocking compatibility issue:

CPAN installs by default MIME-tools version 6.106
(E/ER/ERYQ/MIME-tools-6ALPHA-6.106.tar.gz), and mail-gateway
reports the error:

Can’t locate object method “output_prefix” via package &q
uot;MIME::Parser" at /opt/rt3/lib/RT/EmailParser.pm line 746.

With MIME-tools-5.411 installed by hand, everything’s fine.

It would be nice if rt-test-dependencies would detect this issue.

Tested also MIME-tools-6.200_01, with same (bad) result.

Stan


rt-devel mailing list
rt-devel@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-devel

http://www.bestpractical.com/rt – Trouble Ticketing. Free.