Mason can't write to session_data directory?

I upgraded to 3.0.3pre2 and most of it went smoothly (well, as much as one
can smoothlly upgrade from an installation in /opt into a built RPM… CPAN
was the real killer) so now I’m running rt 3.0.3pre2 with postgresql 7.3.2
(same as before) and apache 2.0.40 (same as before) and now using
mod_fastcgi instead of mod_perl (due to a world of pain I don’t ever want to
be in again).

Now, SESSIONSTATEDIR and MASONSTATEDIR both live in /var/cache/rt, which is
owned by apache and group ‘rt’, and mode 777 (it began life as 770 but
changed when I got the error below), and yet now the web interface gives me
this error:

RT Couldn’t write to session directory ‘/var/cache/rt/session_data’:
DBD::Pg::st execute failed: execute on disconnected handle at
/usr/lib/perl5/site_perl/5.8.0/Apache/Session/Store/Postgres.pm line 76


Check that this dir ectory’s permissions are correct, at
/usr/share/rt/html/Elements/SetupSessionCookie line 60.

code stack:

/usr/share/rt/html/Elements/SetupSessionCookie:60
/usr/share/rt/html/autohandler:51

So, it looked like it just didn’t have permission to write state to
/var/cache/rt/session_data, so I rechecked that the directory was owned by
apache, and I’ve tried both combinations of making it group ‘rt’ and
’apache’. It’s now mode 777 so anyone can write to the directory, but still
that error’s there. Restarting the webserver after each change doesn’t
affect this either.

The mailgate still works though, I have no problems replying to tickets via
email.

jaq@spacepants.org http://spacepants.org/jaq.gpg

This one time, at band camp, Jamie Wilkinson wrote:

The mailgate still works though, I have no problems replying to tickets via
email.

No, as of a few moments ago it’s now bouncing mails with the following
message:

RT could not load a valid user, and RT’s configuration does not allow for
the creation of a new user for your email.

The rt.log shows:

Auth::MailFrom couldn’t find the ‘Unprivileged’ internal group
(…/Email/Auth/MailFrom.pm:57)

and after that the same message as in the email.

jaq@spacepants.org http://spacepants.org/jaq.gpg

That looks like whatever you’ve done, your RT server can’t connect to the
database.On Fri, Jun 06, 2003 at 09:15:45AM +1000, Jamie Wilkinson wrote:

This one time, at band camp, Jamie Wilkinson wrote:

The mailgate still works though, I have no problems replying to tickets via
email.

No, as of a few moments ago it’s now bouncing mails with the following
message:

RT could not load a valid user, and RT’s configuration does not allow for
the creation of a new user for your email.

The rt.log shows:

Auth::MailFrom couldn’t find the ‘Unprivileged’ internal group
(…/Email/Auth/MailFrom.pm:57)

and after that the same message as in the email.


jaq@spacepants.org http://spacepants.org/jaq.gpg


rt-devel mailing list
rt-devel@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-devel

http://www.bestpractical.com/rt – Trouble Ticketing. Free.

This one time, at band camp, Jesse Vincent wrote:

That looks like whatever you’ve done, your RT server can’t connect to the
database.

Only it is connecting to the database. If I restart apache, rt-mailgate
works again, until I try to use the web interface. The web interface will
show the front page with the two ticket lists and the quicksearch box, but
as soon as I click on any link, I am given the error and it all stops
working.

Interestingly, NoAuth/webrt.css is inaccessible when the front page loads,
the page is drawn in default fonts and colours (except for those explicit in
the HTML).

Postgres is still running the whole time, and there have been no changes to
RT_SiteConfig.pm regarding database options.

jaq@spacepants.org http://spacepants.org/jaq.gpg