MariaDB 10.1, but rt-setup-fulltext-index says my version of mysql is less than 5.6?


I am trying to run the /opt/rt4/sbin/rt-setup-fulltext-index program, but even though I have MariaDB 10.1.38, it still gives me the following message:

“Complete support for full-text search requires MySQL 5.6 or higher. For prior versions such as yours, full-text indexing can either be provided by using MyISAM table, or the external Sphinx indexer. Using MyISAM tables requires that your database be tuned to support them, as RT uses InnoDB tables for all other content. Using Sphinx will require recompiling MySQL. Which indexing solution would you prefer? [mysql]:”

Yet, the RT documentation for full text indexing says my version of MariaDB should work?

" MYSQL and MariaDB

On MySQL, full-text search can either be done using native support (which may use MyISAM tables on pre-5.6 versions of MySQL), or RT can integrate with the external Sphinx full-text search engine.

RT supports native full-text search on MariaDB versions 10.0 and greater. It does not support Sphinx integration on MariaDB.

Native MySQL and MariaDB

As RT marks attachment data as BINARY , MySQL and MariaDB cannot index this content without creating an additional table. To create the required table (which is InnoDB on versions of MySQL and MariaDB which support it), run:


If you have a non-standard database administrator username or password, you may need to pass the --dba or --dba-password options:

    /opt/rt4/sbin/rt-setup-fulltext-index --dba root --dba-password secret

This will then tokenize and index all existing attachments in your database; it may take quite a while if your database already has a large number of tickets in it.

Finally, it will output an appropriate %FullTextSearch configuration to add to your ; you will need to restart your webserver after making these changes."

What is happening here? How can I go forward with turning on full text indexing in my RT? I tried running the /opt/rt4/sbin/rt-fulltext-indexer and it said full text search was disabled in my RT configuration and directed me to run the rt-setup-fulltext-index program.