MandatoryOnTransition & CustomFieldsOnUpdate Conflict


#1

Good Day,

We have been using MandatoryOnTransition for some time now to require
certain custom fields be populated when a ticket is resolved. One of the
effects is that it adds those custom fields to the Resolve action screen.

One of our teams recently asked us to add CustomFieldsOnUpdate which, of
course, adds all custom fields to the update screen (note: for the queue in
question the Resolve action has been set to update, not comment).

The result, now, is that all custom fields are shown twice when they go
to resolve a ticket in their queue. This causes issues with the update as
two different fields have the same name. I can’t seem to find any options
that will correct this behavior. The easiest way would be to
block MandatoryOnTransition from displaying the fields, but I don’t see an
option to do that.

Any insight is appreciated.

-Matt


#2

Anybody able to provide any insight here? Or a work around that
accomplishes the same thing? Still experiencing this issue.

Thanks,
MattOn Thu, Feb 18, 2016 at 1:52 PM, Matt Brennan brennanma@gmail.com wrote:

Good Day,

We have been using MandatoryOnTransition for some time now to require
certain custom fields be populated when a ticket is resolved. One of the
effects is that it adds those custom fields to the Resolve action screen.

One of our teams recently asked us to add CustomFieldsOnUpdate which, of
course, adds all custom fields to the update screen (note: for the queue in
question the Resolve action has been set to update, not comment).

The result, now, is that all custom fields are shown twice when they go
to resolve a ticket in their queue. This causes issues with the update as
two different fields have the same name. I can’t seem to find any options
that will correct this behavior. The easiest way would be to
block MandatoryOnTransition from displaying the fields, but I don’t see an
option to do that.

Any insight is appreciated.

-Matt


#3

You could try with:
Set($ShowAllCustomFieldsOnMandatoryUpdate, 0);