Make install results to Pemission error

SMIME dependencies:
    Crypt::X509 ............................................ ok
    File::Which ............................................ ok
    String::ShellQuote ..................................... ok


All dependencies found.

/bin/install -c -m 0755 -o root -g apache -d /opt/rt5/etc
/bin/install: cannot create directory ‘/opt/rt5’: Permission denied
make: *** [Makefile:371: config-install] Error 1

how to fix this issue with Permission denied?

If your user doesn’t have permission to write to /opt/rt5 then you can use sudo make install if you have sudo rights

Are you installing it as you or as root¿ Hint: you probably need to be root.
Su or Sudo are your friends.

totally understood and I run commands in privilege mode using sudo make testdeps most of the dependencies are MISSING.

When I check thoroughly, most dependencies are newer version than what is required, which should be fine and not missing.

Thanks for your inputs and will check more on this issue.

You might have loaded the dependencies so that they have been installed local to your user, so not visible in the path of the sudo’ed root user. I’ve been tripped up with that using CPAN recently (on CentOS 7 IIRC).

@GreenJimll that is what exactly happened. RT is now all set. Thank you all.

I am dealing with a “Possible cross-site request forgery” message when I create a new user. Any lead on this?

Really appreciate your help guys and see your around the community.

Check the settings in your local file for @ReferrerWhitelist. You need to make sure this list matches the hostnames and ports that your requests will be coming from.

So for example if you have a machine called that also has a CNAME record in the DNS for and both of them are using HTTPS on port 443, you’d want something like:

Set (@ReferrerWhitelist, qw(;

If your’re using a SAML IdP for single sign on access to RT, you might need to have that in this list as well (as it will be involved with forwarding on requests after authentication). Also check your $WebDomain and $WebPort config values match up with one of the entries in the white list. In the past folk on the forum have had this pop up when RT thinks it is using HTTP whilst the web server is trying to use HTTPS (or vice versa).

I have use the following two configs to avoid that warning:

Set($WebDomain, ‘’);

Set($WebPort, ‘443’);

Here’s the error:

[Tue Aug 4 16:42:06 2020] [notice]: Possible CSRF: the Referrer header supplied by your browser ( is not allowed by RT’s configured hostname ( (/opt/rt5/sbin/…/lib/RT/Interface/

What do you have set in for WebDomain and WebPort? I would guess localhost and port 80 are the default and are what you need to change

I’ve added the below in

Set($WebDomain, ‘portal101.local’);
Set($WebPort, ‘80’);

I can browse along RT system. the error

Possible cross-site request forgery

appears when I try to create a new user and change the root default password.

Does the domain in your URL match the WebDomain config? Are you accessing RT over http not https? It seems like from the error message earlier you are going to an IP: 192.168.xx.xx so you should put that IP as the domain that you are accessing the web service from

@knation. Sorry for replying late and thanks, RT worked.