Make install problem

I’m having a problem installing RT. I really hope someone can help me out cause I’m supposed to have this setup by tomorrow morning…

Anyway, I read the INSTALL doc and followed the directions. I login as root and run make install and everything goes great till it tries to run the ‘insertdata’ script then it stops.

/usr/bin/perl rt2/etc/insertdata
Can’t open perl script “rt2/etc/insertdata”: No such file or directory
*** Error code 2

I’ve checked the /rt2/etc directory and the insertdata script is there. Anybody got a clue about what I’m doing wrong??

Thanks for your help -
Bruce

Edit the script and point it to a version of perl that actually exists
on your machine.

bl–On Wednesday, February 27, 2002 8:17 PM -0600 Bruce Pea pea@andrewpea.com wrote:

I’m having a problem installing RT. I really hope someone can help me out
cause I’m supposed to have this setup by tomorrow morning…

Anyway, I read the INSTALL doc and followed the directions. I login as
root and run make install and everything goes great till it tries to run
the ‘insertdata’ script then it stops.

/usr/bin/perl rt2/etc/insertdata
Can’t open perl script “rt2/etc/insertdata”: No such file or directory
*** Error code 2

I’ve checked the /rt2/etc directory and the insertdata script is there.
Anybody got a clue about what I’m doing wrong??

Thanks for your help -
Bruce


rt-users mailing list
rt-users@lists.fsck.com
http://lists.fsck.com/mailman/listinfo/rt-users

Hi RT Users,

I wiped the machine and reinstalled Fedora for a clean install of RT3
I have put and untared RT into /opt/rt3 and have fixed all dependancies for both mod_perl and
fastcgi.

but now when i try

make install im getting

[root@bete rt3]# make install
mkdir -p //opt/rt3/etc
cp etc/RT_Config.pm //opt/rt3/etc/RT_Config.pm
cp: etc/RT_Config.pm' and//opt/rt3/etc/RT_Config.pm’ are the same file
make: *** [config-install] Error 1

whats this about??

I know by default rt puts stuff into /opt/rt3
but where should i have put the rt directory so make install wont create
problems with files already existing in /opt/rt3

any suggestions

Regards

Tomas Doyle

Tomas Doyle XA (DL/LMI) wrote:

Hi RT Users,

I wiped the machine and reinstalled Fedora for a clean install of RT3
I have put and untared RT into /opt/rt3 and have fixed all dependancies for both mod_perl and
fastcgi.

You need to untar somewhere other that /opt/rt3 so that the install can
put the final install into /opt/rt3.

but now when i try

make install im getting

[root@bete rt3]# make install
mkdir -p //opt/rt3/etc
cp etc/RT_Config.pm //opt/rt3/etc/RT_Config.pm
cp: etc/RT_Config.pm' and//opt/rt3/etc/RT_Config.pm’ are the same file
make: *** [config-install] Error 1

whats this about??

I know by default rt puts stuff into /opt/rt3
but where should i have put the rt directory so make install wont create
problems with files already existing in /opt/rt3

any suggestions

Regards

Tomas Doyle


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Drew Barnes
Applications Analyst
Raymond Walters College
University of Cincinnati

Where would you suggest? /root or something like that
because of what ive already done will there be any problems untaring a fresh rt all the dependancies should still be there?

ThanksFrom: Drew Barnes [mailto:barnesaw@ucrwcu.rwc.uc.edu]
Sent: 10 August 2005 15:09
To: Tomas Doyle XA (DL/LMI)
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] make install problem

Tomas Doyle XA (DL/LMI) wrote:

Hi RT Users,

I wiped the machine and reinstalled Fedora for a clean install of RT3
I have put and untared RT into /opt/rt3 and have fixed all dependancies for both mod_perl and
fastcgi.

You need to untar somewhere other that /opt/rt3 so that the install can
put the final install into /opt/rt3.

but now when i try

make install im getting

[root@bete rt3]# make install
mkdir -p //opt/rt3/etc
cp etc/RT_Config.pm //opt/rt3/etc/RT_Config.pm
cp: etc/RT_Config.pm' and//opt/rt3/etc/RT_Config.pm’ are the same file
make: *** [config-install] Error 1

whats this about??

I know by default rt puts stuff into /opt/rt3
but where should i have put the rt directory so make install wont create
problems with files already existing in /opt/rt3

any suggestions

Regards

Tomas Doyle


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Drew Barnes
Applications Analyst
Raymond Walters College
University of Cincinnati

Tomas Doyle XA (DL/LMI) wrote:

Where would you suggest? /root or something like that
because of what ive already done will there be any problems untaring a fresh rt all the dependancies should still be there?

I usually make an uploads folder under whichever user I happen to be
using - usually something original, like drew. I untar there, then su
so I can configure and install as root. As far as I can tell, you can
just wipe the /opt/rt3 folder and untar it in /root and you should be
fine. Just redo your configure, then make install.

Thanks

-----Original Message-----
From: Drew Barnes [mailto:barnesaw@ucrwcu.rwc.uc.edu]
Sent: 10 August 2005 15:09
To: Tomas Doyle XA (DL/LMI)
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] make install problem

Tomas Doyle XA (DL/LMI) wrote:

Hi RT Users,

I wiped the machine and reinstalled Fedora for a clean install of RT3
I have put and untared RT into /opt/rt3 and have fixed all dependancies for both mod_perl and
fastcgi.

You need to untar somewhere other that /opt/rt3 so that the install can
put the final install into /opt/rt3.

but now when i try

make install im getting

[root@bete rt3]# make install
mkdir -p //opt/rt3/etc
cp etc/RT_Config.pm //opt/rt3/etc/RT_Config.pm
cp: etc/RT_Config.pm' and//opt/rt3/etc/RT_Config.pm’ are the same file
make: *** [config-install] Error 1

whats this about??

I know by default rt puts stuff into /opt/rt3
but where should i have put the rt directory so make install wont create
problems with files already existing in /opt/rt3

any suggestions

Regards

Tomas Doyle


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Drew Barnes
Applications Analyst
Raymond Walters College
University of Cincinnati

Hi again

the ./configure

should i use

./configure --with-web-user=apache --with-web-group=apache --with-rt-user=apache --with-rt-group=apache
–prefix=/usr/local/rt3 --with-db-rt-pass=password

the --prefix is this needed as by default i thought it would put it into /opt/rt3

another thing should i erase /opt as well will this be recreated

ThanksFrom: Drew Barnes [mailto:barnesaw@ucrwcu.rwc.uc.edu]
Sent: 10 August 2005 15:16
To: Tomas Doyle XA (DL/LMI)
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] make install problem

Tomas Doyle XA (DL/LMI) wrote:

Where would you suggest? /root or something like that
because of what ive already done will there be any problems untaring a fresh rt all the dependancies should still be there?

I usually make an uploads folder under whichever user I happen to be
using - usually something original, like drew. I untar there, then su
so I can configure and install as root. As far as I can tell, you can
just wipe the /opt/rt3 folder and untar it in /root and you should be
fine. Just redo your configure, then make install.

Thanks

-----Original Message-----
From: Drew Barnes [mailto:barnesaw@ucrwcu.rwc.uc.edu]
Sent: 10 August 2005 15:09
To: Tomas Doyle XA (DL/LMI)
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] make install problem

Tomas Doyle XA (DL/LMI) wrote:

Hi RT Users,

I wiped the machine and reinstalled Fedora for a clean install of RT3
I have put and untared RT into /opt/rt3 and have fixed all dependancies for both mod_perl and
fastcgi.

You need to untar somewhere other that /opt/rt3 so that the install can
put the final install into /opt/rt3.

but now when i try

make install im getting

[root@bete rt3]# make install
mkdir -p //opt/rt3/etc
cp etc/RT_Config.pm //opt/rt3/etc/RT_Config.pm
cp: etc/RT_Config.pm' and//opt/rt3/etc/RT_Config.pm’ are the same file
make: *** [config-install] Error 1

whats this about??

I know by default rt puts stuff into /opt/rt3
but where should i have put the rt directory so make install wont create
problems with files already existing in /opt/rt3

any suggestions

Regards

Tomas Doyle


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Drew Barnes
Applications Analyst
Raymond Walters College
University of Cincinnati

Tomas Doyle XA (DL/LMI) wrote:

Hi again

the ./configure

should i use

./configure --with-web-user=apache --with-web-group=apache --with-rt-user=apache --with-rt-group=apache
–prefix=/usr/local/rt3 --with-db-rt-pass=password

You can use this if you want to. --prefix is only used if you don’t
want it installed in /opt/rt3. It seems like that is where you want it,
so maybe you should drop that. Also, you need to make sure that apache
is the user your web server runs under before you leave the directives.
I usually create an rt group to avoid havign to remember to specify
–with-rt-user and --with-rt-group.

I would leave /opt so that you don’t have to expect the installer to
create that directory too. Plus there may be other directories in /opt.

the --prefix is this needed as by default i thought it would put it into /opt/rt3

another thing should i erase /opt as well will this be recreated

Thanks

-----Original Message-----
From: Drew Barnes [mailto:barnesaw@ucrwcu.rwc.uc.edu]
Sent: 10 August 2005 15:16
To: Tomas Doyle XA (DL/LMI)
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] make install problem

Tomas Doyle XA (DL/LMI) wrote:

Where would you suggest? /root or something like that
because of what ive already done will there be any problems untaring a fresh rt all the dependancies should still be there?

I usually make an uploads folder under whichever user I happen to be
using - usually something original, like drew. I untar there, then su
so I can configure and install as root. As far as I can tell, you can
just wipe the /opt/rt3 folder and untar it in /root and you should be
fine. Just redo your configure, then make install.

Thanks

-----Original Message-----
From: Drew Barnes [mailto:barnesaw@ucrwcu.rwc.uc.edu]
Sent: 10 August 2005 15:09
To: Tomas Doyle XA (DL/LMI)
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] make install problem

Tomas Doyle XA (DL/LMI) wrote:

Hi RT Users,

I wiped the machine and reinstalled Fedora for a clean install of RT3
I have put and untared RT into /opt/rt3 and have fixed all dependancies for both mod_perl and
fastcgi.

You need to untar somewhere other that /opt/rt3 so that the install can
put the final install into /opt/rt3.

but now when i try

make install im getting

[root@bete rt3]# make install
mkdir -p //opt/rt3/etc
cp etc/RT_Config.pm //opt/rt3/etc/RT_Config.pm
cp: etc/RT_Config.pm' and//opt/rt3/etc/RT_Config.pm’ are the same file
make: *** [config-install] Error 1

whats this about??

I know by default rt puts stuff into /opt/rt3
but where should i have put the rt directory so make install wont create
problems with files already existing in /opt/rt3

any suggestions

Regards

Tomas Doyle


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Drew Barnes
Applications Analyst
Raymond Walters College
University of Cincinnati