Make initialize-database error

I’m trying to install RT3 on an RH8 box using mysql and fastcgi. I’ve
gotten through most of the process but I get the below error message when I
try ‘make initialize-database’. I’ve reset the password in RT_SiteConfig.pm
and I’ve tried to set the password for rt-user in mysql via Webmin. What am
I missing or doing wrong?

Clayton

[root@ksirh217 rt-3-0-1]# make initialize-database
/usr/bin/perl //opt/rt3/sbin/rt-setup-database --action init --dba root
–prompt-for-dba-password
In order to create a new database and grant RT access to that database,
Use of uninitialized value in concatenation (.) or string at
//opt/rt3/sbin/rt-setup-database line 197.
this script needs to connect to your mysql instance on as root.
Please specify that user’s database password below. If the user has no
database
password, just press return.

Password: Now creating a database for RT.
Creating mysql database rt3.
Now populating database schema.
Creating database schema.
schema sucessfully inserted
Now inserting database ACLs
Now inserting RT core system objects
[Fri May 9 00:04:03 2003] [crit]: Connect Failed Access denied for user:
‘rt_user@localhost’ (Using password: YES)
at //opt/rt3/sbin/rt-setup-database line 284
(/opt/rt3/lib/RT.pm:228)
make: *** [initialize-database] Error 255

I think you are supposed to ‘make dropdb’ and try it again.

If you already created the rt3 user and reset the password you may have RT and MySQL out of sync.

Greg

Gregory L. Hering

(256) 722-6420

4807 Bradford Dr

Benchmark Electronics, Inc.

Hunvtsville, Al 35805-----Original Message-----
From: Tavernier, Clayton [mailto:CTavernier@ksplastic.com]
Sent: Friday, May 09, 2003 4:44 PM
To: RT Users (E-mail)
Subject: [rt-users] make initialize-database error

I’m trying to install RT3 on an RH8 box using mysql and fastcgi. I’ve gotten through most of the process but I get the below error message when I try ‘make initialize-database’. I’ve reset the password in RT_SiteConfig.pm and I’ve tried to set the password for rt-user in mysql via Webmin. What am I missing or doing wrong?

Clayton

[root@ksirh217 rt-3-0-1]# make initialize-database
/usr/bin/perl //opt/rt3/sbin/rt-setup-database --action init --dba root --prompt-for-dba-password
In order to create a new database and grant RT access to that database,
Use of uninitialized value in concatenation (.) or string at //opt/rt3/sbin/rt-setup-database line 197.
this script needs to connect to your mysql instance on as root.
Please specify that user’s database password below. If the user has no database
password, just press return.

Password: Now creating a database for RT.
Creating mysql database rt3.
Now populating database schema.
Creating database schema.
schema sucessfully inserted
Now inserting database ACLs
Now inserting RT core system objects
[Fri May 9 00:04:03 2003] [crit]: Connect Failed Access denied for user: ‘rt_user@localhost’ (Using password: YES)
at //opt/rt3/sbin/rt-setup-database line 284
(/opt/rt3/lib/RT.pm:228)
make: *** [initialize-database] Error 255

The ‘make dropdb’ just removes the rt3 database so you can try again. I’ve
been dropping the database via Webmin anyway. But when I look, there is no
’rt_user’ to remove. I made the ‘rt’ group, should I be making an 'rt_user’
too?

Clayton Tavernier
IS Consultant
Kennerly-Spratling, Inc.
(510) 667-3795-----Original Message-----
From: Greg.Hering@bench.com [mailto:Greg.Hering@bench.com]
Sent: Tuesday, May 13, 2003 8:54 AM
To: CTavernier@ksplastic.com; rt-users@lists.fsck.com
Subject: RE: [rt-users] make initialize-database error

I think you are supposed to ‘make dropdb’ and try it again.

If you already created the rt3 user and reset the password you may have RT
and MySQL out of sync.

Greg

Gregory L. Hering

(256) 722-6420

4807 Bradford Dr

Benchmark Electronics, Inc.

Hunvtsville, Al 35805

-----Original Message-----
From: Tavernier, Clayton [mailto:CTavernier@ksplastic.com]
Sent: Friday, May 09, 2003 4:44 PM
To: RT Users (E-mail)
Subject: [rt-users] make initialize-database error

I’m trying to install RT3 on an RH8 box using mysql and fastcgi. I’ve
gotten through most of the process but I get the below error message when I
try ‘make initialize-database’. I’ve reset the password in RT_SiteConfig.pm
and I’ve tried to set the password for rt-user in mysql via Webmin. What am
I missing or doing wrong?

Clayton

[root@ksirh217 rt-3-0-1]# make initialize-database
/usr/bin/perl //opt/rt3/sbin/rt-setup-database --action init --dba root
–prompt-for-dba-password
In order to create a new database and grant RT access to that database,
Use of uninitialized value in concatenation (.) or string at
//opt/rt3/sbin/rt-setup-database line 197.
this script needs to connect to your mysql instance on as root.
Please specify that user’s database password below. If the user has no
database
password, just press return.

Password: Now creating a database for RT.
Creating mysql database rt3.
Now populating database schema.
Creating database schema.
schema sucessfully inserted
Now inserting database ACLs
Now inserting RT core system objects
[Fri May 9 00:04:03 2003] [crit]: Connect Failed Access denied for user:
‘rt_user@localhost’ (Using password: YES)
at //opt/rt3/sbin/rt-setup-database line 284
(/opt/rt3/lib/RT.pm:228)
make: *** [initialize-database] Error 255

I think you have something empty when it needs a value, probably in the RT_Config.pm or RT_SiteConfig.pm.

I tried letting ‘DatabaseHost’ and ‘DatabaseRTHost’ be empty (i.e. ‘’) like it suggested but that caused this error for me.

Try putting them back to ‘localhost’ and making the db again. Would somebody smarter than me comment on this please?

Look at this error message in your first post:

"Use of uninitialized value in concatenation (.) or string at //opt/rt3/sbin/rt-setup-database line 197. "

right after the statement

"In order to create a new database and grant RT access to that database, "

Make sure you separate things: You have Unix users and passwords and groups, RT users and passwords (in MySQL) and you have the user you run the web server as.

If you drop the ‘rt3’ database, that doesn’t change the users in the system table.

The ‘rt’ group is a Unix thing

rt_user@localhost is a MySQL connect string.

Try listing the user table

#mysql -u root (-p if you have a password)

show tables;

(should see ‘user’)

select Host, User, Password from user;

(list of users and their passwords)

mine looks like

+Host ------------ User — Password

localhost root

localhost.dom root

localhost

localhost.dom

localhost rt_user 1234abcd

Does the root account have a password? If so you have to use it to connect and make tables.

Is there a rt_user in the mysql.user table? The script should create it, not you.

I think you got logged in as root and created the tables, but without a ‘localhost’ entry in the config file you didn’t get a useable entry for ‘rt_user’ in the system user table.

Sincerely,

Greg

Gregory L. Hering

(256) 722-6420

4807 Bradford Dr

Benchmark Electronics, Inc.

Hunvtsville, Al 35805-----Original Message-----
From: Tavernier, Clayton [mailto:CTavernier@ksplastic.com]
Sent: Tuesday, May 13, 2003 5:21 PM
To: RT Users (E-mail)
Cc: Hering, Greg
Subject: RE: [rt-users] make initialize-database error

The ‘make dropdb’ just removes the rt3 database so you can try again. I’ve been dropping the database via Webmin anyway. But when I look, there is no ‘rt_user’ to remove. I made the ‘rt’ group, should I be making an ‘rt_user’ too?

Clayton Tavernier
IS Consultant
Kennerly-Spratling, Inc.
(510) 667-3795

-----Original Message-----
From: Greg.Hering@bench.com [mailto:Greg.Hering@bench.com]
Sent: Tuesday, May 13, 2003 8:54 AM
To: CTavernier@ksplastic.com; rt-users@lists.fsck.com
Subject: RE: [rt-users] make initialize-database error

I think you are supposed to ‘make dropdb’ and try it again.

If you already created the rt3 user and reset the password you may have RT and MySQL out of sync.

Greg

Gregory L. Hering

(256) 722-6420

4807 Bradford Dr

Benchmark Electronics, Inc.

Hunvtsville, Al 35805

-----Original Message-----
From: Tavernier, Clayton [mailto:CTavernier@ksplastic.com]
Sent: Friday, May 09, 2003 4:44 PM
To: RT Users (E-mail)
Subject: [rt-users] make initialize-database error

I’m trying to install RT3 on an RH8 box using mysql and fastcgi. I’ve gotten through most of the process but I get the below error message when I try ‘make initialize-database’. I’ve reset the password in RT_SiteConfig.pm and I’ve tried to set the password for rt-user in mysql via Webmin. What am I missing or doing wrong?

Clayton

[root@ksirh217 rt-3-0-1]# make initialize-database
/usr/bin/perl //opt/rt3/sbin/rt-setup-database --action init --dba root --prompt-for-dba-password
In order to create a new database and grant RT access to that database,
Use of uninitialized value in concatenation (.) or string at //opt/rt3/sbin/rt-setup-database line 197.
this script needs to connect to your mysql instance on as root.
Please specify that user’s database password below. If the user has no database
password, just press return.

Password: Now creating a database for RT.
Creating mysql database rt3.
Now populating database schema.
Creating database schema.
schema sucessfully inserted
Now inserting database ACLs
Now inserting RT core system objects
[Fri May 9 00:04:03 2003] [crit]: Connect Failed Access denied for user: ‘rt_user@localhost’ (Using password: YES)
at //opt/rt3/sbin/rt-setup-database line 284
(/opt/rt3/lib/RT.pm:228)
make: *** [initialize-database] Error 255

I’m having a problem initializing the data base. When I run “make
initialize-database”, I’m receiving the error can not locate Clone.pm.

make initialize-database /usr/bin/perl //opt/rt3/sbin/rt-setup-database

–action init --dba root --prompt-for-dba-password Can’t locate Clone.pm in
@INC

I’m running:

RHEL 5.0

RT version 3.6.4

Apache 2.2.3

MSSQL 5.0.22-2.1.0.1

Perl 4.5.8.8

Can anyone point me in the right direction?

Thanks

John Gaven

innodb is not disabled

In order to create or update your RT database, this script needs to
connect to your mysql instance on localhost as root
Please specify that user’s database password below. If the user has no
database
password, just press return.

Password:
Working with:
Type: mysql
Host: localhost
Name: rt3
User: user
DBA: user
Couldn’t finish ‘create’ step.

ERROR: RT requires that MySQL InnoDB table support be enabled.
Remove the ‘skip-innodb’ line from your my.cnf file, restart MySQL, and
try again.

make: *** [initialize-database] Error 255

my.cnf is as follows

Example MySQL config file for large systems.

This is for a large system with memory = 512M where the system runs mainly

MySQL.

You can copy this file to

/etc/my.cnf to set global options,

mysql-data-dir/my.cnf to set server-specific options (in this

installation this directory is /usr/local/mysql/data) or

~/.my.cnf to set user-specific options.

In this file, you can use all long options that a program supports.

If you want to know which options a program supports, run the program

with the “–help” option.

The following options will be passed to all MySQL clients

[client]
#password = your_password
port = 3306
socket = /tmp/mysql.sock

Here follows entries for some specific programs

The MySQL server

[mysqld]
port = 3306
socket = /tmp/mysql.sock
skip-locking
key_buffer = 256M
max_allowed_packet = 1M
table_cache = 256
sort_buffer_size = 1M
read_buffer_size = 1M
read_rnd_buffer_size = 4M
myisam_sort_buffer_size = 64M
thread_cache_size = 8
query_cache_size= 16M

Try number of CPU’s*2 for thread_concurrency

thread_concurrency = 8

Don’t listen on a TCP/IP port at all. This can be a security enhancement,

if all processes that need to connect to mysqld run on the same host.

All interaction with mysqld must be made via Unix sockets or named pipes.

Note that using this option without enabling named pipes on Windows

(via the “enable-named-pipe” option) will render mysqld useless!

#skip-networking

Disable Federated by default

skip-federated

Replication Master Server (default)

binary logging is required for replication

log-bin=mysql-bin

required unique id between 1 and 2^32 - 1

defaults to 1 if master-host is not set

but will not function as a master if omitted

server-id = 1

Replication Slave (comment out master section to use this)

To configure this host as a replication slave, you can choose between

two methods :

1) Use the CHANGE MASTER TO command (fully described in our manual) -

the syntax is:

CHANGE MASTER TO MASTER_HOST=, MASTER_PORT=,

MASTER_USER=, MASTER_PASSWORD= ;

where you replace , , by quoted strings and

by the master’s port number (3306 by default).

Example:

CHANGE MASTER TO MASTER_HOST=‘125.564.12.1’, MASTER_PORT=3306,

MASTER_USER=‘joe’, MASTER_PASSWORD=‘secret’;

OR

2) Set the variables below. However, in case you choose this method, then

start replication for the first time (even unsuccessfully, for example

if you mistyped the password in master-password and the slave fails to

connect), the slave will create a master.info file, and any later

change in this file to the variables’ values below will be ignored and

overridden by the content of the master.info file, unless you shutdown

the slave server, delete master.info and restart the slaver server.

For that reason, you may want to leave the lines below untouched

(commented) and instead use CHANGE MASTER TO (see above)

required unique id between 2 and 2^32 - 1

(and different from the master)

defaults to 2 if master-host is set

but will not function as a slave if omitted

#server-id = 2

The replication master for this slave - required

#master-host =

The username the slave will use for authentication when connecting

to the master - required

#master-user =

The password the slave will authenticate with when connecting to

the master - required

#master-password =

The port the master is listening on.

optional - defaults to 3306

#master-port =

binary logging - not required for slaves, but recommended

#log-bin=mysql-bin

Point the following paths to different dedicated disks

#tmpdir = /tmp/
#log-update = /path-to-dedicated-directory/hostname

Uncomment the following if you are using BDB tables

#bdb_cache_size = 64M
#bdb_max_lock = 100000

Uncomment the following if you are using InnoDB tables

innodb_data_home_dir = /usr/local/mysql/data/
innodb_data_file_path = ibdata1:10M:autoextend
innodb_log_group_home_dir = /usr/local/mysql/data/
innodb_log_arch_dir = /usr/local/mysql/data/

You can set …_buffer_pool_size up to 50 - 80 %

of RAM but beware of setting memory usage too high

innodb_buffer_pool_size = 256M
innodb_additional_mem_pool_size = 20M

Set …_log_file_size to 25 % of buffer pool size

innodb_log_file_size = 64M
innodb_log_buffer_size = 8M
innodb_flush_log_at_trx_commit = 1
innodb_lock_wait_timeout = 50

[mysqldump]
quick
max_allowed_packet = 16M

[mysql]
no-auto-rehash

Remove the next comment character if you are not familiar with SQL

#safe-updates

[isamchk]
key_buffer = 128M
sort_buffer_size = 128M
read_buffer = 2M
write_buffer = 2M

[myisamchk]
key_buffer = 128M
sort_buffer_size = 128M
read_buffer = 2M
write_buffer = 2M

[mysqlhotcopy]
interactive-timeout
dmz:/usr/local/src/rt-3.8.0 root#

Chaim Rieger

Was your MySQL maybe built without InnoDB?

P.S. Why aren’t the rt lists configured for reply-to list?
Cambridge Energy Alliance: Save money & the planet

Jerrad Pierce wrote:

Was your MySQL maybe built without InnoDB?


Cambridge Energy Alliance: Save money & the planet

i installed the binary,

if it was built without innodb support it wouldnt start up with the
current my.cnf
Chaim Rieger

i installed the binary,

if it was built without innodb support it wouldnt start up with the
current my.cnf

I wasn’t sure. Not all applications are as “finicky” as Apache, and are more
lax in their
acceptance of input i.e; not blowing up because you specify irrelevant
options

Cambridge Energy Alliance: Save money & the planet

Chaim Rieger wrote:

Jerrad Pierce wrote:

Was your MySQL maybe built without InnoDB?


Cambridge Energy Alliance: Save money & the planet

i installed the binary,

if it was built without innodb support it wouldnt start up with the
current my.cnf

If you do Show engines; you should see below if it’s enabled.
| InnoDB | YES | Supports transactions, row-level locking, and
foreign keys |

If you changed innodb_log_file_size you need to shutdown and delete the
old logs in /var/lib/mysql or innodb won’t start up because it tries to
append to a fixed log that’s smaller/larger then the one in the config.
I changed mine to 64mb also and you always have to get rid of the old
ib_logfile0-1files.

Curtis