Make fixdeps OpenSSL/err.h error

When I run make fixdeps it installs all the packages except LWP::Protocol:https

Looking in the log file, it is trying to get dependencies for IO::Socket::SSL and Net::SSLeay.

The error in the log file says that when it is trying to compile Net::SSLeay if can’t find ‘openssl/err.h’

I didn’t see that we needed the src for OpenSSL as a prerequisite. Is there a workaround to this other than installing the OpenSSL source and putting that in the path"

thanks in advance

Forgot to say, this is when trying to install RT 5.0

Do you have openssl installed on your machine? If you’re on RHEL or Centos I believe there is also this package perl-Net-SSLeay available

Yes it is installed. I’m on Ubuntu 16.04. I installed perl-Net-SSLeay with CPAN. I rebooted and tried make fixdeps again and I still get the same error message.

That error seems like you just need to re-install libssl-dev, maybe something went wrong the first time it was installed?

Yup! That was it. Thanks for the help.

1 Like