"make fixdeps" having trouble installing Apache::Session

Hi all,

I’m sure this is a bit off-topic (more related to Perl than RT), but I’m
trying to install RT just to give it a test drive, and I’m having
problems with “make fixdeps”. Everything got installed but
Apache::Session, and when I try to install it, I get:

t/99dbfile…Can’t locate DB_File.pm in @INC (@INC contains:
/home/chris/.cpan/build/Apache-Session-1.6/blib/lib
/home/chris/.cpan/build/Apache-Session-1.6/blib/arch
/usr/local/lib/perl5/5.8.6/i686-linux
/usr/local/lib/perl5/5.8.6/i686-linux /usr/local/lib/perl5/5.8.6
/usr/local/lib/perl5/site_perl/5.8.6/i686-linux
/usr/local/lib/perl5/site_perl/5.8.6/i686-linux
/usr/local/lib/perl5/site_perl/5.8.6
/usr/local/lib/perl5/site_perl/5.8.6/i686-linux
/usr/local/lib/perl5/site_perl/5.8.6 /usr/local/lib/perl5/site_perl .
/usr/local/lib/perl5/5.8.6/i686-linux /usr/local/lib/perl5/5.8.6
/usr/local/lib/perl5/site_perl/5.8.6/i686-linux
/usr/local/lib/perl5/site_perl/5.8.6 /usr/local/lib/perl5/site_perl .)
at
/home/chris/.cpan/build/Apache-Session-1.6/blib/lib/Apache/Session/Store/DB_File.pm
line 14.

When I try to manually install DB_File, I get:

cc -c -I/usr/local/BerkeleyDB/include -fno-strict-aliasing -pipe
-I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O2
-DVERSION=“1.811” -DXS_VERSION=“1.811” -fpic
"-I/usr/local/lib/perl5/5.8.6/i686-linux/CORE" -D_NOT_CORE
-DmDB_Prefix_t=size_t -DmDB_Hash_t=u_int32_t version.c
version.c:30:16: db.h: No such file or directory
make: *** [version.o] Error 1
/usr/bin/make – NOT OK
Running make test
Can’t test without successful make
Running make install
make had returned bad status, install seems impossible

Anybody seen anything like this?

-Chris

-DVERSION=“1.811” -DXS_VERSION=“1.811” -fpic
"-I/usr/local/lib/perl5/5.8.6/i686-linux/CORE" -D_NOT_CORE
-DmDB_Prefix_t=size_t -DmDB_Hash_t=u_int32_t version.c
version.c:30:16: db.h: No such file or directory
make: *** [version.o] Error 1
/usr/bin/make – NOT OK
Running make test
Can’t test without successful make
Running make install
make had returned bad status, install seems impossible

Anybody seen anything like this?

You’re missing a db-devel RPM?

Cheers,
– jra
Jay R. Ashworth jra@baylink.com
Designer Baylink RFC 2100
Ashworth & Associates The Things I Think '87 e24
St Petersburg FL USA http://baylink.pitas.com +1 727 647 1274

  If you can read this... thank a system administrator.  Or two.  --me