Mailgate Setuid Error

When mail comes into rt I am receiving a setuid error. I am using sendmail
for incoming mail on a RedHat 7.3 server. Sendmail is running as root and
not nobody. Apache is also not running as nobody, but apache. Has anyone
run into this problem?

Brad Pinkston
Centenary College of LA
Firewall/Network Administrator
IT Department
(318) 869-5003

Yes, I have. I’ve just installed RT2 on RH8 and experiencing the same
problem. I haven’t been able to get it to work, so I too would appreciate
any help with this problem.

I’ve tried to find suid under /usr without any luck - the perl install is
the one installed by the RH8 install.

Thx. Greg.

on 19/11/02 4:35 AM, at wrote:

I assume you’re both running perl as installed from the RH

To the best of my knowledge, suidperl is not installed in the RH
packages by default, but by a separate RPM available in the RH distro’s
as suidperl-someversion-somearch.rpm

To get suidperl to work with RT, you’ll need to make sure the rt2/bin/*
files are setgid with the rt-group listed in the Makefile when you
installed RT. If the install went well, this was already done.

John Stroud

Yup, that fixed it for me. Package perl-suidperl.rpm needed to be manually

Thx. Greg.