Mail-body encoding, can't use letters that's in iso-8859-1

Hi All

I have problems configuring rt (v-3.0.3) to use iso-8859-1 charset for
mail encoding. It’s quite strange, the “subject” of the mail is
iso-8859-1 encoded but not the body, it’s in utf8. Can anyone help or
give me a hint, aboute where to start, please.

Best regards

Rene Brask

Hi All

I have problems configuring rt (v-3.0.3) to use iso-8859-1 charset for
mail encoding. It’s quite strange, the “subject” of the mail is
iso-8859-1 encoded but not the body, it’s in utf8. Can anyone help or
give me a hint, aboute where to start, please.

Start by upgrading to RT 3.0.5.

Best regards

Rene Brask

Request Tracker — Best Practical Solutions – Trouble Ticketing. Free.

Jaime Diaz wrote:

  1. Open your RT_SiteConfig.pm
  2. Search for the RT UTF-8 Settings
  3. Check if you have this: Set($EmailOutputEncoding , ‘iso-8859-1’);

Probably you have ‘UTF-8’ now. Change it to iso-8859-1. Restart Apache and
it should work (at least, works here).

Done that and my setting is :
Set($EmailOutputEncoding , ‘iso-8859-1’);

Here is all my settings regarding the charset config. :

@LexiconLanguages = qw(*) unless (@LexiconLanguages);
@EmailInputEncodings = qw(iso-8859-1 us-ascii) unless
(@EmailInputEncodings);
Set($EmailOutputEncoding , ‘iso-8859-1’);

in my vhost.conf (apache conf) i have : “AddDefaultCharset ISO-8869-1”

And besite that, I have used a fresh installation of rt (v-3.0.5).

Here is an ex. of a mail header. It’s from the view of history in the
rt-webinterface and the ticket i made i the rt system.

X-Mailer: MIME-tools 5.411 (Entity 5.404)
Content-Disposition: inline
Content-Type: text/plain; charset="utf-8"
Subject: æøå
MIME-Version: 1.0
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: iso-8859-1
Content-Length: 12

æøå

And what I’m wondering about is why the “charset=utf8”

Best regrads

Rene Brask

I now have increased the problem to the rt mailOutputencoding. Because
when I send a mail to the rt system from a outside address, the encoding
is fine :wink: But when I later modify the text in the given ticket in rt,
the encoding gets fucked (encoded in utf8). Same problem arise when I
create a new ticket in the rt system, the text is encoded in utf8. So
the BIG question is, how do I change this ?

Best regards

Rene Brask

Hello.
As I’ve understood RT3 store everything in UTF8 encoding in DB, but
could generate mails in other Encoding.
Thus you have to change default encoding in httpd.conf to
AddDefaultCharset UTF-8…
Hopes this helps…

Realhost I/S - Rene Brask S�rensen wrote:

Ruslan U. Zakirov wrote:

Hello.
As I’ve understood RT3 store everything in UTF8 encoding in DB, but
could generate mails in other Encoding.
Thus you have to change default encoding in httpd.conf to
AddDefaultCharset UTF-8…
Hopes this helps…

Ahh ok, did’nt know that. But then rt have to translate everything all
the time.

What I don’t understand is why you wan’t me to change default charset i
apache to utf8. I would like rt to display letters in iso-8859-1
charset. Maybee I’m misunderstanding something here, but it would seem
intuitive to set “AddDefaultCharset ISO-8859-1”.

Best regards

Rene brask

Realhost I/S - Rene Brask S�rensen wrote:

Ruslan U. Zakirov wrote:

Hello.
As I’ve understood RT3 store everything in UTF8 encoding in DB, but
could generate mails in other Encoding.
Thus you have to change default encoding in httpd.conf to
AddDefaultCharset UTF-8…
Hopes this helps…

Ahh ok, did’nt know that. But then rt have to translate everything all
the time.

Nop. Only when RT get email and send email, but this feature allow RT
handle several encodings at the same time.

What I don’t understand is why you wan’t me to change default charset
i apache to utf8. I would like rt to display letters in iso-8859-1
charset. Maybee I’m misunderstanding something here, but it would seem
intuitive to set “AddDefaultCharset ISO-8859-1”.

Apache do not do any encoding conversions with this option, but set
specified encoding in response headers. You must set this option to
UTF-8 because of RT. RT output content to browser in UTF-8 and don’t do
any encoding conversions. What is a problem with it? Your browser
doesn’t support UTF?

Stefan Seiz wrote:>On 19.09.2003 17:44 Uhr, Realhost I/S - Rene Brask S�rensen rene@realhost.dk wrote:

Ahh ok, did’nt know that. But then rt have to translate everything all
the time.

What I don’t understand is why you wan’t me to change default charset i
apache to utf8. I would like rt to display letters in iso-8859-1
charset. Maybee I’m misunderstanding something here, but it would seem
intuitive to set “AddDefaultCharset ISO-8859-1”.

Install 3.0.5. and you’re all set for email and don’t need to change
anything. But even with 3.0.5, make sure to configure apache for UTF8
anyway. Like so:

<VirtualHost 1.2.3.4:80>
ServerName rt.example.com
ServerAdmin
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

Thanks but I’m sorry I can’t see what that should help, generelly people
in denmark are using iso-885-1 in eg. their email-clients. That’s also
why I want rt to encode in-/out-put into iso-8859-1. It should’nt bee
that difficult. Is’nt there anyone on the list that’s using iso-8859-1
because eg. they are supporting danish ?

/Rene Brask

Thanks but I’m sorry I can’t see what that should help, generelly people
in denmark are using iso-885-1 in eg. their email-clients. That’s also
why I want rt to encode in-/out-put into iso-8859-1. It should’nt bee
that difficult. Is’nt there anyone on the list that’s using iso-8859-1
because eg. they are supporting danish ?

Stop asking and just do what we told you :wink:
UTF8 (ever heared of Unicode?) is absolutely capable of supporting danis,
chinese and even retoromanian… And that is just as probably anyone has set
it up.

Give it a try! Why not?

We are supporting German which has similar funny characters as danish and it
works for us.

http://www.StefanSeiz.com
Spamto: bin@imd.net

Stefan Seiz wrote:>On 19.9.2003 20:41 Uhr, Realhost I/S - Rene Brask S�rensen rene@realhost.dk wrote:

Thanks but I’m sorry I can’t see what that should help, generelly people
in denmark are using iso-885-1 in eg. their email-clients. That’s also
why I want rt to encode in-/out-put into iso-8859-1. It should’nt bee
that difficult. Is’nt there anyone on the list that’s using iso-8859-1
because eg. they are supporting danish ?

Stop asking and just do what we told you :wink:
UTF8 (ever heared of Unicode?) is absolutely capable of supporting danis,
chinese and even retoromanian… And that is just as probably anyone has set
it up.

Give it a try! Why not?

We are supporting German which has similar funny characters as danish and it
works for us.

Ok let me put is another way. Is it possible to use iso-8859-1 charset
encoding with RT ? because that’s a requirement for my firm.

From what I have tryed, it seems that RT can handle iso-8859-1 when
it’s a external email thats encoden in it. But after editing the ticket
in RT the encoding gets fucked.

Really hope that someone can help, because Me and my firm would really
like to use RT.

Best regards

Rene Brask

Hi All

I have problems configuring rt (v-3.0.3) to use iso-8859-1 charset for
mail encoding. It’s quite strange, the “subject” of the mail is
iso-8859-1 encoded but not the body, it’s in utf8. Can anyone help or
give me a hint, aboute where to start, please.

Best regards

Rene Brask

Make sure you use perl 5.8, it will not work with perl 5.6

Cheers,
rhb