Mail-body encoding, can't use letters that's in is o-8859-1

  1. Open your RT_SiteConfig.pm
  2. Search for the RT UTF-8 Settings
  3. Check if you have this: Set($EmailOutputEncoding , ‘iso-8859-1’);

Probably you have ‘UTF-8’ now. Change it to iso-8859-1. Restart Apache and
it should work (at least, works here).-----Original Message-----
From: Rene Brask Sørensen [mailto:rene@realhost.dk]
Sent: Jueves, 18 de Septiembre de 2003 11:48 a.m.
To: rt-users@lists.fsck.com
Subject: [rt-users] mail-body encoding, can’t use letters that’s in
iso-8859-1

Hi All
I have problems configuring rt (v-3.0.3) to use iso-8859-1 charset for mail
encoding. It’s quite strange, the “subject” of the mail is iso-8859-1
encoded but not the body, it’s in utf8. Can anyone help or give me a hint,
aboute where to start, please.

Best regards
Rene Brask

Jaime Diaz wrote:

  1. Open your RT_SiteConfig.pm
  2. Search for the RT UTF-8 Settings
  3. Check if you have this: Set($EmailOutputEncoding , ‘iso-8859-1’);

Probably you have ‘UTF-8’ now. Change it to iso-8859-1. Restart Apache and
it should work (at least, works here).

Done that and my setting is :
Set($EmailOutputEncoding , ‘iso-8859-1’);

Here is all my settings regarding the charset config. :

@LexiconLanguages = qw(*) unless (@LexiconLanguages);
@EmailInputEncodings = qw(iso-8859-1 us-ascii) unless
(@EmailInputEncodings);
Set($EmailOutputEncoding , ‘iso-8859-1’);

in my vhost.conf (apache conf) i have : “AddDefaultCharset ISO-8869-1”

And besite that, I have used a fresh installation of rt (v-3.0.5).

Here is an ex. of a mail header. It’s from the view of history in the
rt-webinterface and the ticket i made i the rt system.

X-Mailer: MIME-tools 5.411 (Entity 5.404)
Content-Disposition: inline
Content-Type: text/plain; charset=“utf-8”
MIME-Version: 1.0
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: iso-8859-1
Content-Length: 12

æøå

And what I’m wondering about is why the “charset=utf8”

Best regrads

Rene Brask

AddDefaultCharset ISO-8869-1 , is this a typo?
What MTA are you using? maybe it is who is changing the encoding.From: Realhost I/S - Rene Brask Sørensen [mailto:rene@realhost.dk]
Sent: Viernes, 19 de Septiembre de 2003 11:38 a.m.
To: Jaime Diaz; rt-users@lists.fsck.com
Subject: Re: [rt-users] mail-body encoding, can’t use letters that’s in
is o-8859-1

Jaime Diaz wrote:

  1. Open your RT_SiteConfig.pm
  2. Search for the RT UTF-8 Settings
  3. Check if you have this: Set($EmailOutputEncoding , ‘iso-8859-1’);

Probably you have ‘UTF-8’ now. Change it to iso-8859-1. Restart Apache and
it should work (at least, works here).

Done that and my setting is :
Set($EmailOutputEncoding , ‘iso-8859-1’);

Here is all my settings regarding the charset config. :

@LexiconLanguages = qw(*) unless (@LexiconLanguages);
@EmailInputEncodings = qw(iso-8859-1 us-ascii) unless
(@EmailInputEncodings);
Set($EmailOutputEncoding , ‘iso-8859-1’);

in my vhost.conf (apache conf) i have : “AddDefaultCharset ISO-8869-1”

And besite that, I have used a fresh installation of rt (v-3.0.5).

Here is an ex. of a mail header. It’s from the view of history in the
rt-webinterface and the ticket i made i the rt system.

X-Mailer: MIME-tools 5.411 (Entity 5.404)
Content-Disposition: inline
Content-Type: text/plain; charset=“utf-8”
Subject: æøå
MIME-Version: 1.0
Content-Transfer-Encoding: binary
X-RT-Original-Encoding: iso-8859-1
Content-Length: 12

æøå

And what I’m wondering about is why the “charset=utf8”

Best regrads

Rene Brask

Jaime Diaz wrote:

AddDefaultCharset ISO-8869-1 , is this a typo?

ups sorry, it’s just a typo :wink:

Jaime Diaz wrote:

AddDefaultCharset ISO-8869-1 , is this a typo?
What MTA are you using? maybe it is who is changing the encoding.

I’m using Postfix and that’s not the case, because then all my other
mail would have the same problem and it don’t. Sorry, I to wish that
just had been the problem.

/Rene