Logout -> /NoAuth/%3C%$URL%%3E

Does anyone know the answer to this one?

I can log into my new RT install as root, but when I click “logout” I
get a quick flash of text and then this error:

 Bad Request

 Your browser sent a request that this
 server could not understand.
 Apache/2.0.52 (Red Hat) Server at
 rt.example.com Port 443

The URL at that point is:
https://rt.example.com/NoAuth/<%$URL%>

Someone else mentioned this once, but no answer appeared on the mailing
list:
http://lists.fsck.com/pipermail/rt-users/2003-August/015983.html

Here are some relevant settings:

httpd.conf includes:________
FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 120

<VirtualHost :80>
RewriteEngine on
RewriteCond %{SERVER_PORT} ^80$
RewriteRule ^/(.
) https://%{SERVER_NAME}/$1 [R,L]

ssl.conf includes:_________

DocumentRoot "/opt/rt3/share/html"
ServerName rt.example.com:443
ErrorLog /var/log/httpd/rt.example.com_error
CustomLog /var/log/httpd/rt.example.com-access_log common
LogLevel warn
SSLEngine on
SSLCipherSuite ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv2:+EXP
SSLCertificateFile /etc/httpd/conf/ssl.crt/rt.example.com.crt
SSLCertificateKeyFile /etc/httpd/conf/ssl.key/rt.example.com.key
<Files ~ “.(cgi|shtml|phtml|php3?)$”>
SSLOptions +StdEnvVars

<Directory “/var/www/cgi-bin”>
SSLOptions +StdEnvVars

<Directory “/opt/rt3/share/html”>
SSLOptions +StdEnvVars
Options FollowSymLinks ExecCGI
AllowOverride None

SetEnvIf User-Agent “.MSIE.
nokeepalive ssl-unclean-shutdown
downgrade-1.0 force-response-1.0
CustomLog logs/ssl_request_log
“%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x “%r” %b”

Alias /NoAuth/images/ /opt/rt3/share/html/NoAuth/images/
Alias /NoAuth/webrt.css /opt/rt3/share/html/NoAuth/webrt.css

AddHandler fastcgi-script fcgi
ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/

AddDefaultCharset UTF-8

THANKS!
phil

what do you have in RT_Siteconfig.pm for rt_urlOn Apr 15, 2005, at 12:34 PM, Phil Lawrence wrote:

Does anyone know the answer to this one?

I can log into my new RT install as root, but when I click "logout"
I get a quick flash of text and then this error:

Bad Request

Your browser sent a request that this
server could not understand.
Apache/2.0.52 (Red Hat) Server at
rt.example.com Port 443

The URL at that point is:
https://rt.example.com/NoAuth/<%$URL%>

Someone else mentioned this once, but no answer appeared on the
mailing list:
http://lists.fsck.com/pipermail/rt-users/2003-August/015983.html

Here are some relevant settings:

httpd.conf includes:________
FastCgiServer /opt/rt3/bin/mason_handler.fcgi -idle-timeout 120

<VirtualHost :80>
RewriteEngine on
RewriteCond %{SERVER_PORT} ^80$
RewriteRule ^/(.
) https://%{SERVER_NAME}/$1 [R,L]

ssl.conf includes:_________

DocumentRoot "/opt/rt3/share/html"
ServerName rt.example.com:443
ErrorLog /var/log/httpd/rt.example.com_error
CustomLog /var/log/httpd/rt.example.com-access_log common
LogLevel warn
SSLEngine on
SSLCipherSuite ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv2:
+EXP
SSLCertificateFile /etc/httpd/conf/ssl.crt/rt.example.com.crt
SSLCertificateKeyFile /etc/httpd/conf/ssl.key/rt.example.com.key
<Files ~ “.(cgi|shtml|phtml|php3?)$”>
SSLOptions +StdEnvVars

<Directory “/var/www/cgi-bin”>
SSLOptions +StdEnvVars

<Directory “/opt/rt3/share/html”>
SSLOptions +StdEnvVars
Options FollowSymLinks ExecCGI
AllowOverride None

SetEnvIf User-Agent “.MSIE.
nokeepalive ssl-unclean-shutdown
downgrade-1.0 force-response-1.0
CustomLog logs/ssl_request_log
“%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x “%r” %b”

Alias /NoAuth/images/ /opt/rt3/share/html/NoAuth/images/
Alias /NoAuth/webrt.css /opt/rt3/share/html/NoAuth/webrt.css

AddHandler fastcgi-script fcgi
ScriptAlias / /opt/rt3/bin/mason_handler.fcgi/

AddDefaultCharset UTF-8

THANKS!
phil


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

RT Administrator and Developer training is coming to your town
soon! (Boston, San Francisco, Austin, Sydney) Contact
training@bestpractical.com for details.

Be sure to check out the RT Wiki at http://wiki.bestpractical.com

Steve Rieger
steve_rieger@tbwachiat.com
(212) 804-1131 (Work)
(646) 335-8915 (Cell)
chozrim (aim)

Steve Rieger wrote:

what do you have in RT_Siteconfig.pm for rt_url

Do you mean one of these?

Set($WebPath , “”);
Set($WebBaseURL , “https://rt.example.com:443”);
Set($WebURL , $WebBaseURL . $WebPath . “/”);

thanks,
phil