Localhost in Search/Results.html

Hi…

I finally managed to get RT and Oracle working :slight_smile:
Everythinig is working fine with the defined host except for the link to the “10 neuesten Anfragen ohne Besitzer” which is the first window containing the latest requests without owner. Here RT always wants to use “localhost” instead of the defined host.

http://localhost/Search/Results.html?Format='<a%20href%3D"%2FTicket%2FDisplay.html%3Fid%3D__id__">__id__<%2Fa>%2FTITLE%3A%23'%2C%20'<a%20href%3D"%2FTicket%2FDisplay.html%3Fid%3D__id__">__Subject__<%2Fa>%2FTITLE%3ASubject'%2C%20QueueName%2C%20ExtendedStatus%2C%20CreatedRelative%2C%20'<A%20HREF%3D"%2FTicket%2FDisplay.html%3FAction%3DTake%26id%3D__id__">Übernehmen<%2Fa>%2FTITLE%3A%26nbsp%3B'%20&Order=DESC&OrderBy=Created&Query=%20Owner%20%3D%20'Nobody'%20AND%20(%20Status%20%3D%20'new'%20OR%20Status%20%3D%20'open')

If I replace “localhost” with my RT server name everything works fine. I just don’t know where the “localhost” string comes from.

Any idea where this can be fixed?

Mit freundlichen Grüßen

Michael Burghart
CAT Service Center
AUDI AG, I/ET-83 extern
Tel: +49 841 89 - 39819
http://catsc-web.in.audi.vwg
mailto:extern.michael.burghart@audi.de

EPOS CAT GmbH
Tel: +49 841 88197070
Fax: +49 841 88197080
http://www.epos-cat.de/
mailto:michael.burghart@epos-cat.de

Sitz/Domicile: Ingolstadt

Registergericht/Court of Registry: Amtsgericht Ingolstadt
HRB Nr./Commercial Register No.: 2802
Geschäftsführer/Managing Director: Günter See

Wichtiger Hinweis: Die vorgenannten Angaben werden jeder E-Mail automatisch hinzugefügt und lassen keine Rückschlüsse auf den Rechtscharakter der E-Mail zu.

Important Notice: The above information is automatically added to this e-mail. This addition does not constitute a representation that the content of this e-mail is legally relevant and/or is intended to be legally binding upon EPOS CAT GmbH.

Hi Michael,

If you the WebBaseURL in your RT_SiteConfig.pm that resolves the issue.

Set( $WebBaseURL, ‘http://yourdomain.com’);

I guess localhost is the default setting there…change it to your RT’s
url and it works fine.

Regards,

Gaurav

Disclaimer:
This Email message along with any attachments is intended only for the addressee and may contain confidential and/or privileged information. If you have received this message in error, please notify sender immediately and delete this message from your system. If the reader is not the intended ecipient then any dissemination, distribution or copy of this communication is strictly prohibited. Reasonable precautions have been taken to ensure that this message is virus-free. However, Subisu Cablenet Pvt. Ltd. does not accept responsibility for any loss or damage arising from the use of this message or attachments.

Burghart, Michael (I/ET-83, extern) wrote:

signature.asc (252 Bytes)