Latin Characters

Hi All

I installed RT as a solution to remove Remedy’s AR in my company, but i’m
having some troubles displaying spanish accented characters like á é í ó ú
or ñ, so, if anybody has any ideas, will be very appreciated

My install is

Solaris 10 SPARC
Perl 5.10
RT 3.8.1
Oracle 10.2.4

Best Regards,

Eliezer E Chávez
+58-416-6125676
eliezer.chavez@gmail.com

Hi All

I installed RT as a solution to remove Remedy’s AR in my company, but i’m
having some troubles displaying spanish accented characters like � � � � �
or �, so, if anybody has any ideas, will be very appreciated

My install is

Solaris 10 SPARC
Perl 5.10
RT 3.8.1
Oracle 10.2.4

Did you set “spanish” in your RT preferences to have the UI in spanish?
If so is the problem only with menu/buttons or with tickets
subject/contents?

Do you have something like “AddDefaultCharset UTF-8” in your apache
configuration?

What is your database encoding?
(select * from nls_database_parameters where
parameter=‘NLS_CHARACTERSET’:wink:

The issue only happens with content that its stored in the database

SQL> select * from nls_database_parameters where
parameter=‘NLS_CHARACTERSET’;

PARAMETER VALUE


NLS_CHARACTERSET WE8ISO8859P1

Best Regards!

Hi All

I installed RT as a solution to remove Remedy’s AR in my company, but i’m
having some troubles displaying spanish accented characters like á é í ó
ú
or ñ, so, if anybody has any ideas, will be very appreciated

My install is

Solaris 10 SPARC
Perl 5.10
RT 3.8.1
Oracle 10.2.4

Did you set “spanish” in your RT preferences to have the UI in spanish?
If so is the problem only with menu/buttons or with tickets
subject/contents?

Do you have something like “AddDefaultCharset UTF-8” in your apache
configuration?

What is your database encoding?
(select * from nls_database_parameters where
parameter=‘NLS_CHARACTERSET’:wink:


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Eliezer E Chávez
+58-416-6125676
eliezer.chavez@gmail.com

Hello Eliezer,

I installed RT as a solution to remove Remedy’s AR in my company, but i’m
having some troubles displaying spanish accented characters like � � � � �
or �, so, if anybody has any ideas, will be very appreciated

Do you have something like “AddDefaultCharset UTF-8” in your apache
configuration?

I’m running RT also with Oracle as a backend and I modified my
/etc/init.d/apache2. The first couple of lines read as follows:
#!/bin/sh -e

apache2 This init.d script is used to start apache2.

It basically just calls apache2ctl.

ENV=“env -i LANG=C PATH=/usr/local/bin:/usr/bin:/bin
NLS_LANG=AMERICAN_AMERICA.UTF8”

Notice the NLS_LANG at the end. That solved my problems with accented
characters in the database.
Specifying it in httpd.conf might work. I never have tried it. If you
don’t specify NLS_LANG in you environment the OCI (DBD::Oracle) will
fallback to the OS default which for most of us will be LANG=C which
doesn’t know about accented characters. Correct me if I’m wrong.

Regards,

Joop

The issue only happens with content that its stored in the database

SQL> select * from nls_database_parameters where
parameter=‘NLS_CHARACTERSET’;

PARAMETER VALUE


NLS_CHARACTERSET WE8ISO8859P1

Should be enough for most spanish chars, but RT is supposed to be full
UTF-8, so I suggest you to dump/restore the database and do this before
import:

export NLS_LANG="AMERICAN_AMERICA.AL32UTF8"
export NLS_NCHAR=“AL32UTF8”

Also, really check that you have a default charset UTF-8 in your apache
config for your vhost, in doubt add:

AddDefaultCharset UTF-8

Hello Eliezer,

I installed RT as a solution to remove Remedy’s AR in my company, but i’m
having some troubles displaying spanish accented characters like � � � � �
or �, so, if anybody has any ideas, will be very appreciated

Do you have something like “AddDefaultCharset UTF-8” in your apache
configuration?

I’m running RT also with Oracle as a backend and I modified my
/etc/init.d/apache2. The first couple of lines read as follows:

#!/bin/sh -e

apache2 This init.d script is used to start apache2.

It basically just calls apache2ctl.

ENV=“env -i LANG=C PATH=/usr/local/bin:/usr/bin:/bin
NLS_LANG=AMERICAN_AMERICA.UTF8”

Shouldn’t be needed as this is explicitely defined in RT
(lib/RT/Handle.pm):

sub Connect {
my $self = shift;

my $db_type = RT->Config->Get('DatabaseType');
if ( $db_type eq 'Oracle' ) {
    $ENV{'NLS_LANG'} = "AMERICAN_AMERICA.AL32UTF8";
    $ENV{'NLS_NCHAR'} = "AL32UTF8";
}

The AddDefaultCharset in apache config is not for database connection, but for
http headers.

Thanks Joop

Worked like a champ!

Regards!

Hello Eliezer,

I installed RT as a solution to remove Remedy’s AR in my company, but
i’m

having some troubles displaying spanish accented characters like á é í ó
ú

or ñ, so, if anybody has any ideas, will be very appreciated

Do you have something like “AddDefaultCharset UTF-8” in your apache
configuration?

I’m running RT also with Oracle as a backend and I modified my
/etc/init.d/apache2. The first couple of lines read as follows:

#!/bin/sh -e

apache2 This init.d script is used to start apache2.

It basically just calls apache2ctl.

ENV=“env -i LANG=C PATH=/usr/local/bin:/usr/bin:/bin
NLS_LANG=AMERICAN_AMERICA.UTF8”

Notice the NLS_LANG at the end. That solved my problems with accented
characters in the database.
Specifying it in httpd.conf might work. I never have tried it. If you
don’t specify NLS_LANG in you environment the OCI (DBD::Oracle) will
fallback to the OS default which for most of us will be LANG=C which
doesn’t know about accented characters. Correct me if I’m wrong.

Regards,

Joop


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Eliezer E Chávez
+58-416-6125676
eliezer.chavez@gmail.com

Uh

But i defined the variables in the env
and used

PassEnv ORACLE_HOME
PassEnv LD_LIBRARY_PATH
PassEnv NLS_LANG
PassEnv TNS_ADMIN

in httpd.conf

Hello Eliezer,

I installed RT as a solution to remove Remedy’s AR in my company, but
i’m

having some troubles displaying spanish accented characters like á é í
ó ú

or ñ, so, if anybody has any ideas, will be very appreciated

Do you have something like “AddDefaultCharset UTF-8” in your apache
configuration?

I’m running RT also with Oracle as a backend and I modified my
/etc/init.d/apache2. The first couple of lines read as follows:

#!/bin/sh -e

apache2 This init.d script is used to start apache2.

It basically just calls apache2ctl.

ENV=“env -i LANG=C PATH=/usr/local/bin:/usr/bin:/bin
NLS_LANG=AMERICAN_AMERICA.UTF8”

Shouldn’t be needed as this is explicitely defined in RT
(lib/RT/Handle.pm):

sub Connect {
my $self = shift;

my $db_type = RT->Config->Get(‘DatabaseType’);
if ( $db_type eq ‘Oracle’ ) {
$ENV{‘NLS_LANG’} = “AMERICAN_AMERICA.AL32UTF8”;
$ENV{‘NLS_NCHAR’} = “AL32UTF8”;
}

The AddDefaultCharset in apache config is not for database connection, but
for
http headers.


http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: sales@bestpractical.com

Discover RT’s hidden secrets with RT Essentials from O’Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

Eliezer E Chávez
+58-416-6125676
eliezer.chavez@gmail.com